Solved

Youtube not playing on mobile data

  • 5 March 2022
  • 17 replies
  • 3723 views

Badge

Youtube does not play on mobile data; however, works perfectly fine on wi-fi. I already tried all options related to software on my phone (iphone XR) and nothing seems to help. I also reset all settings on phone. There is no web guard or family mode in our plan. I also already tried the steps in the troubleshooting for “internet and data issues” with no success. 

icon

Best answer by DanDanNVA 25 October 2022, 15:26

View original

17 replies

Userlevel 7
Badge +15

I had no issues watching YouTube on my OnePlus device today while on the road for a few hours in the morning and the afternoon.  

Badge

I am also having the same issue. Using youtube from my safari browser (iPhone 13 pro) it is working fine when connected to my wifi but not playing the same video when using mobile data.

I came here for this same issue, exactly as OP described, and have taken all steps short of pointlessly trying to call customer support I would greatly appreciate a solution!

Userlevel 7
Badge +14

from what i can tell there is currently a issue mainly affecting the east coast of the U.S with this and a few other issues hitting Android phones and the play store..if the two issues are in fact linked its a known issue they are currently working on.

Having the same issue, tried reseting the phone (I have iphone 12 pro max) clear the cache,network reset .Every possible way but no use even t-mobile guys are not aware the problem .Even tried changing mobile (samsung note 20 ultra) same problem .No one have solution for this problem yet 🙄. I m in georgia 

Even the T-mobile guys replace my Sim card but still same issue 

I have a Google pixel, same issue. Can browse the web with no issues but when I try to access Netflix or YouTube it can never connect. However the moment I get home and it switches to my home wifi, I have no issues. It's frustrating!!

 

Same issue

When set Wi-Fi YouTube works. YouTube kids as well.

when set cellular data YouTube error loading

all other apps works using cellular data

this need to be fixed 

LTE not working 5G works

 

Badge

I am having this issue with the Amazon Music app. It doesn’t fnish a song when using cellular. Works fine on wifi. It may be other apps too but I’m still new to T-Mobile. I have a new iPhone 13, activated by T-Mobile.

Same issue for me for around 2 months with a OnePlus 7t. Works on Brave Browser but the app does not load until I'm on Wi-Fi. T-Mo, pls.

The same issue which blow my mind. Tried all the steps to possible fix but problem still present. Admins, notify me when will have the solution, please.

Userlevel 1

Same issue for my son on iPhone 11. Apple visits 3x. No issues with hardware nor software. They swapped out phone for brand new. 2x visits to TMobile, ended up with new SIM. Issue totally unchanged.

Affecting Netflix (site and app), Snapchat, YouTube (site and app), etc.   HELP!!!

Contacted YouTube TV support as neither YouTube or YouTube TV apps work on LTE or 4G cellular data (on either Sprint or T-Mobile networks) using my iPad Mini 5th Generation (works fine on wifi using T-Mobile Home Internet). They suggested I go to a T-Mobile store, by which the representative replaced my sim card. Unfortunately I still cannot view YouTube or YouTube TV on cellular (browser or app). So it would be good to receive assistance. 

Userlevel 1

Our issue is finally resolved. Here is what worked for us: I called T-Mobile service on a day I knew I had hours to waste. You’ll likely need to get past the first level customer service technician because they don’t have the capability to access what needs to be done. Once I was in touch with the advanced tech service they were able to find a block on third-party data services that had been implemented on their end. It took the technician to second to remove the block and the issue completely resolved. They traced the block back to an error on their end. I was so flipping upset. I have spent countless hours trying to fix the issue, being told her all sorts of conflicting theories. I am sorry for the long story but I am still bitter. To all of you, I recommend getting on the line with an advanced T-Mobile service technician to check for third-party data blocks on the account

Userlevel 7
Badge +14

you can usually attempt to bypass the tier 1 call in support by using either Facebook or Twitter..those land you with tier 2 support starting off.

For short answer go to bottom :)

I know this thread is old but a comment regarding tier 2 figuring out some third party blocking on their end sparked my memory. So my daughter has been complaining for months Youtube doesn’t work when she isn’t on WiFi.. no amount of clearing data/cache reinstalls and the problem continued even after she got a newer phone recently (how I came across this thread). When I saw the post above it sparked my memory that I had enabled parental controls/web filtering .. and sure enough I go into my account, go to her line and “Web Guard” was set to “High” which included the description below. I set it to “Medium” and waited about 30min and went to go check it again and it all started working… mystery finally solved.

 

Short answer:

Log into your T-Mobile account and look for “Family Controls” and then “Web Guard” and adjust filtering from High to Medium.

 

Web Guard High includes this description:

  • Streaming Video - Real-time streaming video including Internet television, web casts, and video sharing.

To be honest, it's strange. I've never had this kind of problem with YouTube. But you can look at https://wave.video/blog/video-thumbnails/ there are useful tips in working with YouTube. It may help you.

Reply