Solved

Android phone only does wifi calling

  • 25 May 2023
  • 4 replies
  • 449 views

Badge

I traveled overseas, and changed some settings on my phone. Now, I’m back in the US, and it won’t connect to the cell network, only to wifi.

“Mobile network is not available” is the message I get.

In the Settings app, under “Network & Internet”, in the “Calls & SMS” section, it says “T-Mobile (temporarily unavailable)”

What settings should I check for (that I obviously screwed up)?

Thanks.

icon

Best answer by syaoran 25 May 2023, 22:07

View original

4 replies

Userlevel 7
Badge +15

Do you have Automatically Connect to Network enabled?  Is your device in Airplane Mode?

Badge

Unfortunately, it’s nothing so trivial. I’ve tried turning airplane mode off/on. I’ve tried rebooting.

I have “Mobile data” and “Roaming” turned on.

“Automatically select network” is on.

“Choose network” is greyed out, with T-Mobile wi-fi calling as the option (but also greyed out).

Userlevel 7
Badge +15

Try removing your SIM, cleaning the gold contacts with some Isopropyl, and putting it back in after drying it with a papertowel.

Badge

That was it.  I would never have guessed that would be the issue.

Thanks!

Reply