Solved

ipads not connecting to home internet


Badge

I have a 2nd gen and a bit later (2012?) Ipad that have been working fine when connects via WiFi to at&t.

However, 2 weeks ago I moved and set up T-Mobile home internet. All my other devices have connected with no issue. A 2013 MacBook Air connected with no issue. The iPads are unable to connect, despite resetting network settings, unplugging modem, etc. The passwords are for sure correct and the devices are able to connect to public networks so not a wholesale WiFi issue on their end. I appreciate any suggestions.

 

 

icon

Best answer by Schroeder5 24 July 2022, 20:14

View original

12 replies

I’ve had the same issue. I’ve powered off, turned off cellular data, I’ve done a hard reset.  Nothing.  

Badge

I was able to fix but I'm not sure of the technical aspects behind it. I changed security settings on the T-Mobile router from WPA2/3 (default?) to WPA (no trailing digits). This meant my older iPad devices were able to connect. I don't know the security ramifications of this, in case someone cares to explain.

Thanks for the update. I just found another conversation on connecting wireless thermostats and the issue that they were having.

1. Open the T-mobile Internet app

2. Go to the Network tab at the bottom

3. Click on the "+" sign to add a network

4. Add in the information for a 2nd network and change the frequency band to 2.4 GHz.

Done. Now you have 2 networks and 1 is 2.4 only. 

I used following via the T-Mobile app and created a 2nd WIFI at 2.4 GHz, WPA2 and AES WUPA Encryption Mode.  This might be a better option without impacting the security options on the router.  I’m also hopeful when we install a new WIFI thermostat that it will allow us to use either network. 

 

 

Thanks for the update. I just found another conversation on connecting wireless thermostats and the issue that they were having.

1. Open the T-mobile Internet app

2. Go to the Network tab at the bottom

3. Click on the "+" sign to add a network

4. Add in the information for a 2nd network and change the frequency band to 2.4 GHz.

Done. Now you have 2 networks and 1 is 2.4 only. 

I used following via the T-Mobile app and created a 2nd WIFI at 2.4 GHz, WPA2 and AES WUPA Encryption Mode.  This might be a better option without impacting the security options on the router.  I’m also hopeful when we install a new WIFI thermostat that it will allow us to use either network. 

 

 

I looked and saw that my system was already set up for automatic switching between 5G and 2.4G. The only thing that worked for allowing me to connect my Ipod (5th gen) was change the security settings to WAP. I'll change it back to the recommended setting when I finish reconfiguring my Sonos system.... Don't want to have a compromised security set up. 

This is very helpful. I did what the above said and my old iPad is now connected to the home internet 

Badge

T-Mobile set up two networks for me, thought I would need it for the printer. Do I understand correctly that I must have a router?

Badge

And i have tried connecting to both networks but my ipad does not connect to either

 

 

Thanks for the update. I just found another conversation on connecting wireless thermostats and the issue that they were having.

1. Open the T-mobile Internet app

2. Go to the Network tab at the bottom

3. Click on the "+" sign to add a network

4. Add in the information for a 2nd network and change the frequency band to 2.4 GHz.

Done. Now you have 2 networks and 1 is 2.4 only. 

I used following via the T-Mobile app and created a 2nd WIFI at 2.4 GHz, WPA2 and AES WUPA Encryption Mode.  This might be a better option without impacting the security options on the router.  I’m also hopeful when we install a new WIFI thermostat that it will allow us to use either network. 

 

 

Thank you so much. I was at a loss for connecting my iPad to the network.

I tried setting up a 2.4 GHz network for my old iPad but the “Add” box remains grayed out and only offers me the option to Cancel.  What am I doing wrong?

Userlevel 5
Badge +6

@whogue you need to give your new network a name different from the other network(s) you already have.  (For example, “MyNetwork2”); create a password; set the frequency band (2.4 GHz); and set your security.  For an older device, I would try WPA/WPA2.  After you have entered something in each of those areas, the Add button should no longer be grayed out.

Userlevel 7
Badge +12

I tried setting up a 2.4 GHz network for my old iPad but the “Add” box remains grayed out and only offers me the option to Cancel.  What am I doing wrong?

You need to set up the 2.4 GHz network in the T-Mobile Internet app before you start connecting your ipad. 

I’m glad I’m not the only one with a super outdated iPad. It’s connected now! Thank you Schroeder5!!!

Reply