Question

S22 Ulra RCS Not Working Properly

  • 25 February 2022
  • 23 replies
  • 1702 views

Badge

S22 Ultra is having RCS issues. I can send chat but everything I receive (from known RCS users) is text. Chat Features shows as Connected

I updated Carrier Services as well.

Any ideas?

 


23 replies

I have the same issue. It appears T-Mobile has not adopted Universal Profile and we are locked into their network for chat.  T-Mobile is providing the server connection on the S22, and they have not interconnected with Google (best I can tell).  Former Sprint customers on older devices, however seem to have access to Universal Profile. 

There is a solution that worked 100% for me. It is worth a try:

https://9to5google.com/2022/02/25/galaxy-s22-google-messages-rcs/

Userlevel 6
Badge +12
  1. Force Stop Android Messages
  2. Go into Sim Manager
  3. Turn off the sim
  4. Wait 1 minute
  5. Turn on the sim
  6. Open Android Messages

This has worked for me.

Userlevel 7
Badge +16

are you unable to see when they are replying or when they have read it? always a possibility they turned that part off on their side..

Userlevel 7
Badge +15

Roll back your messaging app to a June release or earlier until Google and how blindly Samsung jist copies and pastes the code into their Android Messages clone is fixed.

I just upgraded to s23 unlocked and I can't communicate with any t-mobile chat users. I think it's because my new s23 ultra unlocked is using jibe. They my t-mobile users show as online and it even says my chat is encrypted and I try and send messages to them and it never sends. I've done all the steps recommend and it's not working still. It's stupid...

Userlevel 7
Badge +15

Is Jibe up to date?  Google has been making some changes to RCS recently.  If everything else works fine.  It is more than likely related to the changes to RCS and Jibe just hasn't been updated yet.

Userlevel 6
Badge +12

turn off 5G turn off rcs then wait 1 minute and turn it back on.  when it connects turn on 5G. send a test. Jibe and 

t-Mobile should already be interloped as I would think Google wouldn’t make Android messages be connecting to T-Mobile servers

Everything is up to date. I work in IT, I worked known to unknown in a logical sequence. I'm just sending it back and getting the T-Mobile model and will have them send me the unlock code. Pain but stuff just seems to work better which is ridiculous. 

Carrier services, tried rolling back, tried everything. The only thing I'm thinking is happening is something is wrong with universal profile. Like the T-Mobile users connect and we show as encrypted but when the data is sent it sends to the old profile that's on the T-Mobile servers and even though I've confirmed my number on new devices it's still trying to hit the cached profile but it's just a guess. 

Only reason it disconnects is because we gave up and sent as sms/mms 

 

Userlevel 6
Badge +12

My Daughter has the S22U unlocked and I have the S23 Ultra T-Mobile and it all works fine.  I don’t have the problem you are having.  

It's bizarre for sure.. I'm hoping it clears after me being on jibe servers for a few more days.

 

Came across The doc on how it works and user stories and such.

 

https://www.gsma.com/newsroom/wp-content/uploads//RCC.71-v2.6-1.pdf

 

 

So I got it working after forcing my buddy to go to the website to confirm his number. We both had to. I'm 90% sure it was because we had stale entries and it wasn't replicating properly. I actually went to the site for him as he's not super technical and was tired of me trying to troubleshoot so he just gave me the otp and blammo it worked about 2 mins later. 

I knew I had to do all the same troubleshooting on his end to reset his connection because there was nothing else for me to try. I had done it all on my so many times lol. I was able to get other t-mobile user too. I had already started the return process too and was about to send it back and to get the network locked version. Which I don't mind either because T-mobile unlocks it for me when I have if you reach out to the right customer service reps. Glad I didn't have to though. I liked the blue color and I wouldn't have lost about $50 from the pre-order and discount programs I'm part of not to mention my screen protectors. 

Badge +1

There are issues when using Message with T-Mobile as the backend for RCS. It is sending pictures and videos as text. Even now it displays SMS or MMS on the send button when sending to another person running Google Messages with T-Mobile as the back end. If I send to someone using Samsung Messages on T-Moible it's fine. If I send to someone using Messages with Jibe as the backend it seems ok. When I first got my S23 Ultra it would not compress the videos so long as they were under 30 MB. I noticed that it was compressing photos before when I was recently on the T-Mobile S20. RCS was provided by a Jibe. Again, I've tried all troubleshoot steps. Disabled RCS and deregistered my number from Google Messages and waited 10 days before enabling. There is so much inconsistency with Google Messages over T-Mobile RCS servers. There is something implemented wrong. Anyone who has a S22 or S23 look at the photo or video size of one you sent or received. Specifically those using Google Messages over T-Mobile RCS servers. See if it's the original size. 

Well the t-mobile chat servers on google messages default allowed is unlimited size. For unlocked devices it’s only 100mb… kinda sucks. Not sure I’ll buy an unlocked device again. So many gotchas and they just don’t work the same way as the network locked devices.. not to mention my esim is broken.. tried different carriers and everything. I mean t-mobile unlocks it for me me anyways. So will never go the unlocked route again. ( I did this to myself I believe on the s20 ultra and had the similar drama and said I wouldn’t do it either but of course I did and now I hate it.. 

Badge +1

It's 100 MB for RCS Universal Profile 1.0. Ignore what it says in the settings of the Google Messages app. That just means it will receive a file of over a gig. The protocol doesn't support over 100 MB. What's crazy is I can send pictures through Samsung Messages over RCS to someone on Android Messages. There is still slight compression with photos. The resolution is smaller. 

Badge +1

Google Messages is compressing photos down to 768 x 1024.

Had the same issue on my S23+. This solution finally fixed it for me:

go here and de-register RCS for your number - How to turn off RCS chats (google.com)
then wait 5 minutes and turn the RCS feature back on in messenger. 

I think it has something to do with your previous phone messenger app still being cached or whatever. That definitely fixed RCS for me. Nothing else i tried worked.

Badge +1

Believe me, I've tried that as I said in my initial comment. I wait 1 minute, 5 minutes, and even 10 days after disabling RCS on my phone and deregistering on the link provided. The same thing happens to my wife. We had similar issue on our S20's. We both have new S23 and it so flaky. Decided to try RCS today and I had messages sitting for 30 minutes before they were sent. We both turned on RCS at the same time. A few messages went through just fine and then stuck at waiting until person is online. This is in the middle of talking and RCS was still connected on both of ours. There is no advantage of using RCS right now. Photos and videos are compressed over RCS. The only thing I don't get is seeing them type or seeing they read the message. You can get a delivered report on SMS. Their literally an issue on the back end with how TMobile and Jibe RCS servers are interconnected.

Doesn't matter if 5G is enabled, or on WiFi, what my DNS servers are set at, or if private DNS is on or off or set to automatic for it. App has been removed clean off my phone and network settings reset. Again, these are new S23 phones. Both are eSIM. Can't say if having a traditional sim would make a difference. I do know with my S20 I used a sim card and then converted it to eSIM still experience RCS text hanging up.

 

Had the same issue on my S23+. This solution finally fixed it for me:

go here and de-register RCS for your number - How to turn off RCS chats (google.com)
then wait 5 minutes and turn the RCS feature back on in messenger. 

I think it has something to do with your previous phone messenger app still being cached or whatever. That definitely fixed RCS for me. Nothing else i tried worked.

Damit, this took me about a month to resolve. 
What worked for me in the following order:
Unregistering on the site
Clear cash and data for Messenger
Uninstall updates.
Restart
Install updates.
Activate

And it started working 

  1. Force Stop Android Messages
  2. Go into Sim Manager
  3. Turn off the sim
  4. Wait 1 minute
  5. Turn on the sim
  6. Open Android Messages

This has worked for me.

Please explain "turn off the sim" 

Reply