Question

WIFI Calling Preferences Being Forced to Cellular Preferred

  • 10 October 2020
  • 87 replies
  • 31769 views

Userlevel 3
Badge

I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.


87 replies

I called TM yesterday to inquiry about this. The rep treated me like I was stupid. Kept telling me there is no service at my adddress when the entire issue is why is my

phone switching to cellular service and staying on cellular. He also suggested that I contact Apple because it could be an issue with my phone. After I told the guy repeatedly this is a known issue with TM. I even told him to go look in the community forum. He more or less ignored the issue. 

Userlevel 1
Badge

The last I knew this was not a problem with Verizon (and XFinity Mobile and other Verizon offshoots).  TM is still not willing to admit that they are the source of the problem. 

However, if you complain enough they will provide you with one of their pico cell devices.  There is a $20 deposit for that.  That way you don’t need to worry about cell connections (and this setting) at least in the house.

I have yet to figure out why TM is doing this.  Probably just incompetence and/or laziness. 

 

This problem seems to have started after a recent T-Mobile software update and is affecting your ability to make and receive calls and text messages due to poor mobile data signal in your area. You've already tried several troubleshooting steps, including changing routers and contacting T-Mobile tech support, but the issue persists.

Here are some additional steps you might consider:

  1. Software Update Check: Ensure both of your Samsung Galaxy S20 phones have the latest software updates installed. Sometimes subsequent updates can fix bugs introduced in previous versions.

  2. Wi-Fi Calling Settings: Double-check the Wi-Fi Calling settings on both phones:

    • Go to Settings > Connections > Wi-Fi Calling.
    • Ensure Wi-Fi Calling is turned on.
    • Set the "Calling preference" to "Wi-Fi preferred".
  3. Carrier Settings Update: Sometimes carrier settings need to be updated separately from the phone’s software. This can usually be done via:

    • Settings > General management > Reset > Reset network settings.
  4. Network Reset: This step can often resolve connectivity issues:

    • Settings > General management > Reset > Reset network settings.
    • Note that this will reset your Wi-Fi, Bluetooth, and other network settings, so you will need to re-enter Wi-Fi passwords and pair Bluetooth devices again.
  5. Contact T-Mobile Again: Since this issue might be more widespread, consider asking T-Mobile if they are aware of any ongoing issues with Wi-Fi Calling preferences and if there are any patches or fixes planned for an upcoming software update.

  6. Samsung Support: Reach out to Samsung support to report the issue. They may have additional insights or solutions.

  7. Community Forums: Continue to monitor and participate in forums and discussion boards. Sometimes, other users or unofficial support channels might provide solutions or workarounds that are not yet widely known.

  8. Replacement Phones: Since T-Mobile has offered you two new S20 phones under warranty, go ahead and try them. If the issue persists with the new devices, it further indicates a software or carrier issue rather than a hardware problem.

  9. Alternative Solutions: In the meantime, continue using the workaround of switching to Airplane mode and manually changing the Wi-Fi Calling preference when necessary. Although tedious, it might be the most reliable interim solution until a permanent fix is available.

Given your situation, it's understandable how this issue impacts your daily life. Hopefully, T-Mobile or Samsung will acknowledge and address this problem soon. Keep documenting your interactions with support for reference and potential follow-ups.

I live in an area with bad cellular service, but I have great Wi-Fi and I still have this issue all the time.  It is so frustrating that I’m considering leaving TMobile because of it.  I assume this is still an issue for others and no fix from TMobile?

Userlevel 1
Badge

I know that this is an old thread.  However, they ARE STILL DOING THIS.  It is hard to understand why.  I don’t know what it “buys” them, except a lot of customer annoyance.

I agree that it is likely some TMo bloat/firmware that is doing this since the VZW phone I was using didn’t have the problem.

Yes, I knew that they were likely just trying to get rid of me.  Since I’m retired I can take the time to go to Level 2/Manager support.  That is a task for this week now that I’ve done my research.

In the mean time I’m trying the Tasker hack that is supposed to automatically turn wi-fi preferred on if anything turns it off.  I don’t know yet if that is going to help, but it is worth a try. 

Samsung support said that this isn’t their problem since all wi-fi calling features are carrier specific.  I had to try.

I don’t know if there is a root for the S22 yet.  Even if there is I probably won’t do it yet since with a new model there is often a flurry of stock firmware updates for the first few months.  I’ve read that there is one coming.

I don’t believe T-mo bloatware is the issue here.
I have an unlocked S22 Ultra, purchased directly from Samsung.
I’m using Mint mobile, which uses T-mo towers, and I’m having this ongoing issue.

Still an issue and could be an easy fix if T-Mobile actually addressed it. A simple added feature to select preferred networks based on location. I need Wi-Fi calling at home. Is it really that difficult to have a home location set with an option to specify a network preference based on that location? Home -> use cellular, use wifi, use strongest network.

 

Duh T-Mobile. Let's actually do a little engineering and not let issues founder for years. 

I have this same problem with my Samsung 13 5G.  I called T-Mobile’s ‘technical’ support line, and they had the audacity to say that wifi calling is only supported on the iPhone. This was idiotic, and I vainly tried to argue with them that they were mistaken, but, for the technical support agent on the phone, ‘the script is always right’.

Very frustrating.

Very frustrating that this issue has persisted for years and across multiple devices. I usually only think to check the setting when my call quality is bad, and sure enough it's switched back to "cellular preferred". 

So frustrating to find such an old thread, on a topic that has not been answered.

We live outside cell-signal range. Way back when, Wi-Fi calling was THE reason we had T-Mobile in the first place.

And we are still being frustrated by automatic resetting to "cellular preferred" MULTIPLE TIMES DAILY, disrupting our communications. 

I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.

Yes, still having this issue though less often for the past six months or so. I thought it was fixed but has gone back to switching to cellular preferred lately.   It seems to change sometimes when there is no wifi, but does not change back when I get home with good wifi, but very poor cellular.   So, yeah, makes no sense and very detrimental if you forget to check it every time you get home.   I'm likely to leave T-Mobile due to this issue.   

 

And no I don't know any more about what T-Mobile has done.  I got tired of calling and reporting this issue a year ago.

Badge

 

Userlevel 1
Badge

I’d like to refresh this very old thread.  T-Mobile still refuses to fix this issue.  I am now on a Galaxy 23.  The same thing has been going on 4+ years. 

They still “automagically” change this setting to Cellular Preferred.  They have no business ever touching this setting. It is simply a customer preference.  A preference should have nothing to do with what is actually happening while a phone moves. 

 

What should happen (obviously) is that when a phone move to a location where there is no Wi-Fi they should (silently) change over to the cell network.  IF the customer has Wi-Fi preferred and they go back to a location with Wi-Fi they should silently change over to Wi-Fi.  There is absolutely no need for this user preference to ever change unless the user changes it manually.

I have tried to explain this simple concept to T-Mobile reps on at least 7 occasions (including over an hour today).  For whatever reason they are completely unable to understand this simple concept.  This is very, very frustrating!

ONCE I actually got a rep who understood the issue the first time I explained it.  She finally said she’d refer to up the line.  Obviously nothing happened (in 18+ months).

I don’t understand why T-Mobile is so resistant to fixing this issue.

BTW, I know that Verizon does not do this.  I don’t think AT&T does either, but I haven’t tried them.

WiFi calling and HD calling rolled out on Sprint before my GS8 replaced my GS3, and it worked flawlessly. Handoff from my killer WiFi to cellular & back no problem, ever. Even in my expanded-wire plaster, wire & lathe walls (1940’s) WiFi calling gave me HD calls all over the house …

… now disabled, a phone means life even more than the ‘maybe I need 911’ of years past. The merge got me my first T-Mobile SIM -- and bad WiFi calling, so I went back to the Sprint network, until I had to go to a new T-Mobile SIM -- WiFi calling was improved … but I’m now in ‘preferences’ v. ‘settings’ land like most every post here. Been to tech support -- forced to the Sprint side. Pushed to buy a phone at every turn, go to iOS, completely migrate to a T-Mobile account … get a Cell Spot.

No reason to expand TMo’s 4G-LTE by giving them free data, free run of my LAN, and free power, for an unregulated, unlicensed, cell tower, which will shut down as soon as power fails. I currently do better with my Ooma VoIP setup.

In my case, TMo 4G LTE is usable 1 meter inside the house, entering from the east (front). The middle is a 4G dead zone. The north window in my office can see 5 bars of ATT 4G LTE and tries to use it - but the power drops to minimum necessary, saving bandwidth, triggering a switch back to WiFi -- after a few rounds of WiFi/AT&T ping-pong -- all cell connectivity is broken, and my number is “unknown” to all callers -- no texts, no voice mail , no calls, in or out -- but I can still browse the web just fine -- I must restart my phone to restore service.

Done the support orbit for two weeks -- same exact story as everyone else.

I suspect that Samsung struck a data deal with TMo, that must use cellular data to satisfy, because if it used WiFi, it would be trivial to snoop and see what’s being forwarded … if this hypothetical is in any way correct, we’ll be very unhappy with such a dark alliance.

So, TMo and AT&T are not playing well together --- but what can you do?

This is a patch - it’s ugly - but it will keep you online and able to use 911 in an emergency, without a restart and a password. Three steps:

  1. settings→connections→WiFi→[three-vertical-dots, upper right]→advanced→switch to cellular→off

Now, go someplace where you do have TMo coverage, or this will glitch.

  1. settings→connections→mobile networks
    1. verify that T-Mobile is the Network Operator
    2. set it manually if you must
    3. Data roaming→off

Final Step

  1. settings→connections→data usage→mobile data→ off

With those 3 settings in place, my GS8 now pesters me relentlessly with a system dialog asking for permission to search for a better data connection -- why my WiFi isn’t ‘supremely endowed enough’ for their liking is impossible to fathom without considering hypothetical situations such as those expressed as my personal opinion above.

I’ll happily ignore and cancel a fast system dialog that self cancels as you type a text or e-mail. Far less painful than 6 reboots on a Sunday afternoon. It keeps me from getting kicked to the curb by AT&T, which clearly does not approve of playing ping-pong - it’s a waste of cellular setup resources - the most expensive connection in the game - no wonder they kicked my T-Mobile data-roaming to the curb.

Side note, the phone won’t scan for other Cellular Data networks if it’s connected to one, so this happens only in fringe cases and ‘sturdy’ construction -- and no, 28GHz and 39GHz 5G won’t do any better - it will do far worse - you’d need 100GHz to walk through the mesh in my walls, unscathed.

I’m unhappy, have been disrespected, and unacknowledged.

I’m patched well enough for now -- but it’s not a solution. As far as I’m concerned, I’ll let the US DOJ have an image of my phone’s firmware …

 

 

Userlevel 1
Badge

This has been a long ongoing problem.  I have had it happen on many phones including now on my S22 ultra.   From what I’ve found out it is only on Samsung phones and only on T-Mobile. 

Every time it happens I call T-Mobile.  Yes, it is a PITA but if everyone does it maybe they will take notice.

Alas, after several days, my phone spontaneously changed my wifi calling setting back to cellular preferred, so turning off the “intelligent wifi” setting was not a permanent solution after all. I am left to conclude that this “feature” must be baked into the software, and immune from deactivation by the user. Oh well, it was fun while it lasted.

I'm truly sorry to hear that. I've been researching this problem on a friend's Samsung phone for a long time. (It does not occur on my own Pixel 5.)

 

I really wish somebody somewhere would fix this problem.

So here’s my problem. I’ve had poor cellular reception for over a decade at my home, so I had T Mobile  send me a 4G LTE cellspot, which works great.  But with my new 5G phone, it refuses to use 4G and keeps trying to use 5G towers, which do not work in my neighborhood. They work very well elsewhere in my city/county, but not at home.  So I’ve tried to use WiFi calling at home, the phone says it’s using it, but it will not connect nor do I get any incoming calls. I have it set to use WiFi and not cellular preferred, it doesn’t matter as it always tries using the cellular network. The phone keeps trying to use the 5G towers which suck.  So my only solution is to turn WiFi calling off and manually change my cell service to 4GLTE while at home (so I’m using the cellspot), and then remember to change it back to 5G when I leave the house.

Setting the preferred cell network at home to Automatic (5G on/ 5G/LTE/3G/2G) won’t work either, it won’t use the full bars LTE instead of the nearly non-existent 5G. 

I have the same problem. I do not have good service at my home so this is a big pain.  I tried the solutions on here and I don't want to pay for an app so the solution I came up with is to put my phone in airplane mode and then enable my wifi. Cellular preferred is no longer an issue. Only down side is I have to remember to take my phone off airplane mode when I leave the house. Oh and my phone is a OnePlus. If that doesn't prove the issue is TMobile, IDK what does

Userlevel 1

Alas, after several days, my phone spontaneously changed my wifi calling setting back to cellular preferred, so turning off the “intelligent wifi” setting was not a permanent solution after all. I am left to conclude that this “feature” must be baked into the software, and immune from deactivation by the user. Oh well, it was funwhile it lasted.

Userlevel 1

You’ll get no argument from me that this fiasco should never have been allowed to happen. Assuming that changing this setting finally puts a stop to the problem, it is clear that the tech support people at T-Mobile know nothing about Samsung’s efforts to “improve” its products’ network performance by overriding user-applied settings. I would have left T-Mobile long ago over this single issue if I could have found a better deal with a different service provider, but I couldn’t, so here we are. I have often wondered what other user settings might be getting altered without my knowledge, but I’ve never caught one in the act. All of that aside, I now believe that Samsung was the “villain” all along, but I blame T-Mobile for not understanding what Samsung has been doing to its customers in a misguided effort to make its products look better.

Userlevel 1
Badge

It is definitely worth a try.  I’ll give it a shot.

 

There is a big “however” involved here though.  The phone (or maybe T-Mobile One UI) has no business changing a setting that I have deliberately made.  That is not to say that on a case-by-case basis the phone/T-Mobile shouldn’t opt to use cellular or wifi.    In this case I would interpret that to say: “Unless there is a reason not to, I very strongly suggest that you use ….”.

I do have to say that I may have been incorrect on what was going on with specific reference to the S22 with the release date firmware.   I assumed that the phone was changing to cellular preferred, and that cellular (4G in my area) just didn’t work well.  I now believe that there were two things going on.  First, wifi calling just didn’t work at all with the release date (factory) firmware.  That is, it was completely non-functional   That would explain why the phone was constantly reset to “cellular preferred”.  Second, 4G calling had major problems that resulted in at least partially unusable calling (the first 5-30 seconds of 50% of the calls) was the problem.

Starting with the first (around 3/20/22??) firmware upgrade, wifi calling suddenly (apparently) started working.  When I had wifi calling turned on voice call were now 100% clear.  Suddenly I no longer had my preferences reset to “cellular preferred” except when I left home.  When leaving home it will sometimes change to “cellular preferred”, but when reaching home to would revert back to “wifi preferred”.  I still say it shouldn’t do that ever though.

One of the reason I misinterpreted the major cause of the problem was that the phone UI does not clearly state the status of the call -- wifi vs. cellular”.  That is still the case.  It really wouldn’t hurt the to note that in that screen.  There is plenty of room.

So, at least for the S22 there is good news!  Still, T-Mobile needs the fix the “preference” problem.  T-Mobile also needs to train their support people better.  There was apparently at least a month where the S22 wifi calling didn’t work.  Support should have know that.  They didn’t.

 

Userlevel 1

I know this is an old issue, and I have also been seeking a solution for a LONG time, but I have cautious optimism that I may have discovered a solution. Samsung includes a “feature” called “Intelligent Wi-Fi” through its “Knox Ecosystem” that, apparently, attempts to adjust its phones to optimize data usage through the application of artificial intelligence to monitor user behavior over a period of time after which settings are automatically modified, including the prioritization of either wifi or cellular data for handling calls and/or texts. I recently noticed a notification on my handset informing me that it had automatically switched my wifi calling setting from wifi preferred to cellular preferred. For some reason, this prompted me to go to my actual wifi settings rather than my wifi calling settings, after which I tapped the 3-dots icon in the upper right corner and selected “Advanced” Wi-Fi settings. There I discovered a category called “Intelligent Wi-Fi” with a setting called “Switch to mobile data” turned ON, and that contained an explanation saying “Use mobile data whenever your Wi-Fi internet connection is slow or unstable.” A little research revealed this article on Samsung’s website: https://docs.samsungknox.com/admin/knox-platform-for-enterprise/kbas/kba-360034073174.htm, where I learned that Samsung had experienced problems in the past with users having their phones switched to cellular data against their wishes, causing them to update the software in the manner described in the article. This inspired me to turn the “Switch to mobile data” setting OFF, after which I have now gone several days without experiencing the dreaded automatic switching back to “Cellular preferred” on my Wi-Fi Calling feature. Not enough time has gone by for me to feel completely confident that this issue is resolved, but I am cautiously optimistic. We shall see.

Userlevel 1
Badge

Well, I was actually surprised recently.  My phone preferences automatically “optimized” briefly to “prefer wifi” rather than the other way around.  That was the first time I’ve seen that.  Either way, the phone/T-Mobile should never change a user preference.  It can/should change which way it chooses to make/receive a particular call, just not a preference.

Userlevel 1
Badge

I agree that it is likely some TMo bloat/firmware that is doing this since the VZW phone I was using didn’t have the problem.

Yes, I knew that they were likely just trying to get rid of me.  Since I’m retired I can take the time to go to Level 2/Manager support.  That is a task for this week now that I’ve done my research.

In the mean time I’m trying the Tasker hack that is supposed to automatically turn wi-fi preferred on if anything turns it off.  I don’t know yet if that is going to help, but it is worth a try. 

Samsung support said that this isn’t their problem since all wi-fi calling features are carrier specific.  I had to try.

I don’t know if there is a root for the S22 yet.  Even if there is I probably won’t do it yet since with a new model there is often a flurry of stock firmware updates for the first few months.  I’ve read that there is one coming.

Userlevel 1
Badge

I was using an S21+ originally on the Verizon network and ported to TM.  This problem did not happen on that device.  I purchased a T-Mobile S22 Ultra and I immediately started getting this problem.

I have 1 - 2 bars cellular and 2 excellent Wi-Fi routers with a super high signal strength.  So, there is no possibility that anything is actually being “optimized”.  ‘

I did call TM tech support.  They blamed Samsung.  It is very disconcerting that this problem has been going on for years!

I have no problem with the phone temporarily switching to cellular if the phone sees a problem with wi-fi.  However, I have a major problem with them resetting the wi-fi preferred option I deliberately set.  That makes zero sense.  Suddenly a 30 second issue with Wi-Fi strength becomes a permanent preference for cellular???? 

This is a huge problem because all my calls are going from crystal clear wi-fi to very broken cellular.

At the very least if they “optimize” to cellular they should re-optimize back to wi-fi when wi-fi is better. Instead, it just goes in one direction.

 

 

I’ve been fighting this a LONG time.  I don’t believe it to be a Samsung issue. They will tell you anything to get rid of you.  They DO know it is an issue for many.  Switching between WiFi calling and cell calling doesn't need to change the preferred method setting.  I’ve had inside sources tell me that it is TMo doing it.  They want you to use the cell system not WiFi which is why they keep pushing the change.  For those with good cell signal strength it doesn’t matter, which is why they make the change.  For those with poor cell service it is a huge problem.  TMo needs to understand and stay out of your settings!

I too have a new S22U.  I did not automatically transfer across everything, but took the time to install new.  I purposely limited and avoided everything TMo related.  It has yet to happen to me on this phone.  I do not do auto updates and nothing TMo ever gets updated.  I am in the process of doing a debloat.  I will root this phone if I have to.

Reply