Solved

Dell laptop connects to gateway but no internet

  • 13 February 2024
  • 14 replies
  • 158 views

Badge

Got the T-Mobile gateway today, set it up and I had my laptop connected to it using wifi, My wife's desktop is working (Ethernet cable), my Iphone 13 Promax connects no problem and I have a network switch in the second Ethernet jack that is working.

 

My laptop is a Dell Inspiron 17 5767 running Windows 10. Wireless adapter is a Intel dual band wireless AC 3165. Tried updating the driver for the wireless adapter already.

 

Also tried creating a second network set to 2.4 and 5 GHZ ( 2 separate times) and lowered the security to WPA2, no change, When I try to connect to either network I get “secure, connected no internet)

 

Keep in mind when I first hooked up the gateway it was working on my laptop, I closed my laptop to do something else and when I came back to my laptop I could not connect to the internet.

 

Tried resetting the network adapter and ran the network troubleshooter.

 

tried rebooting the gateway, no change.

 

Don’t know what to do next, read on this community about getting a USB wireless adapter that is compatible with 802.11 ax.

 

Thanks for any assistance

icon

Best answer by Hardbody 15 February 2024, 02:01

View original

14 replies

Badge

also spoke to T-Mobile tech and he couldn’t help

Userlevel 5
Badge +8

@Hardbody if it was working before it should work now. 

Please confirm your laptop setup. Did your Windows laptop connect via wifi? Did the laptop wifi see the SSID you setup on your TM Gateway? When you tried to connect what happened? Have you tried to connect via ethernet cable? 

 

Badge

Dell Inspiron 17 5767 running Windows 10. Wireless adapter is a Intel dual band wireless AC 3165

 

When I first installed the gateway the SSID was the default name, I just changed the pass code

 

Yes it connected using wifi, no I have not tried a cable

 

When I connect it says “secured, connected, no internet”

Userlevel 5
Badge +8

So it appears your laptop sees your gateway, which is good. Maybe your laptop needs you to tell it which DNS server to use. 

Go to control panel > open Network and Internet > Network and sharing center > change adapter settings > properties > Internet Protocol Version 4 > find the DNS server address and input: 1.1.1.1 and 8.8.8.8 - save and restart your laptop. Let us know if this solves your issue.

https://www.windowscentral.com/how-change-your-pcs-dns-settings-windows-10

 

Badge

No change

Userlevel 5
Badge +8

If your other devices work, then its a laptop issue. Have you tried to update the wifi adaptor driver in Windows? I use Macs, and my technical knowledge is limited. If you go into Device Manager, you can check it there or Google your AC 3165 for a newer driver. 

Sorry, I am out of suggestions. Maybe someone else has a better idea. 

Badge

Tried to update the driver, searching now to see if I find anything

Userlevel 5
Badge +8

Try this one?

https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=txtm8

 

Badge

Found an updated driver on Intel site, installed no difference, still showing the same, thanks for trying to help

Badge

Found the specs for my wireless adapter and it says it uses 802.11ac

Userlevel 5
Badge +8

I came across this: 

Did you try to reset the laptop network settings? You have Windows 10, and the video is Windows 11. It’s the same idea. 

And, here is one from iFixIt: https://www.ifixit.com/Answers/View/644431/Why+can't+I+connect+to+the+internet

Badge

I did that already, also did all the dns release, renew, windsock, etc.

 

today I disabled than re enabled the WiFi adapter. Rolled the driver back, no change.

 

weird that it worked at first but now it won’t. 

Badge

Ordered a usb wireless adapter, will see what it does later when it arrives 

Badge

USB wireless adapter just arrived and I’m online no problem !

 

Bought the Asus AX100

 

Thanks for all the suggestions.

Reply