Question

how to connect Canon Pixma MG3620 printer to Tmobile home internet?

  • 10 May 2022
  • 7 replies
  • 2048 views

Badge

The printer gets the correct SSID, but no encryption or authentication. It looks like on earlier version of the internet box you could set network parameters, but no longer in the black tower.


7 replies

Userlevel 1
Badge

On my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.  Voila!  This is after a fruitless call to Tmobile tech support, which described the problem I had connecting to a printer problem, and transfer me to Cannon tech support, which never connected me to a live person, but instead directed me to their website, then hung up.

On my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.  Voila!  This is after a fruitless call to Tmobile tech support, which described the problem I had connecting to a printer problem, and transfer me to Cannon tech support, which never connected me to a live person, but instead directed me to their website, then hung up.

Wow!  Thanks so much!  Been googling forever to figure this out with my Canon wireless printer!  Great instructions!  Stupid question…do I leave the WPA version or change it back to WPA2/WPA3 now that I’m connected??

Userlevel 7
Badge +15

On my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.  Voila!  This is after a fruitless call to Tmobile tech support, which described the problem I had connecting to a printer problem, and transfer me to Cannon tech support, which never connected me to a live person, but instead directed me to their website, then hung up.

Wow!  Thanks so much!  Been googling forever to figure this out with my Canon wireless printer!  Great instructions!  Stupid question…do I leave the WPA version or change it back to WPA2/WPA3 now that I’m connected??

If you change it back to WPA2/WPA3, your printer will not connect so leave it on WPA/WPA2.  Your printer is connecting via WPA.

Badge

Thanks. It worked!

Although my TMobile Gateway is now WPA/WPA2 instead of default WPA2/WPA3, with lower security and performance.

Also the lowest end Canon printers lack a control screen and input. So you have to hit the On, Wireless, and Color buttons in a certain order to accept connection settings from the TMobile Gateway. These are described in online Cannon Printer app.

This worked great for me!  Wireless using my phone, didn’t have to change any settings.

 

 

@SSW I do not know who or where you are, but I could kiss you right now!  After spending almost 16hrs trying to figure this out... I just so happened to stumble on this in my crazed ocd search to figure out what is wrong with my printer.  May the Kama God's smile upon you and you be blessed with good JuJu for the rest of your days!

@SSW Thank you so much! This was so helpful! I have spent so much time trying to get it to connect! I just added another “network” that I will just use for printing as the WPA/WPA2. You are a lifesaver!! 

Reply