Question

Printer not Connecting to Wifi

  • 12 April 2023
  • 8 replies
  • 4706 views

Badge

I have a wireless HP Office jet 7500 wide format all in one printer and it will not connect. HP told me that a Mac address needs to be entered into my wireless routers. 


8 replies

Userlevel 5
Badge +7

Your problem is pretty common among T-Mobile Internet users. This usually fixes the problem.

Try adding a new WiFi network specifically for the HP. Launch the T-Mobile phone app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your printer. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. Scroll down and make sure the Hidden switch is set to Off. Scroll down and tap Save, and your gateway will reboot with your new network.

 

Now, go to your printer and clear out all of the information you have entered for your printer’s setup and then recreate your wireless connection to the new network you just created.

Let us know how it goes. Good luck!

I tried this for my Epson ET2800 but I con not get the printer to talk to my Chromebook. The printer works with my phone (in the Epson app) and everything says that the printer is connected to the network. My Acer Chromebook cannot find the Epson printer no matter what! It is extremely frustrating and I can not find answers anywhere else. Can anyone help, please!

Your problem is pretty common among T-Mobile Internet users. This usually fixes the problem.

Try adding a new WiFi network specifically for the HP. Launch the T-Mobile phone app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your printer. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. Scroll down and make sure the Hidden switch is set to Off. Scroll down and tap Save, and your gateway will reboot with your new network.

 

Now, go to your printer and clear out all of the information you have entered for your printer’s setup and then recreate your wireless connection to the new network you just created.

Let us know how it goes. Good luck!

Works great

I FOUND A SOLUTION!!! 
Apparently, the new tower is so powerful with its security that it won’t let just anybody through.

Here is what I tried for my wireless printer and it WORKED, because it creates a less secure connection for printers, etc.!!!
1. Open T-Mobile Internet App
2. At the bottom (where it says Home Devices Network Support More) SELECT NETWORK
3. Press the red circle with the PLUS sign in it (bottom right corner
4. Opens ADD NETWORK
5. Choose your Network NAME in the first line (where it says Wi-Fi network name (SSID)), i.e. Printer
6. Enter your password for this connection (where it says Wi-Fi network password (Key)

Scroll down to Advanced Settings:
7. CHANGE WPA VERSION from WPA2/WPA3 (recommended) to simple WPA2 (at the bottom) to make it slightly less secure

When you ADD this new network to your existing one, the internet might disconnect for 90 seconds. Mine DID NOT even disconnect.
Another thing I saw was CHANGING THE FREQUENCY BAND (above the WPA Version) from Automatic to 2.4 GHz, but I forgot and it still worked perfectly for my printer. So just in case it doesn’t work for you, try changing that too.

Then, when need to connect your printer, you can now find this new network, log in with that new password and it should work.

I spent all morning trying to connect my printer (which I need for work) and it drover me crazy!!!! 

Thank you Baby Jesus!! It worked.

I set up as recommended here and still not able to connect my HP Printer.  The blue light was blinking but now with reset, it is not blinking - HP 100 color MFP M175nw

Thanks   Got it 👍🙌

My Canon MB2320 doesn't support WPA3 so I had to change as previously suggested.

Great help here. I would never have figured this out myself. 

 CHANGE WPA VERSION from WPA2/WPA3 (recommended) to simple WPA2 (at the bottom) to make it slightly less secure

Reply