Question

International Roaming - Not connecting

  • 29 December 2023
  • 19 replies
  • 5269 views

Badge

I can’t get international roaming to connect to the internet even though all my settings are correct. We have unlimited data and texting, internationally.  I have a feeling T Mobile is blocking my number from roaming but they can’t figure it out. My wife on the same plan has working roaming - Any suggestions? T mobile cusomer care or technical could not resolve the issue - it’s as though they are not recognizing my number, associated with the plan… 


19 replies

Userlevel 7
Badge +15

Have you checked your devices settings to make sure you have roaming enabled on your device?  Have you tried reaching out to Customer Care at 611 from your T-Mobile line to make sure roaming is enabled on your account?  You can also send T-Mobile a DM on Facebook or Twitter to reach someone from the T-Force Team that could look into that for you as well.  Sometimes the speeds of the network you are connecting to are slow enough that it might seem like your data is not working.   

Badge

Yes, I’ve enabled data roaming. It shows in my “cellular tab” that “no data” has been used. It’s crazy since my wife’s phone works just fine on the same plan, etc. It’s honestly as though something associated with my number has roaming blocked or not enabled; I’ve been to an Apple store and a local cell phone store; they’ve tried the SIM card, etc. and it works in their device. They’ve also tried every setting, etc. Yes, we were on with TMobile technical support for almost an hour today; he tried reset, and all kinds of things, etc. Tried adding some random plan (my wife is on same plan and her phone is fine for data roaming). It’s hard because I can’t even use Whats App or GPS away from a wifi router. Tech support said they’d issue “a ticket” and get back with me but nothing yet. 

Userlevel 7
Badge +11

Don’t count on anyone getting back in touch with you.

Userlevel 7
Badge +13

Yes, I’ve enabled data roaming. It shows in my “cellular tab” that “no data” has been used. It’s crazy since my wife’s phone works just fine on the same plan, etc. It’s honestly as though something associated with my number has roaming blocked or not enabled; I’ve been to an Apple store and a local cell phone store; they’ve tried the SIM card, etc. and it works in their device. They’ve also tried every setting, etc. Yes, we were on with TMobile technical support for almost an hour today; he tried reset, and all kinds of things, etc. Tried adding some random plan (my wife is on same plan and her phone is fine for data roaming). It’s hard because I can’t even use Whats App or GPS away from a wifi router. Tech support said they’d issue “a ticket” and get back with me but nothing yet. 

To have one line working and the other one not on the same account is totally strange. Have you logged into your T-Mobile account to see if you have a roaming block on your line? It is normally something they check for when you call in, but it could have been overlooked. Are you able to make and receive calls and text messages? At the top of your screen, do you have signal bars and some kind of data indicator next to it? What phone are you using? Sorry this is a lot of questions, but more info makes it easier to help. 

Thanks! 

I am curious if you found a solution. This is happening to my daughter’s phone and she is in Japan. It started about a week ago. She will use use a friends hot spot to text me but if she is not somewhere we she can use WIFI, then she has no service. She has stated that she did all the routine checks etc and restarting the phone, but no solution. Did this happen to your service?

Userlevel 7
Badge +13

I am curious if you found a solution. This is happening to my daughter’s phone and she is in Japan. It started about a week ago. She will use use a friends hot spot to text me but if she is not somewhere we she can use WIFI, then she has no service. She has stated that she did all the routine checks etc and restarting the phone, but no solution. Did this happen to your service?

It is so cool that your daughter is traveling in Japan. Paint me green with jealousy. Let’s see what we can do to get her data working. Basic checks are good to make sure data roaming and mobile data are on and no data limitations are set in the phone settings. Our Internet and data issues | T-Mobile Support page also has some other suggestions for roaming travel. 

Do you know if she got a message when she got to Japan about her available service while she is there? Is she on your account? Have you checked her line for any roaming blocks on your MyT-Mobile account?

Badge

Thanks for you inputs. 

Yes, the TMobile person I spoke to today fixed my issue within a few minutes. She said it is a very common issue and knew just what to do - the previous two “helpers” tried everything, unsuccessfully. She understood the issues here in Malaysia and somehow manually connected me with a tower (4G) - and, everything works fine - a bit slow, but fine.  So, THANK YOU.  There was also something amiss with my specific number that had not be “unlocked” or something, even though my wife and I are on the same plan…. I feel like I can navigate now thanks to GPS and internet access.  

Userlevel 7
Badge +13

Thanks for you inputs. 

Yes, the TMobile person I spoke to today fixed my issue within a few minutes. She said it is a very common issue and knew just what to do - the previous two “helpers” tried everything, unsuccessfully. She understood the issues here in Malaysia and somehow manually connected me with a tower (4G) - and, everything works fine - a bit slow, but fine.  So, THANK YOU.  There was also something amiss with my specific number that had not be “unlocked” or something, even though my wife and I are on the same plan…. I feel like I can navigate now thanks to GPS and internet access.  

Doing a happy dance knowing that you are getting the service you need there in Malaysia. 

Safe travels!

I have called Mobile on three several occasions and they keep telling me it's being worked on but never get any details. My wife's phone works fine but I get no service unless on wifi

I am curious if you found a solution. This is happening to my daughter’s phone and she is in Japan. It started about a week ago. She will use use a friends hot spot to text me but if she is not somewhere we she can use WIFI, then she has no service. She has stated that she did all the routine checks etc and restarting the phone, but no solution. Did this happen to your service?

It is so cool that your daughter is traveling in Japan. Paint me green with jealousy. Let’s see what we can do to get her data working. Basic checks are good to make sure data roaming and mobile data are on and no data limitations are set in the phone settings. Our Internet and data issues | T-Mobile Support page also has some other suggestions for roaming travel. 

Do you know if she got a message when she got to Japan about her available service while she is there? Is she on your account? Have you checked her line for any roaming blocks on your MyT-Mobile account?

My sons and I are having this same issue right now in Japan. Wife's phone is working and mine was until a couple days ago. We're all on the same plan. Would love a solution to this! 

I have a same issue. I travel to Japan al the time and usually don’t have this type of issue. I wonder why it’s not working. Usually shows soft bank or docomo on the left top corner and that’s not showing anymore and 3G or 4G will shows on the right top corner but I see 4 bars but 3G is showing off and on. This never happened to me. Anybody know how to fix? I called Tmobile and trouble shooting but still not working. 

I've been having the same issues while here in Japan. In fact, out of 5 workers here that have tmobile, only the 2 android users are effected. The other 3 have iPhone. 

Customer care said it could be due to the way iPhone creates their ports for the network. But has no explanation why we've had no network for the past 2 months. They gave us free international passes for calling and data, but nothing is working. VERY frustrating 

I can’t get international roaming to connect to the internet even though all my settings are correct. We have unlimited data and texting, internationally.  I have a feeling T Mobile is blocking my number from roaming but they can’t figure it out. My wife on the same plan has working roaming - Any suggestions? T mobile cusomer care or technical could not resolve the issue - it’s as though they are not recognizing my number, associated with the plan… 

SOLVED!

I contacted customer support for the second time, and my issue was fixed. I have a physical SIM card, and they uploaded an eSIM card to my phone via text message. Once I completed the steps and changed the setting as required, and removing the physical SIM card (final step), works just fine! 

If you have an eSIM card already, you may also need to ask for the three digit code needed to force your phone to accept international data.

I hope this helps you guys... ✌🏿

I am curious if you found a solution. This is happening to my daughter’s phone and she is in Japan. It started about a week ago. She will use use a friends hot spot to text me but if she is not somewhere we she can use WIFI, then she has no service. She has stated that she did all the routine checks etc and restarting the phone, but no solution. Did this happen to your service?

I just got back from Japan on NYE.  Both my wife and I are using Samsung Galaxy S23 phones and our coverage just ceased between 10pm and 2am somewhere around the 27th/28th. My wife is still there and will be for months more.  Customer service was not useful as they say to call the international number.  Kind of not possible when you have nothing.  No roaming, data, or cellular at all.  She said her service is still out.  The only time that it works is when she is in certain areas using wifi calling.  Beyond that, it is nonexistent service.

If you're in Japan and having this issue. For context on service stoppage in Japan. DOCOMO and T-mobile ended their service agreement at the end of last year so the default no longer is in service you need to do the following and connect to softbank instead.

 

This is the fix I found below on reddit:

 

Found a fix to this for Android. Go into Mobile Networks and select Access Point Name (APN).

Create a new APN with the following details:

Name: (Anything you want)

APN: [epc.tmobile.com](https://epc.tmobile.com)

Proxy: Not set

Port: Not set

Username: Not set

Password: Not set

Server: Not set

MMSC: [http://mms.msg.eng.tmobile.com/mms/wapenc](http://mms.msg.eng.tmobile.com/mms/wapenc)

Multimedia message proxy: Not set

Multimedia message port: Note set

MCC: 310

MNC: 260

Authentication type: Not set

APN Type: default,supl,mms,xcap

APN Protocol: IPV6

APN roaming protocol: IPv4

Bearer: Unspecified

Mobile type: GID

Mobile value: 544D

​

Save this. Restart your phone. When you power it back on go back to mobile networks and select Network operators, unselect automatic. A list of of names will pop up, select Softbank.

I have a same issue. I travel to Japan al the time and usually don’t have this type of issue. I wonder why it’s not working. Usually shows soft bank or docomo on the left top corner and that’s not showing anymore and 3G or 4G will shows on the right top corner but I see 4 bars but 3G is showing off and on. This never happened to me. Anybody know how to fix? I called Tmobile and trouble shooting but still not working. 

Any fix for iphones data roaming issues in Japan? I’m seeing the exact thing Sakura described above - seeing 3G shows on and off next to 4 signal bars. Can call/text but no data. All settings are correct and no data roaming block etc on my account. 

If you're in Japan and having this issue. For context on service stoppage in Japan. DOCOMO and T-mobile ended their service agreement at the end of last year so the default no longer is in service you need to do the following and connect to softbank instead.

 

This is the fix I found below on reddit:

 

Found a fix to this for Android. Go into Mobile Networks and select Access Point Name (APN).

Create a new APN with the following details:

Name: (Anything you want)

APN: [epc.tmobile.com](https://epc.tmobile.com)

Proxy: Not set

Port: Not set

Username: Not set

Password: Not set

Server: Not set

MMSC: [http://mms.msg.eng.tmobile.com/mms/wapenc](http://mms.msg.eng.tmobile.com/mms/wapenc)

Multimedia message proxy: Not set

Multimedia message port: Note set

MCC: 310

MNC: 260

Authentication type: Not set

APN Type: default,supl,mms,xcap

APN Protocol: IPV6

APN roaming protocol: IPv4

Bearer: Unspecified

Mobile type: GID

Mobile value: 544D

​

Save this. Restart your phone. When you power it back on go back to mobile networks and select Network operators, unselect automatic. A list of of names will pop up, select Softbank.

Thank you!! This worked.

Thanks this worked for me too!

May 22 2024

Arrived In Tokyo, Japan. 

Tmobile would not work. On Samsung S23+.

Tried many things like rebooting, Connections, Sim Manager, Mobile Networks. Last time i was in Japan (2019) it worked fine without doing anything, but now it wasnt finding any network operators. 

 

Finally what worked is this:

1. Under Access Point Names, click + to add an APN. 

Name : tmob.japan (anything you want)

APN: https://epc.tmobile.com

MMSC: http://mms.msg.eng.tmobile.com/mms/wapenc

APN Type: default,supl,mms,xcap

2.Select this new APN.

3.Toggle airplane mode off and on.

4.Under Network Operators, turn off Select Automatically. 

5.Manually select Softbank

Sent some test text messages to myself and finally received them. 

 

Then Tmobile sent me this text: 

T-Mobile: Welcome to Japan! Your plan includes coverage that gives you unlimited data On Us now at faster speeds up to 256Kbps, plus unlimited texts at no extra cost. Calls are $0.25/min. Want high-speed data and unlimited calling? Get an International Pass: t-mo.co/intl-pass1. Enjoy your stay!

 

All good now. Thanks!

 

Correction: 

MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

Note: "t-mobile" (not "tmobile")for MMSC, otherwise group messages wont work. 

 

Reply