Question

WiFi keeps dropping in Mexico

  • 9 January 2024
  • 5 replies
  • 91 views

Badge

For some reason, if I am connected in Mexico, my phone seems to prefer to use the cell network. My WiFi will connect for a while, then drop and I go back to the cell network. I should say that there is nothing wrong with the WiFi in my home. I have another phone connected as well as a computer, a couple tablets, Google home devices, smart plugs etc. They all work fine. And I’m connected to the Internet over high speed fiber optic. So this seems to be some setting either on my T-Mobile account or on the phone itself.

I’m using a Google Pixel 7 Pro. And it seems to be some sort of preference because if I put my phone in Airplane mode and turn on WiFi while at home, my phone never drops. The connection is perfectly stable.

Any ideas? Has anyone else noticed this type of behavior?

 


5 replies

Userlevel 7
Badge +16

under wifi there should be an advanced settings option that should have a wifi preferred option in there. see if that is selected or not?

Badge

Thanks for your response. I did look under the WiFi preferences and advanced settings, but I didn’t find anything that would prefer the cell network over the WiFi network. I should have also said that last year, I used this same phone while here and never experienced this issue. What changed was that last year, I was using Google Fi and roaming on the Telcel cell network, this year, I’m using T-Mobile and roaming on the Telcel network. I’m also using the same Telmex WiFi as last year. 

Of course, something on my phone may have changed without my knowledge during an update. But the obvious change is that I’m now using a T-Mobile SIM instead of a Google Fi SIM.

Userlevel 7
Badge +16

@syaoran  any thoughts? i havent traveled out of country in a long while..im a bit rusty when it comes to possibilities down there lol

Userlevel 7
Badge +15

I have encountered WiFi networks that do block VOIP from working, including WiFi Calling.  This could be why.  If the option to specify the network preference isn't there.  Put your device in Airplane Mode amd turn on WiFi Calling.  If it works, the device won't have any other option to use anything except WiFi.

Badge

Yes. If I put it in Airplane mode, it never drops from the WiFi and everything works normally. That’s what I’ve been doing when I get back home. But that means that when I leave, I often forget to turn off WiFi mode so I don’t get messages, calls, notifications etc. until I notice. And the reverse is true. I forget to turn WiFi on when I get home, and I’m unable to cast to my devices, because I’m not connected to the same network. There’s nothing wrong with the WiFi, our other phone works perfectly well, and mine did last year as well. So while the Airplane mode workaround is functional, it’s hardly the way I want to live my life. I’d like my phone to just work. And this isn’t just for WiFi calling. It completely drops from the WiFi network, even though the signal is at full strength. So it’s more like a preference. It will connect to the WiFi, then it’s like some preference kicks in and says, “oh, drop that, he wants to be on the cell network.”

Reply