Question

Devices require IPV4, but TMHI is IPV6 only..

  • 5 December 2022
  • 4 replies
  • 1729 views

Badge

I have Whistle dog trackers that require ipv4. The gateway is ipv6 only…is there any way to go around that? considering connecting a router to the gateway. any advice? 

 

Thanks!


4 replies

I had the same issue, even after creating a separate 5G and 2.4 G networks, then remembered I had a TP Link WiFi extender and created 2 more extended networks for both. So 4 total networks, a 5 G and 2.4 G with the t-moble Gateway and a 5 G and 2.4 G with the wifi extender. Worked like a charm on the 2.4 G extended network. The WiFi extender is cheap, so no major investment or hassle.

Badge +1

Curious, what gateway do you have.  May not be relative but I have a T-Mobile hotspot device and was able to create a new APN and have the settings from IPv6 to IPv4v6 to cover both standards.  Should be a way to do it with your gateway.  In my case I had to change it because Roku devices don't support IPv6.

T-mobile is an ipv6 ONLY carrier, unless a business account. Their CGNAT is horrible, absolutely horrible, worse than spaghetti code. The majority of the internet STILL runs on ipv4 tables and this is why there are so many issues with Tmo home internet. You have options though, but they all require a monthly fee, essentially paying someone else to re-route your service to an individual ipv4 address, inbound and outbound. Like i said their ip tables with cgnat are disgusting and there is no fix in sight because tmo at this point could care less. I don’t recommend TMHI to ANYONE unless it is literally the only option available. It is just too much trouble to deal with. Til the day all these carriers are held responsible for the lies and deceit they have pushed over the years, we all will continue to have what we have and just have to deal with it. I had spent over 18 months and a total of 32 tickets trying to get so many things to work correctly with them, in the end I got nowhere and decided to get rid of it and go back to my dsl. Mind you i have 3 towers at perfect distance to my house and no matter what I did the CA(carrier aggregation) was all crap, leaving my connection in limbo, everything thinks its connected when in reality it wasn’t. Without paying someone else (vpn generally) all of my iot devices had so many issues when i was away from the house. Maybe in another 5+ years they will figure it all out, but at this point no one is on the same page and Tmo, atm, doesn’t care. Beware.

Sorry but I could not disagree more with Wicked.  I have use T-Mobile Home Internet for about 9 months. I am running a ASUS mesh network behind it and have turned off everything not needed on the T-Mobile box.  I have about 35 devices hung on the meshnet work and use LocalXpose tunnels to reach those devices remotely.  The system has run flawlessly ever since I completed the installation. The latest devices T-Mobile supplies does not allow WI-FI to be turned off from the interface but a quick Google search will find a hack to make that modification.  

Reply