New Inseego Mifi Issue

  • 26 February 2022
  • 11 replies


I just got my Inseego Mifi device today.  I did the set up.  Put the sim card in and fired up the device.  It worked for 5 minutes before I got an alert that said Invalid Sim.  I rebooted the device to get a “no service” alert.  I had another sim card so I put that one in and activated it and dealt with the same thing.  So I called tech support.  I went through a process of rebooting.  Then was told to pull out the sim, put it back in then hit reset.  This seemed to work but only for 15 minutes.  So this time I went through the process of pulling the sim card out putting it back in then turn on the device.  This time it worked for an hour before I got the invalid sim alert again.  I rebooted to get the no service alert.  Did the who thing over again to have it work for 5 minutes before the invalid sim alert.  Reboot.  No service.  This is not a cheap device so I’m getting really frustrated.  What is up with this thing? 

11 replies


It seems to be working but connectivity is still crap!  I the day after this to be told by tech support that the device was buggy and that there is some software update coming to fix it by mid-March.  First, I’m upset that I’m being charged full price for a service that is clearly unreliable right now and I can’t utilize.  I did call customer service after this.  I’m suppose to receive some type of discount on my bill this month which isn’t showing up right now.  Secondly, I’m really frustrated that I was sold a device that is buggy and it was known.  I’ve been with T-Mobile for about 2 years and have basically been pretty happy till this. 

I’ve been dealing with this since the first week of February. This is an absolute FAIL on T-mobile upper management and Leadership! They have known about this issue with the device before I even reported it and their excuse was…. You are one of the first to come in about the issue. They have YET to disperse this info through the ranks and they are or only wasting our time but their own employees time get communication out and resolving this issue. I was told it was resolved today only to still not have working after over 6 hours of dealing with tech support and then telling me it would take about 2 hours to resolve since for some reason they turned off the data on my device… then told me I used all my data when the device hasn’t worked for over a month. The speculated fix date is March 17th or earlier. I called today just to get a status update. Been dealing with them changing my plan and everything now! Absolutely asinine that a communications company can’t get communication out to their employees! And I totally blame leadership at T-mobile on this! Losing faith that they have the ability to keep the public connected if they can’t even do it internally!


That is incredibly frustrating and I’m hearing you.  I think they should put this device on hold and lock people into a 24 month payment plan for something that isn’t working properly.  And having to pay full price for a month of non-service, isn’t right what so ever.  I’m thinking about taking it back because it can’t do what I need it to do.  Namely Zoom meetings.  

They credited me the $7 device charge and then the $50 service charge for last month. I explained to them it was not ok to charge for a device that is not working. As of today it still says no service. So they will be crediting me again this month, or they will have a headache on their hands. This is already effecting my ability to work as I need it to work remotely. They take no responsibility for that and I get that they will fight it, but THEY are directly effecting my ability to do business without offering me any solution. I do really hope they have a solution by the 17th. My concern and lack of faith currently is they claim it’s all of these devices as it’s going to be a software fix, but can not explain why there are devices that are still functioning. My brother-in-law has had no issues with his as of yet. This lack of communication is just ridiculous and grounds for action.


I hear you.  That is the same problem I’m having.  It seems to work for basic things like email but doesn’t seem to work well with streaming video conferencing platforms like Zoom.  

I believe we resolved the issue. I am I. Store and through much effort we have seemed to resolve my connection issue. Store techs are amazing, at my Store. And upper management stopped in the store and was kind enough to have some conversation with me about communication. Communication on the issue should get better now. I am hopeful. I always have found having direct interaction has a lot better results. I am very appreciative of the effort they made today to take care of my issues and this is why I continue to be a customer. 

Userlevel 6
Badge +9

I believe we resolved the issue.


Can you tell us what the solution was, so others may benefit?


Sorry, I spoke to soon. They corrected my account issue, but there is still an issue with the device. It went back to Invalid SIM error after a short period. I can say this, do not let a tech adjust your account to a Home Internet Plan, this is not the solution, and it was a nightmare to get it back to the correct plan it was on. Best solution at this point is to wait for the software/firmware patch to be pushed on the 17th. I will be following up on this with the Territory Manager. Not ideal, but at least there is progress and I have contact with management that can get a more direct answer.

   There has been communication within the company and it wasn’t in an ideal place for these communications to be seen, so I am told that is being corrected also. The store personnel and the Managers were extremely helpful and went through every effort to resolve things before I left the store. I am confident they will do what they can to move communication up in priority.

Just bought one today. Invalid SIM issue. It's brand new as of an hour ago. I saw a prompt to run software update. It better resolve or Im going to be PISSED this was not brought up to me upon purchase as it is CLEARLY a known problem!! 


This was resolved on March 18th for my device. I used it on Friday, most recently. If a restart or reset doesn’t trigger the update, I would definitely go back and talk to the store. There are notes available on this now. I assured that after my LONG conversations with upper management. Should be easily accessible for support. If they have an issue I would suggest they seek help higher up the chain. Having this issue is unacceptable on a brand new purchase. Sadly, phone support lacks since that person never has to speak to you again. Store staff has more of a vested interest in keeping you happy and not coming back to them with the same issue.

Invalid sim. I’ve been working on this for a month, new sim card, new device.