T-Mobile Home Internet LTE Router Connection Issue

I received my LTE router in the mail a few days ago and everything seems to be working just fine service wise. However, I am having issues with connecting specific devices to the router and logging into the router itself via the IP address and using the user name and password stated.

Device issue: I seem to not be able to connect my Ring Doorbell to the T-Mobile LTE Router. I have tried it many times, followed the help guide for the router and the Ring doorbell several times as well without success. Has anyone else or T-Mobile tested the connection of a ring doorbell to the T-Mobile Home Internet LTE router?

Logging in: I have typed in the IP address, entered the user name and password MANY times and it always says "login failed!". Should I hard reset the router? I wanted to try and avoid this as it took me about 2 hours to connect all my devices the first time and would love to avoid that.




Best answer by myleslz 28 May 2019, 14:12

View original

19 replies

Userlevel 7
Badge +15

If you can't login to the router, a hard reset is something I would consider.  Are you trying to login wired to it or over wireless?  For security reasons, you might need to ne wired to the router to access it.

Some Amazon and Ring devices are very picky about tue wireless security settings and channel the WiFinis set to.  Set the channel to 3, 6, or 9 on the 2.4GHz settings and try setting the security encryption to WPA2-AES or WEP

Thank you for your assistance.

1. I tried the hard reset and that worked. I am now able to log into the device.

2. I tried changing the channels for the 2.4ghz WiFi but the Ring doorbell still did not connect. I ended up calling technical support and they stated that most people are currently not able to connect their Ring devices to the WiFi. So at least this is a known issue by T-Mobile. I will respond back to this post if I find out any additional information.

Userlevel 6
Badge +15

Hmm this is interesting and I do hope this gets resolved for you soon. Did someone on our Tech team file a ticket for you? Have you spoken with any support group at Ring for more help?

I have not received a response as of yet but I was told that I would get a call today or tomorrow.

And at this point, I have not contacted RING support directly but I have used their help documentation but without success. I will contact RING directly to see if they can provide any insight as well.

Userlevel 7
Badge +15

One thing to potentially consider, is the distance of the Ring Doorbell to the router.  WEP might also be eaiser to tinker with until you get it connected. 

I've tested it at 5 ft, 15 ft, and 25 ft. But good suggestion.

I'll look into the WEP but I was told by T-Mobile support it is probably a firmware issue. Ill post an update once I have one.

Userlevel 4

Just checking in to see how things are going 😊 Please let us know if you still need help.

Hello Chris,

Yes, the connection issue is solved. There was a software update last week for the LTE Router/Modem and that seemed to fix my connection issues. This included my Ring doorbell and an off-brand smart plug that I have. At this point, all of my devices connected and are functioning.

Userlevel 4

That is great to hear! Thanks for updating us.

I can’t get my ring doorbell to connect to my LTE router. All of my other devices in my home are connected but the doorbell is causing me a major headache. I’ve entered my password numerous times and the doorbell still will not connect. What else can I do to get the router to connect to the doorbell?

I am having this same issue with 5g MiFi Hotspot


I am having this same issue with 5g MiFi Hotspot

Did you ever this get this resolved?


I just got my 5G Mifi Hotspot from Tmobile today and am having the same issue. All other devices including a Ring Flood Light connect, but the Ring Doorbell 3 errors while trying to connect. it flashes the left side lights after trying to connect to the wifi. so it’s not authenication or lack of signal. I’m not sure what the issue is.


i’ve tried setting up 2.4 and 5.0 separately. I tried DMZ and assigning an IP to the doorbell. i tried connecting to guest hoping it’s less firewall security. I tried disabling IPV6. I tried assigning channels to both 2.4 and 5.0. Nothing works. I have no issues having the doorbell connect to an ATT hotspot that I have for work without having to configure or change any settings.

I’ve made sure both the ring doorbell and tmobile 5G hotspot have latest software installed.



I am not having any luck with this.  I had ring come out and trouble shoot.  They had no success either.  Next option is to go to Tmobile.  The question is, “Where to go for best action.”  The local offices are clueless.  Online is not much better.  I don’t know where to turn.

Userlevel 1

I also cant connect my new 5G mifi to my ring system. It connected to all my other devices no problem but won’t connect to the ring devices? I have tried literally every single idea over two days time with zero success. My ring system worked perfectly until I got my new mifi and it’s like with all these Otgers having the same issue there should be some kind of help. I have already started the tech service support I got through the first person whom walked me back through all I have already done again and no connection. She has since sent me to the next level tech support which I am waiting on a call in like 2 hours! So frustrating 

Userlevel 1

Update: I just first of all was given 100% top notch customer service while on the phone with a few different t-mobile experts- so this is the outcome- I was sold the wrong device. Yes, I like y’all were sold the new Mifi 5G PORTABLE hotspot. This hotspot is not set up for security devices I.e the ring products. You must have their “in home internet service” that comes with a free router and unlimited data for 50 dollars and no contract either. I was super lucky they agreed to allow me to return the Mifi Hotspot and they are refunding my 300 dollar out of pocket cost to get this useless Mifi Hotspot. I did just pass the 20 calendar days when they would normally accept the return by three days but they said it was their mistake so I am so sorry to tell everyone there will never be anything done to allow the hotspot to connect to products like our ring. I highly recommend contacting t-mobile and nicely explain the situation and I wish all of you luck!! 

I couldn’t get my Ring doorbell to connect to my mifi either.  Then I saw post about

setting APN to and IP4.  This worked for a while then tmobile

just a couple of days ago stopped supporting this APN setting.  Couldn’t get

internet to work at all using those settings.  Now back to no Ring doorbell connection.

It worked last year when I had ATT for service. 


I set up my internet router, I wanted to connect rasperrypi dns server to block adds. I do not see any dns server information in the new router, can I add a dns server?

Does anyone else with TNobile internet lose all connection when it rains?

I am having a strange issue.  I have my home internet connection and a extender for some dead spots in my house.  Currently my devices can connect to the extender, but not to the main router. Any idea what the issue might be?