Solved

Timex Smartwatch won't turn o n

  • 25 March 2020
  • 7 replies
  • 6301 views

About family connect timex watch: the watch shut itself off. We charged it, but the charger light stays red. We have not been able to turn it on. When I check the app, it says the watch/phone is 83% charged. Has anyone experienced this? The unit is 4 months old and still in  very good condition. Thanks in advance.

icon

Best answer by montana1929 31 March 2020, 18:27

View original

7 replies

Userlevel 2
Badge +10

The watch might be frozen, so it's already on but the screen just isn't updating. Try forcing the watch to reset by holding Power/Sleep button until it vibrates, should be about 15 seconds.

Userlevel 6
Badge +15

Hi there!

Have you checked out the link Ian posted above? Please check it out and let us know if you need more help.

Hi, and thanks for writing again. I was on the phone for quite some time

with T-Mobile support and we tried various things. A conclusion we came to

was that the charger was defective. It works sometimes it didn't others.

The signal light stays red all the time, even though when you check the

phone it has been charged most of the times. So we are hanging on till

stores open and til stores open and may request a new charger. Thanks again

for your help

I'm having the same problem with my son's watch we got him last month. It's been flaky from day 1, but now it won't turn on at all. It's been charging for about 30 hours now, and still has a red light on the charger. I've tried reseting it by holding down the power button for 15 seconds about a hundred times. I also tried turning it off in the app. All that did was change the status in the app. The watch still won't turn on.

I also tried a different USB cable and a different USB power adaptor. Same problem.

We contacted tmobile support over Facebook and they very quickly offered to send a replacement watch. It was just a watch, no charger. The new watch charges on the old charger just fine. This definitely looks like a watch problem.

Holding down the power button worked for me.  Just to be clear, the power button is not the SOS button.  It's the button on the right side of the watch face, with an open oval.  Take the watch off the charger, hold the power button down for ~15 seconds, until it vibrates.  The 15 seconds will feel like forever.  If it doesn't vibrate, it didn't reset.  This is the second watch I've had issues with.  The first one failed within one month, and I was able to get T-mobile to replace it.  The second one "failed" after 5 months.  Thankfully, the reset worked this time.  I really wasn't looking forward to arguing with T-mobile, or having to setup the watch all over again.  The other downside to a replacement watch is that you get a new phone number, so then you have to update everyone's contacts.  I really wish there were other kids watch options.

After switching to Tmobile from Verizon, I bought my son’s watch almost a year and half ago, and today when he put it on the screen was glitchy. I turn it off, turn it on, reset it and nothing. The watch was completely fine yesterday night. 
Yes, I know I had the watch for over a year now, and it has kinda held up, few issues from time to time, 

but not as great as the Gizmo kids watches from Verizon. It is very disappointing that some of the features in his watch doesn’t work properly now because of the screen. I don’t know what else to do. Help!  

Reply