5G 5G21-12W-A Gateway "Trashcan" Bridge Mode

  • 14 June 2021
  • 8 replies
  • 11740 views

Badge

I have purchased the 5G home internet and off the bat have issues with the “barebones” firmware on the Nokia 5G21-12W-A Gateway.  No ability to dictate port forwarding, enable UPNP, but more specifically turn it into a “dumb modem”.

My home network needs the ability to put my Ubiquiti Edge Router in the DMZ(modem in bridge mode) so my OpenVPN server and Plex server can have public access.

For the first couple weeks I kept my Ubiquity Router connected to fu*king ATT DSL and only put a few devices on the T-MOB GW.  It was pretty unpredictable and unstable.  The last 3 days its been stable with 300Mbps down, and 20+Mbps up and below 50ms ping times.   So on a Sunday with everyone home, I did it. Plugged it in and changed the DNS servers on my Ubiquity DHCP. 

 

It couldn’t handle the throughput.  From my desktop I was running continuous pings to my pubic web server and google.com.  Separately they would become unreachable or timeout, not in succession but at different times.  I’ve got 2 separate tickets open with them now for these issues.  What I am really posting for here is I would like to know if anyone else has similar issues, with 40+ devices on their LAN in a mildly similar configuration?


8 replies

Userlevel 1

Sadly, looks like my experience is similar.  Well, maybe worse.  I received the trashcan yesterday.  Best speeds I’ve seen is about 19/4.5.  More commonly in the range of 10/2 or so.  Always LTE rather than LTEA.  (As a comparison, a Pepwave BR1 Mini with TMO SIM and OEM “rabbit ears” does better in the same location.)

I ran it all night plugged into one of the WAN ports of my Peplink Balance 210 router and had the router set to disconnect the WAN if ping times to reliable hosts (e.g., 8.8.4.4 and 1.1.1.1).   (WAN supervision is highly desirable when using a load-balancing/fail-over router.)  This AM I was greeted with a log showing more than 100 disconnects over night. 

Yesterday I set up WAN smoothing on the Balance 210 for SIP calls to VOIP.MS.   When TMO ISP was introduced into the WAN mix the calls turned to garbage.  In each case I had to return the outbound connection to Spectrum [uuugh] alone -- then all was OK.

Like others, I was unable to set the trashcan in bridge mode or to invoke DMZ.  That’s likely part of the problem but that does not explain everything.

So my experience differs from yours in that the trashcan was unable to handle even the most mild of requirements.   I’ll call tech support today but I’m spring-loaded to pack up this POS and send it back to TMO.    (5G?  Laughable.  I’d just like a rock solid 4G connection and I’d be happy with, say 50/10.  I’m sure it works fine in urban areas where TMO has coverage.)

Userlevel 5
Badge +5

Unfortunately, all inbound unsolicited traffic is "blocked" by design.

 

There was much discussion about this late last year/first of this year, but it has all sloughed off to the back pages now.

 

Basically, it is all tied into how they are managing the dual IP4/IP6 stack situation.  They chose to go the route of 464XLAT, which is a roundabout way of translating v4 addresses to v6 to run packets through their v6 only network.

 

So there isn't a forward facing v4 address space for us to use--it all gets "tunneled" through TMO's v6 network, and then flipped back to v4 when it exits their network.  Without extra layers to manage the port traversal aspect with this process, it screws up a LOT of what people do on their networks--including things as common as voice chat on gaming consoles, cameras, etc.

 

Some people have managed to get SOME applications to behave via VPN, but that can still bring some issues with it.  The 464 tunnel drops MTU down to 1420, so some VPN's need to be tweaked to drop MSS low enough to keep packets under that limit (1320 to 1380, depending on the config).  But this doesn't solve all issues...some VPN's only support known peer to peer style communication for known application standard port assignments--meaning they won't always work with custom numbers.  Some may even require you to pay extra to get a "static" IP (not truly static, they may still change periodically with a "hard" lease renewal, kind of like how cable companies do it).

 

Oh yeah... and we also can't run a pure v6 network on our end either.  We have tried to set up v6 delegation through their older more flexible Askey modems and our routers like we were able to do with our previous ISP's, which APPEARED to work at first... but was a no go in the long run as well.

Userlevel 1

Agreed and understood.  Thanks very much.  But even if PINGS had been returned I would not have had repeated disconnects.  (I’ve not gotten so far as to mess with MTU yet.)

 

I think the “issues” (and barriers to effective use) with this equipment are huge and insurmountable. 

 

As I write this, I’ve been on the phone for about one hour to TMO’s off-shore technical support.  The trashcan is going back to the mother ship. 

Userlevel 5
Badge +5

If you can get them to send you the white Askey LTE modem, you can at least do DMZ.  It has UPnP and manual forwarding capability and all that, which will appease an xbox or playatation's network test and all... but the P2P communications still get broken at the next tier up because of the 464/CGNAT crap. Haven't been able to get remote access to my media server, but at least it works locally for us.

 

It is a trade off... 5G access for a more flexible modem.  In some markets, 4G/5G seem to be performing pretty close to each other during peak traffic times anyway, since their 5G is not standalone (yet)... so the 4G congestion still hamstrings both technologies atm.

Userlevel 1

Hi.  When I called off-shore TMO support and didn’t have a PIN (never assigned or chosen) they would not help me.  I can get past their CGNAT issue but I can’t get past frequent DSL-like speeds, 100-200ms ping times, choppy SIP calls, etc.  So, in this situation 4G/5G would probably not make a difference.  They said I could not ship it back because they could not “verify” me so they said I had to take the trashcan to a store -- which I will do later today.  It’s already boxed up.

I had a lot of hope for this.  Would have LOVED to fire Spectrum.  But it looks like it is not going to happen -- at least until my number comes up for StarLink. 

I very much appreciate your comments.  Thank you.  Just wish I could remain a TMO customer.

 

Any word on getting these into Bridge mode?

Userlevel 5
Badge +5

Any word on getting these into Bridge mode?

Unfortunately, no mention of them addressing the XLAT464/CGNAT implementation that basically makes that irrelevant.

A new "cube" looking modem from a third vendor (name escapes me atm) is slated to start shipping sometime in Q1 2022, but not a whole lot is known about it other than some FCC specs and a limited user manual found online.  Appears to only support the same existing bands, BUT it looks to support aggregation that is currently not available.  So performance could increase somewhat in some markets.  Remains to be seen if we will be able to setup V6 delegation on our own routers or do passthrough again.

 

But until they do something about the heavy handed filtering/blocking that their current upstream networks are doing, bridge mode/port forwarding will not work properly.

Badge

Yeah I think I am going to cancel and return this thing. Too bad because my father has one and gets insane speeds at his place, he lives in another state though.  I am having similar issues.

Reply