sync up tracker goes offline


I recently bought a Sync up tracker. It has randomly gone offline randomly a couple times. Battery still has 30-40% charge when it does it, and the only way I can get it back online is to put it on a charger and hold the power button down. It happens after the tracker has been stationary for 2-3 days. Anyone have thoughts on what causes this?

14 replies

I got 2 syncup trackers a month back.  Initially they would not Onboard at the store, but did about 12 hours later.  Worked for 2 days quite well, then not quit.  All efforts by hard working T-Mobile staff and tech support had not effect.  2 warranty exchange trackers arrived without the internal eSim cards setup, knowledgeable US support spotted that, setup, now working for 2 days  tracking well.  Now the tracker app is failing to connect to the back end servers on all phones, causing failed login and no updates from the apps already logged in.  The whole tracker system is appearing to be a weak effort, not a serious system, no fault-tolerance on the servers, perhaps weak backups,  coding errors on trackers (according to above experiences).  T-Mobile management, you are giving T-Mobile a bad reputation by what ever corner cutting / outsourcing strategy you are using.  Better to have no trackers than a half baked attempt.  It’s also costing your staff and customers large amounts of wasted time.  In my case at least 50 hours at this point,  between 10 to 20 of your staff’s time on just 2 trackers.  One has to wonder if the company has entered general failure mode,  am I also noticing a decline in store front customer service?  Services out of the Philippines is close to pointless.  What’s going on guys.

Looking for specific instructions on how to reset / initialize  … tried deleting and restarting n-times but none of ours have been activated since we switched our phone plan (> 3-weeks) to T-mobile 

I held down the reset button and nothing happened.  I had my new tracker for less than a week and it went offline.


Hold down the button until the little light starts blinking like a xmas 🎄 tree.  I’m not sure the button has any other use.

How do you reboot the tracker?

I’ve had these trackers for several years.  They now work better than before.  Also, I recommend routinely rebooting them every week… just like yur computer or cell phone.

My syncup trackers seems to be failing as well, I have three active tractors working on equipment that I own. Sporadically , it asked me to enter the IMEI numbers or scam the QR codes like im setting up new trackers on this account. Very frustrating because the equipment that I'm tracking is my livelihood and not cheap. Any moderator or T-Mobile technicians that monitor this page, can you help or assist them what's going on ! I remove the app from my device and also cleared memory and cache. Sometimes it comes back online and shows me the real time location, then I attempt to update and it's not updating and not showing the true locations. 

The tracker will give me alerts such as light detection and sometimes update on the tracker in motion, but when I hit the map to check the device location, it'll show a location from hours prior. 

MIne have also been offline for a week now, June 17th weas last communication date. nothing seems to bring them back online.

Userlevel 2

The “Offline” problem has been remedied but as is so often the case, a software or firmware update can cause one problem to be solved at the expense of creating a different technical issue. The SyncUp Tracker application’s “Enable Biometric Login” setting is stuck in the “On” position and cannot be switched off. I have removed the SyncUp application and reinstalled it, to no avail. This is an especially strange anomaly because I never set up and never use any biometric logins on my Android phone. I remind T-Mobile of the unresolved technical issue each month.

I just bought a bundle of 3 this past weekend, installed them and was very happy with my testing...initially. 1 day later I used the app to share the device statuses with my wife. All was well again... 1 day later all 3 device configurations have disappeared from my phone. I called tech support and they said they were not aware of any issues. They obviously have not read these comment chains. It's a great idea but I guess either the hardware or software is lousy. I'm bummed but it won't keep me from returning the devices.

Thanks everyone for describing your experiences here. It's been very helpful. 


Is this problem still going on for others? I bought one last week and it turned itself off after about three days with 25% of battery power still there (according to the app).

Userlevel 2

An application update occurred on or about March 3, 2023. A few days later, the SyncUp device began going offline each day. No matter how long the device was in motion and no matter how many miles the SyncUp device traveled, the device would never go online again without performing a number of steps including, deleting and reinstalling the application, deleting the device from the app, and cycling the power on the device multiple times. Identical problems occurred over the previous few days with a refurbished replacement SyncUp device sent to me by T-Mobile under a warranty replacement.

I spoke with an advanced technical support representative from T-Mobile about the issue. The tech rep said that at least some of the SyncUp devices failed to receive and/or properly load the update information associated with the early March application update. According to T-Mobile, another application update is currently in the works that will hopefully fix the issue.

I’ve had SyncUp for a couple of years now and in the past it has infrequently gone offline maybe once every one to two months requiring a power cycle.  For the month of March, 2023, it has been awful and seems to go offline on a daily basis, while fully charged and in a coverage area.  Even when it’s offline and the tracker moves into a strong coverage area, it stays offline until someone physically cycles power on it.  I’m not sure if it’s a problem with a recent firmware/mobile-app upgrade or if there’s a hardware issue with the device.  Either way, it’s rendering this device useless and I’m close to cancelling the service.  How wide spread is this issue?  How many others are seeing the same behavior?  Thanks...

Userlevel 7
Badge +14

That's why I got rid of mine a few months ago.