Question

SyncUP Drive not reading diagnostic codes

  • 20 August 2022
  • 8 replies
  • 820 views

Badge

I have a new SD 7000T1 and plugged it into my ‘09 Ford F150 for about a week, and over 200 miles driven so far.

The engine health tab still shows that the “information isn’t available right now”.

I have unplugged it and plugged back in, reset it. Driven without it, then driven with it and tried it again. Still nothing.

 

Any suggestions?


8 replies

I have a 2008 F250 Diesel and the Sync Up Drive keeps setting EV charging codes 😂😜🤪🤣🤫🤦‍♂️. I guess I can now apply for EV tax credits. I got this thing because T-Mobile couldn’t get internet to work on my SIM in my new Phoenix Tesla style stereo 🤦‍♂️

I also am noticing the same thing and it's actually kinda funny because I just upgraded from the legacy which was able to read my engine but was a bit slow and now the stupid thing won't read anything and is constantly saying unplugged

(possible duplicate)

Bad experience with SyncUp-Drive --  Worked satisfactorily for 5 months.  (A couple of modest issues, like not being able to clear old trips.  Want only 7 days, erase older.)  MAJOR issue started in August with FOUR Engine status codes.  Took car to shop.  They confirmed the same codes with Professional Diagnostic Tool.   Afterwards, reinserted Sync-up Drive.   Never was recognized.  Most recent info (car location) shows still at repair shop.  Still shows the 4 error codes.  Lacks detailed instructions for users who like to dig into the weeds.  TMobile (corporate) Store personal tried to help, discovered internal doct revealing a reset pin.  Tried that, no joy.

Badge

I’ve talked to TMobile several times.  One rep said she found out it’s something wrong in their program and TMobile is trying to fix it.  I don’t really believe so.  Other reps don’t seem to know there’s a problem….if there’s a problem why wouldn’t they let customers know.  
I’ve done everything to include deleting App and starting over.  It’s just the engine health.  I can read battery and gas info, I get notice when my car starts and stops.  Just no engine health.  If you get yours fixed please share .  Thx

I have a Cadillac XTS and I am having the same problem. Just trying to find a fix

Badge

Did you find a fix?  I’m on my second Syncup device. Both would read gas and battery health but “unable to read engine health”. Spent lots of phone time with TMobile but still not working. 

I have 3 vehicles.  
2018 Nissan Titan, 2017 Ram 1500, and 2004 Ford Ranger and I just got 3 drives yesterday.    

None are showing the engine diagnostics.    
They made me upgrade from the Sprint Drive to this SyncUP Drive crap.    
sprint drive was so much better.   
If they don’t start working, I will be canceling my service.    

I am having the same issue. I drive a 05 Ford Taurus. Engine health hasn’t worked since I got it. Tech support was no help but they’re ordering a new device so MAYBE that will work. If not I’m obviously canceling the “service”. 

Reply