SyncUP Drive not reading diagnostic codes

  • 20 August 2022
  • 5 replies


I have a new SD 7000T1 and plugged it into my ‘09 Ford F150 for about a week, and over 200 miles driven so far.

The engine health tab still shows that the “information isn’t available right now”.

I have unplugged it and plugged back in, reset it. Driven without it, then driven with it and tried it again. Still nothing.


Any suggestions?

5 replies

I am having the same issue. I drive a 05 Ford Taurus. Engine health hasn’t worked since I got it. Tech support was no help but they’re ordering a new device so MAYBE that will work. If not I’m obviously canceling the “service”. 

I have 3 vehicles.  
2018 Nissan Titan, 2017 Ram 1500, and 2004 Ford Ranger and I just got 3 drives yesterday.    

None are showing the engine diagnostics.    
They made me upgrade from the Sprint Drive to this SyncUP Drive crap.    
sprint drive was so much better.   
If they don’t start working, I will be canceling my service.    


Did you find a fix?  I’m on my second Syncup device. Both would read gas and battery health but “unable to read engine health”. Spent lots of phone time with TMobile but still not working. 

I have a Cadillac XTS and I am having the same problem. Just trying to find a fix


I’ve talked to TMobile several times.  One rep said she found out it’s something wrong in their program and TMobile is trying to fix it.  I don’t really believe so.  Other reps don’t seem to know there’s a problem….if there’s a problem why wouldn’t they let customers know.  
I’ve done everything to include deleting App and starting over.  It’s just the engine health.  I can read battery and gas info, I get notice when my car starts and stops.  Just no engine health.  If you get yours fixed please share .  Thx