syncup kids watch school mode


Hi folks. I got the SyncUP watch for my kiddo yesterday, and I can’t get the school mode schedule to work. I set up a schedule, but it is not following the schedule. It’s randomly turning itself off and on, almost like the time is wrong. Is it a time zone issue? Has anyone run into this? The watch updated last night, so that shouldn’t be the problem. 

11 replies

Having the exact same issue. School schedule was supposed to end at 5:03. Received a notice that school mode ended at 8:03. Wondering if there is a time zone issue. 


Yes, I went back and checked and it’s exactly 3 hours later than it should be. Are you in the Eastern Time Zone? I wonder if the new update made this feature stuck in Western time. It’s not like the watch is displaying the wrong time!

Having the exact same issue. School schedule was supposed to end at 5:03. Received a notice that school mode ended at 8:03. Wondering if there is a time zone issue. 


Yes, I’m in the eastern time zone. 

Same here! (And yes I’m in EST) I emailed T-Mobile, awaiting response. I’d love to get this fixed:) 

I think you guys are onto it. We’re seeing a 1-hour discrepancy in the Mountain Time zone. We’ve only had the watch a couple days and are still trying to figure it out.

I had a slightly different response… first, I have two watches which ran through a million updates last night, and still resulted on each watch being on different firmware versions (one on 1.1.7 and the other on 1.1.9).  However, I got notification that school mode ended EXACTLY 2 hours after the scheduled start time even though they’re scheduled to stay on 6hrs and 35min (end at 3:30pm but it ended at 10:55am).  Now, I also found that they had started BEFORE the scheduled start time of 8:55am as they were already in school mode before getting them on their wrists at 8:40am.  So I am not sure if it did in-fact run for the full 6+ hours but started overnight.  I am also EST.

I was thinking about getting one of these, but if school mode hasn’t been fixed yet, I will hold off.  Every review and forum post I see complains about this.  I wish I could tag support in this thread to get it bumped up.

I’m currently experiencing this issue of a three hour delay (located in EST zone). The watch is great, and this is only a MINOR concern, but still an inconvenience. (For comparison’s sake, the watch is leaps and bounds more reliable than our previous one (Timex Family Connect).) I would normally assume this kind of issue would be corrected in the next update, but considering the original post is 2 months old, I haven’t much faith. Until this issue is corrected, I’ll just offset the School Mode times by 3 hours.

I have almost the same problem, except that school mode is still on since last Friday and I can’t figure out how to turn it off, I rebooted and deleted the school mode from the app but my daughter’s watch is still in school mode. I just talked to tech support and they are sending me a new one, they couldn’t do anything about it because those watches are not like cell phones and can’t be fixed remotely.  

This is still not working in January, 2023. I have two of these devices, both on firmware 1.2.10, live in the eastern time zone, and both are exactly 3 hours off in terms of enabling and disabling school mode. It seems like this should be an easy programming fix for devices that sync their time with a cellular network. Disappointed that I’m forced to do the math and make the adjustment to get this to work as expected.

Update to this issue. Looks like the time zones are finally in syncopation! At some point last week (Feb. 20-24, 2023), my son’s watch started making noise 3 hours before school mode should’ve ended. I tested the school mode time settings tonight and they (finally) correctly reflected EST. No more 3 hour offset!