Syncup tracker won't update

  • 27 November 2023
  • 7 replies


My syncup tracker keeps giving me a message that the firmware update has failed and it will try again later.  I've tried everything I can think of and still waiting on support to get back to me.  I was wondering if anyone else is having this issue. 

7 replies

I have the same issue for over a week now.  Trackers are plugged in and on and my phone signal strength is excellent.


I have had the same issue since day one on November 7th. I got the 3 tracker and home internet bundle. Two of the trackers have worked perfectly but the 3rd has never worked. I'm not on the 3rd replacement and it doesn't work. I've been been the store and on tech support so many times I lost count. I refused to buy a new one or add another line. I feel like there is something wrong with the phone number assigned to it but no one listens to me. I need this to put in my wife's car as it has been stolen once already. This 18 year customer is very unhappy. 

Userlevel 2

For a few weeks I have been receiving the message, “Tracker firmware update failed and will try again”. My SyncUp device is fully charged and connected to the T-Mobile network. T-Mobile technical support provides little to no assistance. Technical support agents, purportedly well versed in the technical nuances involving the SyncUp Tracker, know less about the device than I do. For example, they are completely unaware of the differences between a firmware update and a software update. The only thing technical support can do with any efficiency is waste my time and bother me with return phone calls that are completely irrelevant to the technical problem I’ve reported.

Same here, it tells me i need an update, then does Absolutly nothing, have uninistalled and resetup. Hopefully someone from Tmobile replies???!!!

Same issue for a few months. I've left them on and plugged in for days at a time but no dice. I've had them in multiple cities and countries - always w great signal strength. Something is clearly borked. 

Userlevel 2

Still no solution from T-Mobile in reference to the firmware update failures, so I turned to the manufacturer of the SyncUp Tracker device, TCL. All I received from TCL was customer disservice ad nauseam. The first, apathetic and inept TCL representative I spoke with claimed the only way to receive technical support from TCL was through a 3-way phone call between the customer, T-Mobile and a TCL tech support agent. Later that day, a T-Mobile supervisor generated the three-way phone call, but the TCL agent refused to provide any support. The TCL representative would not even detail the steps necessary for a successful firmware update on their own device. I scheduled a callback from a TCL supervisor, but, over a week later, I never received a response. Multiple calls to TCL proved pointless and exhausting. One TCL customer disservice agent would not so much as confirm that TCL was, in fact, the manufacturer of the SyncUp Tracker. She also said TCL policy permitted her to schedule a callback from a supervisor, but there was no guarantee the customer would ever receive a call from anyone at TCL. TCL touts itself as a company that “cares for our users” but the only care I received from the multiple TCL representatives I spoke with was woefully negligent and inconsiderate.

Since my SyncUp Tracker is still under warranty, a T-Mobile agent I spoke with said T-Mobile will exchange the SyncUp device with a “5-star” refurbished replacement. The agent could not assure me that the “5-star” replacement would have the latest firmware update or that the device would be free of the same problem preventing my current SyncUp Tracker from updating its firmware. The refurbished device has a paltry, 90-day warranty. Additionally, a $5.00 warranty exchange fee would be charged to my T-Mobile account.


After almost 3 months of issues, my tracker finally updated randomly last night (1/28/24).  Not sure if someone finally fixed something or it just finally came though, but I’m happy that I won’t have to be getting all the notifications that my firmware failed to update.