Question

T-Mobile Home Internet + Google Nest WiFi


I purchased T-Mobile Home Internet and just set it up. When I plug the Ethernet into my Google Nest WiFi router, it does not work. Does anyone know how to get the T-Mobile Home Internet working with a Google Nest WiFi mesh network?


15 replies

Userlevel 7
Badge +14

Have you tried putting the Nest into AP/Repeater mode?

Userlevel 6
Badge +14

Have you tried the suggestion above? We do have our Tutorials | T-Mobile Support page for installation steps that can be helpful. Otherwise, getting in touch with our Tech care team to go through more thorough troubleshooting is another option.

Was this questions resolved? I’m planning on buying the Google WiFi mesh routers and I’m worried it won’t work with my T-Mobile Home Internet gateway.

Yes!!! I know how.  Could not find online, could not resolve with technical support 1+hour phone call.  The WAN port is not active on the T-Mobile Gateway, do not try and use it.  Plug Google Wifi point into the LAN of T-Mobile Gateway and the Internet WAN of the Google Wifi Point.  Then you need to assign the Google wifi point an IP address in the range of the Local LAN T-Mobile Gateway (Reset to default if this has been changed).  I just picked a random 192.168.2.XXX in the range (100-150 default I think, I used 102) Subnet 255.255.255.0 and Domain 192.168.1.1.  The wifi point then finished setup and my existing devices connected back up to it after I gave it the same name/password as my prior network.  I then using wif on a computer (can not do it in the phone app) to turn off both wifi bands (the one I wasn’t on first and then the one I was on).  Unplugged everything and moved to better location and it all worked when powered back up.  *Note - the app will no longer work but you can log back into the gateway page using the 192.168.1.1 admin and your password, alternatively you could do a hard reset on the gateway to get back in using default wifi.

Yes!!! I know how.  Could not find online, could not resolve with technical support 1+hour phone call.  The WAN port is not active on the T-Mobile Gateway, do not try and use it.  Plug Google Wifi point into the LAN of T-Mobile Gateway and the Internet WAN of the Google Wifi Point.  Then you need to assign the Google wifi point an IP address in the range of the Local LAN T-Mobile Gateway (Reset to default if this has been changed).  I just picked a random 192.168.2.XXX in the range (100-150 default I think, I used 102) Subnet 255.255.255.0 and Domain 192.168.1.1.  The wifi point then finished setup and my existing devices connected back up to it after I gave it the same name/password as my prior network.  I then using wif on a computer (can not do it in the phone app) to turn off both wifi bands (the one I wasn’t on first and then the one I was on).  Unplugged everything and moved to better location and it all worked when powered back up.  *Note - the app will no longer work but you can log back into the gateway page using the 192.168.1.1 admin and your password, alternatively you could do a hard reset on the gateway to get back in using default wifi.

Thanks for this! Do you think this will cause problems with double nat? I’m trying to decide on the Google Wifi, Nest Wifi, or Eero 6 that seems buggy right now but can also be put into bridge mode unlike googles wifi’s. Does double nat slow down speeds to everything or just affects gaming? I was thinking of plugging my xbox directly into the tmobile lan port and google wifi into the other lan port and have everything connected to google wifi but my xbox being directly wired. 

Badge

I'm curious about that, too. I am moving in a month. My plan was tmo home internet, using my existing Nest WiFi mesh. If I'm going to have double nat issues, then that could change the isp I choose.

I just set up my T Mobile Gateway with Google WiFi Mesh as well as Sonos controller on 1-8-21. 

The Summary: Drop dead simple. 

The T Mobile High Speed Gateway is the Grey one that is Tube shaped. (I was not sure i was shipped the right hardware when it was not a small book shaped device). The Google mesh has 4 Google hardware pieces to create the mesh around the House, and the Sonos has speakers all around the house. Ethernet connection from the TMobile Gateway to the google Mesh. From the google mesh device ethernet cable to Sonos controller. Then just followed the instructions on the app TMO has you download on your phone. The google mesh just lit up and had the same network settings that i had before disconnecting from Xfinity. 

I had set hours aside, had my headset ready to go, laptop up, all ready call the TMO helpdesk. probably took 30 mins, 10 minutes of that was connecting up the hardware. 

Speed seems fine, ran 4 tv’s connected via Kindle Firestick at the same time, sonos, and on the internet on laptop, seemed fine. We don’t have gamers here though. thumbs up. Giving it a few days before i call Xfinity to cancel, but so looking forward to that. 

Userlevel 2
Badge

I have a TP-Link Deco M9 Plus mesh router system that used to be connected to a cable modem for internet service. After setting up the T-Moble home internet device and making sure that it was working properly, I just unplugged my Deco from the cable modem and plugged it into one of the two LAN ports and after rebooting the Deco, everything worked fine. All the 30+ devices already signed into the Deco Wi-Fi continue to work normally. I have my gaming laptop signed into the T-Moble Wi-Fi directly to minimize lag. Doing a speed test on my laptop, I was very pleased to get a download speed of up to 200!

Userlevel 2
Badge +2

Same here with Orbi Router and two Satellites.   

Disconnect Orbi Router from cable modem and connect to T-Mobile High Speed Gateway ethernet port.

Log into Orbi router and change to Access Point mode.   That’s it.

Leaving both Wi-Fi networks active does not seem to be a problem.   The Gateway and Orbi Router auto-selected channels for 5G and 2.4G that did not overlap. 

I don’t think the T-Mobile Gateway supports Bridge mode.

Same here with Orbi Router and two Satellites.   

Disconnect Orbi Router from cable modem and connect to T-Mobile High Speed Gateway ethernet port.

Log into Orbi router and change to Access Point mode.   That’s it.

Leaving both Wi-Fi networks active does not seem to be a problem.   The Gateway and Orbi Router auto-selected channels for 5G and 2.4G that did not overlap. 

I don’t think the T-Mobile Gateway supports Bridge mode.

It doesn’t support bridge mode, per se, but you can disable the SSID(s) through the web interface at 192.168.12.1. The username and password can be found on the bottom of the device, unless you changed it when you first set it up. Once logged on:

  1. Navigate to Network>Wi-Fi Networks>2.4GHz
  2. Scroll down to Enable SSID, and click the slider to disable
  3. Click “Save”
  4. Give it a second to save, then click “Ok”
  5. Go back to the SSID selection, and do the above for each SSID

Make sure you click “Save” before moving on to the next SSID, otherwise the previous changes won’t save. You should only have to change (under 2.4GHz) SSID1, and (under 5 GHZ) SSID5 and SSID9. Once you’ve gone through and confirmed each SSID has been disabled, click on Statistics>WLAN to confirm you’re all good and disabled.

You may be tempted to also disable Enable Broadcast; however, I prefer leaving this enabled so you have a another way of verifying all the SSIDs are disabled. If you disable broadcast and the SSID itself hasn’t been disabled, the SSID won’t show up in the typical connection dialog on your devices, but it can still be found by savvy users. On the other hand, if the SSID is disabled, broadcasting is going to be automatically disabled behind the scenes by default.

This should effectively disable Wi-Fi on your T-Mobile gateway, so now you can then just use the software for your mesh system to manage your network.

NOTE: changing these settings will still allow web access to the admin menu at the address above.

P.S. here is the link for the web interface manual in case anything changes: https://www.t-mobile.com/support/devices/web-user-interface-t-mobile-lte-wi-fi-gateway

Same here with Orbi Router and two Satellites.   

Disconnect Orbi Router from cable modem and connect to T-Mobile High Speed Gateway ethernet port.

Log into Orbi router and change to Access Point mode.   That’s it.

Leaving both Wi-Fi networks active does not seem to be a problem.   The Gateway and Orbi Router auto-selected channels for 5G and 2.4G that did not overlap. 

I don’t think the T-Mobile Gateway supports Bridge mode.

It doesn’t support bridge mode, per se, but you can disable the SSID(s) through the web interface at 192.168.12.1. The username and password can be found on the bottom of the device, unless you changed it when you first set it up. Once logged on:

  1. Navigate to Network>Wi-Fi Networks>2.4GHz
  2. Scroll down to Enable SSID, and click the slider to disable
  3. Click “Save”
  4. Give it a second to save, then click “Ok”
  5. Go back to the SSID selection, and do the above for each SSID

Make sure you click “Save” before moving on to the next SSID, otherwise the previous changes won’t save. You should only have to change (under 2.4GHz) SSID1, and (under 5 GHZ) SSID5 and SSID9. Once you’ve gone through and confirmed each SSID has been disabled, click on Statistics>WLAN to confirm you’re all good and disabled.

You may be tempted to also disable Enable Broadcast; however, I prefer leaving this enabled so you have a another way of verifying all the SSIDs are disabled. If you disable broadcast and the SSID itself hasn’t been disabled, the SSID won’t show up in the typical connection dialog on your devices, but it can still be found by savvy users. On the other hand, if the SSID is disabled, broadcasting is going to be automatically disabled behind the scenes by default.

This should effectively disable Wi-Fi on your T-Mobile gateway, so now you can then just use the software for your mesh system to manage your network.

NOTE: changing these settings will still allow web access to the admin menu at the address above.

P.S. here is the link for the web interface manual in case anything changes: https://www.t-mobile.com/support/devices/web-user-interface-t-mobile-lte-wi-fi-gateway

This worked like a charm! I am

using my Google Nest WiFi mesh network to provide a fast and reliable network for the whole house. Thank you for this post. 

I just set up my T Mobile Gateway with Google WiFi Mesh as well as Sonos controller on 1-8-21. 

The Summary: Drop dead simple. 

The T Mobile High Speed Gateway is the Grey one that is Tube shaped. (I was not sure i was shipped the right hardware when it was not a small book shaped device). The Google mesh has 4 Google hardware pieces to create the mesh around the House, and the Sonos has speakers all around the house. Ethernet connection from the TMobile Gateway to the google Mesh. From the google mesh device ethernet cable to Sonos controller. Then just followed the instructions on the app TMO has you download on your phone. The google mesh just lit up and had the same network settings that i had before disconnecting from Xfinity. 

I had set hours aside, had my headset ready to go, laptop up, all ready call the TMO helpdesk. probably took 30 mins, 10 minutes of that was connecting up the hardware. 

Speed seems fine, ran 4 tv’s connected via Kindle Firestick at the same time, sonos, and on the internet on laptop, seemed fine. We don’t have gamers here though. thumbs up. Giving it a few days before i call Xfinity to cancel, but so looking forward to that. 

I essentially did the same thing, without the Sonos complication. But what I am seeing is no impact to downloads, but a huge hit to uploads. I've tried enabling/disabling iPv6 and changing DNS from automatic to use ISP DNS on the Nest router with no change in results. Everything else is fine except uploads.

 

Edit: I tried the SSID enable/disable thing above and it made no difference that I could see, only removing the option of uploading more quickly by jumping on the T-Mobile Wifi.

I purchased T-Mobile Home Internet and just set it up. When I plug the Ethernet into my Google Nest WiFi router, it does not work. Does anyone know how to get the T-Mobile Home Internet working with a Google Nest WiFi mesh network?

Hi! I just received my router (the silver cylinder). I was a little nervous about interoperability given some of the earlier responses. I’m happy to report the process (literally) couldn’t be easier.

You just have to connect the Google Wifi Nest router to the T-Mobile router with an ethernet cable, and everything sets itself up automatically! No reconfigurations or extra steps necessary. It took me (without exaggeration) 3 minutes. 

Agreed.  If your mesh system was set up plugged into some other modem you just unplug it from there and plug it into the tower/trash can and between Google Home and your phone logged into the mesh system, it does it all. I guess it must get info from the phone about the new network? I just did a factory reset the other day on the mesh system and that part was totally painless. (I had stupidly removed permission from a speaker of all things to access my Google account.)

Badge

So I looked farther after I made this post. I got it to where I could plug my computer directly into the T Mobile device and the location was incorrect. I would type “wheremai” and check the computer vs the mesh. They were in agreement. The help people said everything looked good that hey could see so they though I had a bad device. Every time I powered it on it came up in different major cities. The people at the store are always great. The only problem was that their system would not let them exchange it for a working device. They had to order one to replace the broken one. I hate that. I was getting about 350mbps with the hub. Sadly to say I had to come home and hook my cable modem back up. The really interesting data point was I could power the Tmobile device and ask what time it was to the mesh. It had the correct but as soon as I asked for something regional like the weather or location the time would change to the zone it was reporting from. I would love to have been able to reload the software and firmware. I suspect that would have corrected the issue. I was a little surprised they couldn’t even do that in the store.

Lesson 1: No matter how great the box works:

Keep the receipt and the original box. That seemed to tilt them a little at the store. They had boxes in the back. I wish I could have walked out with a new box as opposed to waiting now on shipping leading me to

lesson 2:

Don’t turn off your current provider until you have run with the new box for a while. Had I turned off my COX cable I would have to live with weather from other places and alarms going off for the wrong time zones.

For the people asking about the mesh my observations from the mesh correlated directly with what I had without the mesh. I am certain that the mesh had nothing to do with this and was working fine other than this bug. I have no doubt that the mesh will work great as always. I have thee hubs on my mesh and a Google Home. They all worked great. I don’t think I had any compatibility issues. I just plugged everything in and it worked.

Reply