Problem with T-Mobile Home Internet app

  • 19 December 2022
  • 16 replies

Userlevel 5
Badge +6

I've got an Arcadyan KVD21 5G Gateway from T-Mobile and used the T-Mobile Internet app to configure it. Everything is working, but when I try and launch the app on my phone, it flickers or a millisecond on the gateway home page, then goes to the initial screen (the one with the magenta “T”) and I just get a spinning gear icon for as long as i leave it there.

I try killing the app, but when it's relaunched, the same thing happens. I deleted the app and then reinstalled it from the App Store, but the problem still persists.

The weird thing is that sometimes, like first thing in the morning, it connects with no problem. Go figure!

Is anyone else having this problem, and if so, have you solved it?

As always, thanks in advance for any insight.

16 replies

Userlevel 7
Badge +8

You don’t state which phone type you have. Is it Android or iOS based operating system. I find the application works better on an Android but stinks on Apple iOS. It takes patience and persistence to get it to work on my iPhone 12 Pro. If it does not work after 6 attempts I usually give up on it and move on to something else. 

“Is anyone else having this problem, and if so, have you solved it?”

Yes and No

It does what it wants when it wants to. Very problematic on an Apple iPhone it seems.

Userlevel 5
Badge +6

It's an iPhone 12 Pro. The only “solution” is to shut down the iPhone and restart it. Once it restarts, I can gain access.

Userlevel 7
Badge +8

Sometimes that is true. I agree but I have not seen that to be consistent. I have the Nokia so the mobile application is of little interest to me. I can use other tools to get information on the devices on the network and I don’t need to control other devices for access time so life is good. 
I did find that on some occasions if I disable the wireless connection on my iPhone and then enable it sometimes after doing so I can get the home internet mobile application to work but that is still hit or miss. 

I have Arcadyan and seeing same problem on my iOS devices (iPhone 14 Pro, iPad Air).  One workaround is to disconnect WiFi, force quit and relaunch the app, and allow app to help you reconnect.  It doesn’t fix the problem though because you have to do this every time and it can be slow to reach the “help connect” point.

Same issue here.  iphone 12 pro. 

I’ve got the qr code saved in a onenote on my pc.  I delete the app from my phone whenever I need to use it and scan the qr code to download and reinstall the app, it does the location popups for iphone and then asks for the popup to connect to the tmobile ssis and it seems to work every time.  Very annoying, my guess is it does not save the location approval to the phone and the app thinks it has been approved. ergo waiting for the approval that never comes. 

Userlevel 7
Badge +8

I hav not found anything that has fixed the mobile app on the Apple device. It works ok on my old useless Pixel phone. It works on Android but is not well implemented for iOS. 

Userlevel 7
Badge +8

If T-Mobile is going to force users to try to use the flakey mobile application on an iOS device they need to fix the flakey home internet mobile application. If they can’t seem to fix it so it functions on an iOS device they should bring back the web GUI for management of the newer gateways. When the Arcadyan gateway first released it worked with the web GUI. Then the first firmware update was released and they crippled it so the web GUI was no longer able to access the gateway. I get that they want to dumb it down for setup but the user experience with the home internet mobile application is so bad on an iOS phone or iPad. If the mobile application is only pseudo functional for the initial setup when using an iOS device and then is nothing but unreliable after it is setup that is just wrong. 

Same experience here on iPhone 13 iOS 16.1. The app flashes the Home Screen for a millisecond then  goes to the logo with the spinning icon…forever. Have to delete the app and reinstall to make it work again.  Ridiculous!

I found the solution to the T-Mobile Internet app hanging on open on iPhone. You have to be logged in to your T-Mobile account in the other T-Mobile app. Not sure if it’s a bug or security. 

App doesn’t work while logged in to the other app also. Anyone have a solution? The app is garbage. I’m on IOS 16.2, iPhone 13. 

I am running the T-Mobile Internet app on an IPhone 14 Pro Max running IOS 16.3.1. The app launches just fine but the most important tab, the device tab does not work. Trying to locate devices the app will show the spinning icon but never connect. In fact this causes the app to freeze up making it impossible to go to other tabs. Customer service’s solution was to unplug the gateway then refresh my instance. After my gateway rebooted the device tab worked.  That’s the good news, the bad news was the second time I used the app the device tab once again froze up. This is very disappointing since there is no way to manage the connected devices without the device tab.  Please fix this app or at least give us a web based access solution. Note my gateway is the FAST 5688W. 

We still don’t have a fix?  When i first got the Arcadyan the T-Mobile app worked wonderfully.  This was about a year ago.  Now I’ve noticed I cant do anything.  I can barely get into the app.  My main purpose of using the app is to manage the devices that are logged onto my network.  You can forget it. If I manage to get into the app itself I shouldn't even try to select the devices tab.  I will get the spinning gear “forever”. Come on T-Mobile what are you’ll doing.  What is the fix? Im on an Iphone XR with latest IOS.  Again this feature worked fine months ago. 

having the same issue. The internet is working fine but the app is just useless at this time

The app keeps hanging on old iPhone running iOS 16.7.2.

The app not reliable at all.

I am having the same issue after updating my iPhone 13. Is there a website that can be used instead of the app. I need to make adjustments to our wifi and the app simply will not work. Deleted and downloaded again, cut phone on and off, disconnected from wifi and forced to reconnect and it gets stuck there. I am out of options. 

I have the same problem.  After 2 days and about 4 hours on the phone with multiple support people and being told more than 6 times to delete the app and reinstall it, still not working.  I am not impressed with T-Mobile support or their app.  If they don’t want to fix it they should remove it from the app store.