Question

Unable to use T-Mobile Home Internet with work VPN, any suggestions?


Userlevel 1
Badge

I’ve recently been told by work Information Services that I cannot use my work laptop with T-Mobile Home Internet.   Here is there response to my support request.

 

T-Mobile's primary service called "5G Broadband" is not true wire-to-site broadband.  While Cisco AnyConnect can work over 5G and other wireless connections, MTS does not recommend its usage unless absolutely necessary, and if you utilize a phone line such as Cisco Jabber call quality cannot be guaranteed.

The issue is that while 5G can provide broadband level speeds and bandwidth wireless solutions, such as 5G, have a higher tolerance for "packet loss."  Packet loss is when individual pieces of data are dropped/lost during transmission.  For most applications this is a minimal issue that 5G speeds may render unnoticeable, but a live connection, such as the AnyConnect VPN or Voice Over IP phone services, will experience connection degradation or be completely disconnected forcing you to reconnect.

This is not an issue MTS can mitigate.  For this reason the only recommended Internet service types are fully wired based connections including DSL, Broadband, Cable, and Fiber Optic services.

 

Does anyone have a suggestion on a way to work around this issue?  It does not need to be perfect, but being able to work from home is essential, and if I can’t use TMHI to do that… it would be a deal-breaker for me.


108 replies

So I did also just find out it appears to be a Modem issue.  If you have the “sagecom” modem it seems to be specific to that.  Go into your local tmobile store and see if they have one of the other 3 brands.  I did it and now my cisco VPN is working fine.  Took 5 minutes for them to exchange it out for me at the store

So I did also just find out it appears to be a Modem issue.  If you have the “sagecom” modem it seems to be specific to that.  Go into your local tmobile store and see if they have one of the other 3 brands.  I did it and now my cisco VPN is working fine.  Took 5 minutes for them to exchange it out for me at the store

Hi Tom,

Could you share the make or model you got as a replacement for the Sagemcom gateway?

Thanks!

So I did also just find out it appears to be a Modem issue.  If you have the “sagecom” modem it seems to be specific to that.  Go into your local tmobile store and see if they have one of the other 3 brands.  I did it and now my cisco VPN is working fine.  Took 5 minutes for them to exchange it out for me at the store

Hi Tom,

Could you share the make or model you got as a replacement for the Sagemcom gateway?

Thanks!

I ended up with the Arcadyan.  That's the manufacturer but apparently there are 2 other ones that work as well.

So I did also just find out it appears to be a Modem issue.  If you have the “sagecom” modem it seems to be specific to that.  Go into your local tmobile store and see if they have one of the other 3 brands.  I did it and now my cisco VPN is working fine.  Took 5 minutes for them to exchange it out for me at the store

Hi Tom,

Could you share the make or model you got as a replacement for the Sagemcom gateway?

Thanks!

I ended up with the Arcadyan.  That's the manufacturer but apparently there are 2 other ones that work as well.

Great. Thanks for sharing Tom!

Finally spoke to someone who knows what’s going on in their tech team, Travis. He called all the local stores and found one, one single store, with a modem that should work (1st edish Arcadyan?). I have 3 different VPNs and none of them are compatible with the sagemcom gateway tower. Global Protect, Forticlient, Zscaler. I will check back in once I get the new one and get it all set up. Stand by and send your prayers! Hah

tom2t- mind sharing what city or metro area you’re in? I have hundreds of options and could spend an entire weekend looking for the right one. IDK where to begin. My closest local store gave me the same damned one- this before the tickets came flying in and none of us had any idea what was going on. Even though I shouldn’t I’d even buy one at this point. Life is hell working off of my hotspot, well slightly less than hell since I can still WFH. 

tom2t- mind sharing what city or metro area you’re in? I have hundreds of options and could spend an entire weekend looking for the right one. IDK where to begin. My closest local store gave me the same damned one- this before the tickets came flying in and none of us had any idea what was going on. Even though I shouldn’t I’d even buy one at this point. Life is hell working off of my hotspot, well slightly less than hell since I can still WFH. 

I'm in the Seattle tacoma metro area.  I'd just keep calling around or ask your local One if they can get anything OTHER THAN a sagecom.  There has to be a store near you with a different model

tom2t- thank you! I’m in LA so hoping my chances are good! 

Btw- anyone else notice since the collapse of T-Mobile VPN connections a corresponding “weak security” right underneath your WiFi name?

tom2t- mind sharing what city or metro area you’re in? I have hundreds of options and could spend an entire weekend looking for the right one. IDK where to begin. My closest local store gave me the same damned one- this before the tickets came flying in and none of us had any idea what was going on. Even though I shouldn’t I’d even buy one at this point. Life is hell working off of my hotspot, well slightly less than hell since I can still WFH. 

You need to get a different modem for the VPN to work. I exchanged it for a Nokia 5G21 Gateway(gray color) since T-Mobile can’t give me the new white modem. I called the T-Mobile customer service. one of the tech reps was aware of VPN issue. He was able to locate an old Nokia Modem for me in my area. I went to the store to picked it up. The VPN works fine with Nokia 5G21. However, I noticed that the connection signal isn’t as strong as sagecom.

 

Here is a picture of the Gateway.

https://www.t-mobile.com/support/home-internet/nokia-gateway

HotSpotPet, thanks for sharing. Will be on it shortly. Unfortunately 1st two reps I’ve encountered who know this is a cure cannot or will not give out any info on where to find one. Given the fact that I live in America’s 2nd largest city I’m hopeful. I still feel horrible for the rural folks who have little if any chance of getting one. How unbelievably awful of T-Mobile! The worst customer service I’ve dealt w/ in a very long time. I can only hope that people are blowing this up on Twitter (now X). Thank you again and wish me luck!

Thank you for this thread. I came across it because I was having issues with my VPN and internet. I did have the Sagecom model and TM tech support was actually super helpful. 

I went in to a local store and was able to swap my modem for the arcadyan one and all is well. 

Created an account here just to give that feedback. 

They did say the new white ones will be the best so be on the lookout. This arcadyan one is a tad slower but with the VPN my upload speeds have 10x’d so I’m happy. 

I appreciate your thanks but I have not been nearly as lucky as you and a couple others here. I’ve known the cure for at least a week if not more but every TM tech I get refuses to help me find one. Meantime I’m stuck in a dangerous monsoon in LA and cannot go out searching for one until Wednesday earliest. Please wish me good Karma or pray for me- it appears this is what I need now. Thank you and very happy you got the solution! 

I appreciate your thanks but I have not been nearly as lucky as you and a couple others here. I’ve known the cure for at least a week if not more but every TM tech I get refuses to help me find one. Meantime I’m stuck in a dangerous monsoon in LA and cannot go out searching for one until Wednesday earliest. Please wish me good Karma or pray for me- it appears this is what I need now. Thank you and very happy you got the solution! 

 

Wish you the best luck! The rep found one for me in South Pasadena (Old Town). I would keep call them and hope one of the reps would be able to find one for you!

Mine started working last week, and again today is completely broken.

I appreciate your thanks but I have not been nearly as lucky as you and a couple others here. I’ve known the cure for at least a week if not more but every TM tech I get refuses to help me find one. Meantime I’m stuck in a dangerous monsoon in LA and cannot go out searching for one until Wednesday earliest. Please wish me good Karma or pray for me- it appears this is what I need now. Thank you and very happy you got the solution! 

 

Wish you the best luck! The rep found one for me in South Pasadena (Old Town). I would keep call them and hope one of the reps would be able to find one for you

 

Good to know, thank you! 

If the issue I with Global Protect VPN, they are aware and are working the problem they say. I wasn't given any timing, the rep did not have any. Very frustrating since this is for work but hotspot on my phone appears to be a slower but good workaround. 

 

Lets go T-mobile…..HELP

In case anyone was curious.  Mobile Hotspot also does not work, their advice at least from the tech support was to “Reset My Devices Network” so they could “Re-align” the Lan.  This is a mobile hotspot I have used to connect to my company’s AnyConnect VPN for years. 

It’s not longer worked for the last few weeks, after debugging and trying other devices on the T-Mobile Network all failed to work.  Finally was able to test on AT&T’s network on the same device (IPhone 13 Pro) and my VPN connected perfectly.  With any luck T-Mobile will resolve this before I get fed up enough to switch carriers.  But I doubt it.  Tech support I got was incompetent, wouldn’t actually listen to what I was trying to say, even put me on hold when I attempted to repeat what was happening.  

For any and all here, if you’re running into the same issue understand that tech support likely won’t resolve your issue.  I refused to resent my devices network settings, I have a mountain of connections I don’t want to spend attempting to reconnect to for a solution as you are likely aware won’t work.

Add me to the list. Globalprotect VPN has been unusable for the past few weeks. Blocking UDP port 4501 forces it to connect in SSL mode and it helps a little but is very slow. Lowering MTU did not resolve for me. T-Mobile please get this fixed.

It had to have been something T-Mobile changed around Jan 20th time frame. I have been using T-Mobile 5GHI for about 1 year with my companies GlobalProtect VPN. Worked great until Jan 23rd when it would not hold the connection. My companies IT group has been trying to troubleshoot the problem and sometimes it seems like it is fixed but alas it only lasts for a couple of hours. Luckily I have a work around for work so not ready to scrap T-Mobile internet just yet. But this needs to get fixed.

FINALLY…. Success! My new (white) modem arrived yesterday, worked w/ it today and I’m back in action. Incredibly grateful to my awesome Tech support Andrea. She did what no one else would and it was literally my Hail Mary attempt before moving on to another carrier. 

I was on the phone with support and was able to get VPN working. I’m connected via ethernet and it was very hit or miss if my VPN was going to work, but was able to get some success by going into Windows settings > Network & Internet >  Change adapter options > Right click on Cisco AnyConnect (or whatever name of VPN is) > Properties > Uncheck “Internet Protocol Version 6 (TCP/IPv6) > Okay. I also did the same for the “Ethernet” setting as well (so both VPN and Ethernet setting unchecked IPv6). Restart VPN application and try then. Was able to go right through for me. Hopefully this fixes my issue, and anyone else that requires VPN for their job!

For those who have issues with Palo Alto GlobalProtect, what are your issues? Is it

  1. Global Connect does not connect. No internal website can be accessible?
  2. Global Connect shows connected. But no internal website can be accessible?

I am situation 2.

I hope people get a chance to see this note.  My husband and I have been using T-Mobile in 2 homes (2 separate black towers).  We both work remotely and I have had a few occasions in the past where I could not get my VPN to work for a specific client/vpn, but in January, everything stopped working.  I read through this forum trying to find a solution.  Finally, I called support unsure of what type of help I would receive.  Short story, they were amazing and acknowledged the problem.  He also worked remotely and had the very same issues we are all having.  In the end, he had to jump through a lot of hoops to switch out the black boxes with the white towers.  T-Mobile will not allow a simple swap because the boxes are not provided by the same manufacturer.  He was very apologetic and tried to find every discount he could apply to make up the difference of the cost of switching.  But I could not continue to stay in the situation I was in.  He ordered them for us to be shipped out instead of going to a store where they are hard to find.  It cost us around $80 to swap out the hardware.  The big news is they WORK with the VPNs seamlessly!  If you have no other options, get the white boxes!

Yesterday I was able to exchange my black Sagemcom Fast 5688W for a Nokia 5G21 at a store in Hagerstown, MD for no charge.  The Nokia is working great.  I connect to GlobalProtect.  I tried without success most everything mentioned in this blog except for unchecking “Internet Protocol Version 6 (TCP/IPv6)” because there wasn’t an entry for GlobalProtect.  I’ve been having issues since 2/24… and to answer 4C_W’s question I could connect to the VPN but nothing on my work network was accessible.  It was intermittent for quite a while but on the afternoon of 2/8 it stopped working completely.

Reply