Solved

Account Suspended For Seemingly No Reason

  • 11 October 2021
  • 10 replies
  • 2904 views

Badge +1

Hi all,

 

I went in to my local T-Mobile store today and 1) Switched from a pre-paid account to a post-paid account (Magenta Max) and 2) ordered the new iPhone 13 Pro. The rep assured me that I would still be able to use my current phone (iPhone 7) until my new one comes in November.

 

Here’s the issue: my phone line/account has been suspended for some reason and there is seemingly no way for me to restore it. My account says “Pay outstanding balance of $0.00 to restore service.” The issue is that my service was not suspended for missing payments. I paid like $2 just to see if that would work and it did not.

 

Does anyone know what’s going on here or have experienced anything similar? I’m on the 611 line right now but I’ve been waiting for ~1 hour so if anyone has any ideas I’d love to hear them haha.

icon

Best answer by actualvarric 11 October 2021, 05:37

View original

10 replies

Badge +1

Resolved--had to message a rep through the app to get the issue fixed.

Hi! Can you please provide me the name of the app you used to message a TM rep? I'm entering week 3 with no resolution to a problem I'm having. I've visited 2 different TM stores in my area, worked with at least 5-6 different reps there, and on the phone, and am still having the same issue. No one seems interested enough to resolve my issue. They continue to tell me to visit my local store, where I can stand in line waiting for an hour or more each time. Thx!

Badge +1

Hi! Can you please provide me the name of the app you used to message a TM rep? I'm entering week 3 with no resolution to a problem I'm having. I've visited 2 different TM stores in my area, worked with at least 5-6 different reps there, and on the phone, and am still having the same issue. No one seems interested enough to resolve my issue. They continue to tell me to visit my local store, where I can stand in line waiting for an hour or more each time. Thx!

Of course! The app is just called “T-Mobile” (it’s the T-mobile official app). You’ll have to log into your account. After that, you can go to “More” → “Message us”. Hope that helps!

Thank you 🤗

Account activation with device ordered but not delivered creates a temporary suspension, which is a system function for brand new accounts, to prevent the line from being used before device is in hand, and/or maintain tentative status for a brand new account not fully valid in the system yet.

 

Prepaid to postpaid sometimes creates these conditions while everything moves over.

This just happened to us today. Went into a T-Mobile store today to buy new phones and switch over from a different carrier. New phones are having to be shipped, so the associate activated our current phones and said we can use them until the new phones come in. We confirmed that we could send and receive text messages and calls, and left. A couple hours later, I get a notice that our account is suspended. It says I have to make a payment, but our account shows $0 due and won’t let me make any payment. Now, we can’t make or receive phone calls, and I’m not able to contact any support right now since it’s evening during the weekend. As a new customer, I’m livid and this is beyond frustrating. 

 

Edit: After waiting a while to chat with someone, customer support was able to fix it. I’m still frustrated that someone the system suspends your account like that, but I do want to give customer support credit. 

Woke up on Christmas morning to this issue - if this is a known problem, why isn’t it fixed? Or at least flagged when you make a purchase in the store? Ugh. Thanks for sharing the fix here!

 

Thanks everyone — I had the exact same issue… account suspended after a few hours — had no idea WTH was going on until I found this thread… and apparently this is a well-known issue, as it appears to have been going on for at least 3 years, if not longer… RIDICULOUS.  

I understand that TM may be doing this to reduce fraud, fake activations, don’t want customers charged for services they aren’t receiving yet etc., HOWEVER — I think it’s more about the former (reducing fraud, fake activations ala Wells Fargo) than the latter (charging for service you aren’t receiving), because OBVIOUSLY I’m receiving the service because you SUSPENDED IT!  Also, you can tell the SIM is activated and being used in a phone… so I think the excuse of not charging for service not yet being received is bogus BS… it’s cover for something else, such as fraud reduction…

SOOOO, if that IS the case, fine, leave it place — BUT, TELL THE STORE employees #1, and #2, create a 2-step authentication with the customer to verify they are using the service on their old/existing phone and are waiting for the new one — BOOM!  That’s it, done — no more angry customers whose service was suspended seemingly out of thin air AND you still have a fraud reduction system in place.

Until then, the fix is to call 611 (customer service) and/or go to back to the store and ask them to reinstate it… note that the first time I called the rep didn’t know what to do, but after reading this thread, I called back and Mabel (rep in The Philippines) was great and knew exactly what to do — service was reactivated within minutes.  Woohoo!  Thanks Mabel.

So, key takeaways:

** For customers experiencing this issue, call customer service at 611 or go back to the store to reactivate the service.  If the first rep you speak with doesn’t know what to do, call back.
** For TMobile — you need to fix this — this is just f’g idiotic.  I was with AT&T for more than 20 years, and was an INCH away from porting back to either them or Consumer Cellular over this. If you feel the need to retain the auto-suspend, make damn sure your store reps know the procedure AND institute a 2-step authentication to verify that the customer is ok with using the service until their new phone arrives.  That should help fix the issue for customers and help keep potential fraudulent activations you might be concerned about under wraps.

This is so ridiculous, I just signed up a 3 line service with phones for all of us, and an hour after leaving the store getting messaged that our service is cut off and threatening me with $20 reactivation fee. That is horrible service. I like tmobile but this is so hostile to customers. We had our devices shipped. You should train your store staff about this AND give them an option to circumvent this. We had our own devices, the store was out of stock, we are getting punished for this.

 

Thank you everyone saying to call and explain what the problem is.

Reply