Question

T-Mobile Shows Hotspot Data Usage When it is Disabled in My Phone Settings

  • 22 November 2022
  • 35 replies
  • 2993 views

Badge

I just started with T-Mobile on the Magenta Max 55+ plan.  I activated my new phone using the plan 10 days ago.  I am noticing that my mobile hotspot data usage goes up a little bit each day and is now at 2.13 gigabytes.  But I have all "Mobile Hotspot & Tethering" settings disabled on my phone settings, and they have been disabled all along.  So, how am I using mobile hotspot data?  I looked at all the apps that have used mobile data on my phone, and "Mobile Hotspot & Tethering" is nowhere in the list, which is as it should be.  I am sending screenshots of the top 5 apps under mobile data usage; and showing that all my "Mobile Hotspot & Tethering" settings are disabled.  Furthermore, my TOTAL mobile data usage for the 10 days is only 5.6 gigabytes, so this “error” makes up almost half of my total data usage.  What happens if I use 100 GB of mobile data, will T-Mobile say I’ve used 50 GB of hotspot data? I was going to try the mobile hotspot feature today for the first time, but I don't want to do that until I get a good answer as to why I am using data with this feature turned off.  Please let me know what's going on.  Thank you.

 


35 replies

Same problem here.  Galaxy Fold 5 running Esim.  I get the text message every month with no hotspot usage.  No resolution so far.

Update: I have used over 90gb of data, almost 60 gb of Hotspot now, and have experienced zero throttling and great data speeds. I don't know if it matters but I'm kinda out of the main town area so congestion isn't a problem here. Perhaps if I was in the city I would notice a slow down but as for now, I think most of this issue is just annoying texts, doesn't seem to impact service itself. 

Badge

Amazing that this thread is so long. I would like to report that I am experiencing the same issue. It seems to be impact my Music streaming application (Tidal). Tidal’s data usage is being marked as hotspot and when hitting the data cap it reduces the speed of Tidal data streaming, and only Tidal

Went to Samsung 24u, esim, no vpm.   Turn on hotspot to make sure it worked and I know how to use it..  turned it off...For last four months i get the message mobile hotspot data usage 80 percent then a few days later 100 percent.  Called support , spent time on phone etc finally a tech, went thru their steps, recycled my phone per them , fixed.  naw, same problem for three more months calling support is worthless,  final call this time (fourth month in a row) i kept demanding escalation,  sometimes this would be back to the suport queue sometimes to the agent sitting next to them, zero possibility of ever being escalated.   After four agent i was told this is a unique problem to me and has never been previously reported,  huh ?  i reported for four straight months, what, no record?  One agent did the standand, factory reset your phone….i said i did this previously, they said if i would not work with them they would not help.

I have verified HOTSPOT is off in the phone

I have changed the password to my hotspot

I verify daily on the phone zero hotspot usage

I have checked permission and no app has behind the scene access..

Tmobile Support is non-existent , incompetent…

Tmobile Wake up,   we the customer pay the bills,  we are not tethered to you.

Running Samsung S20 5G FE and also have eSim installed. Yep, just activated service yesterday and hit the 10gb Tethering Data cap. Customer service was no help but so far my data speeds aren't any slower. 

I am facing the same issue as well. I have raised a ticket with the customer care too. Hoping for some resolution. Did anyone here got any resolution from T-Mobile?

I upgraded my phone to the 24U and chose to use ESIM. Had the same issues like everyone else, so switched back to physical SIM, which became a whole thing. It did not want to work at first and took way longer to setup (over an hour of customer support troubleshooting) than if I had just stuck with the physical SIM in the first place. I think that solved my issues, even though they tried to convince me that it couldn't be the problem.

Also, T-Mobile support, without my authorization, added a 10gb data add-on to my plan, even though I made it clear MANY TIMES that I did not want any upgrades or add-ons. The add-on was also not listed in managed add-ons and was 5 bucks more expensive than the one we can select for ourselves. Make sure you guys check your account activity as it tells you everything you and T-Mobile does to your account. Also, view your T-Mobile data usage and plan details frequently. Mobile hotspot usage category disappeared from my account after this whole debacle.

I've always sung support's praises since they're usually very helpful and professional, so I couldn't believe what they did to me. While troubleshooting with them not only did they downgrade my plan (which I had to make them correct since they claimed to not know my plan was upgraded FOR FREE from a Simple Choice 6gb to unlimited years ago) they added data without my permission.

For some reason, even though I have an unlimited plan, it still shows my original plan. Usage details does make clear it's an unlimited plan though. Make sure you guys save all your texts, emails, chats, and any other correspondents with them, ESPECIALLY when it comes to changes made. I still have the info from when my account was upgraded to unlimited, so it's grandfathered in, which is not great for them and their pursuit of making more money.

I'm disgusted and furious. If they mess with my account again, I'm closing it and making sure no one I know uses them. There's many more options now.

Badge

I am having this same issue, and the customer service reps are just ignorant. I have a Samsung A52, and my account renewed 8 days ago and according to Tmobile I have used over 300GB of data. My phone usage says 13 and my laptop says 9. I only have my laptop connected and use it for streaming services. I havent even used it everyday. 

This is the 3rd time this has happened to me. I was previously a Sprint customer, that was automatically switched to Tmobile last summer. 

The last time this happened one of the agents was able to look at my usage while I was connected to it and reset it. Today, after 2 agents they wanted me to call them to speak with a tech. Even though I never spoke to one previously. I don't have the time or patience right now to try and understand someone's accent, and have to explain all over again that the usage they have doesn't match what I have. 

I will go back to the chat though and tell them they need to check their forums as there are many people with this issue for over a year now. 

My problem with the hotspot "leaking" happened since I changed my new phone S24 from S22, so I think the new android OS may conflict with tmobile's hotspot configuration and it caused data usage increasing. I'll try the physical SIM instead of eSim. Will update.

My two cents here… I too have this issue, among many others but to throw a wrench in this thread I have an iPhone, not an android. I don't use a VPN. And, I have a physical SIM as opposed to an e-SIM. So, it's not just the Android users that experience it. As for the comment regarding the engineers should be embarrassed by this, I agree and would add a laundry list of other reasons why the entire company should be embarrassed beyond measure. 

1st question... Are y'all using THE eSIM vs physical sim? I noticed when I got my flip 4 and used my Sim card everything was fine. I stream video all day at work n would only get the warning abt my monthly Data usage. . Then I decided to try the eSIM route. All of a sudden it says I went over my HOTSPOT ALLOWANCE. But I rarely if at all use Hotspot since my kids got a free one from TMob. One rep recommended to go back to physical sim AND WHAT DO U KNOW? PROBLEM SOLVED! 

I think you are right. I got the s24 Ultra. And I was transferring stuff and got a thing saying transfer SIM. So since it looked easier to transfer via eSIM I clicked yes.  And not I'm getting the Hotspot issue. 

 

I will put my SIM in this phone now. 

 

Thank you

1st question... Are y'all using THE eSIM vs physical sim? I noticed when I got my flip 4 and used my Sim card everything was fine. I stream video all day at work n would only get the warning abt my monthly Data usage. . Then I decided to try the eSIM route. All of a sudden it says I went over my HOTSPOT ALLOWANCE. But I rarely if at all use Hotspot since my kids got a free one from TMob. One rep recommended to go back to physical sim AND WHAT DO U KNOW? PROBLEM SOLVED! 

If you are using VPN"s.  This can cause the data you are using to be misinterpreted.  Disable the VPN to ensure this doesn't happen.  A third party DNS can also sometimes cause this issue as well.  I have never experiences this issue personally on my s23 Ultra using Cloudfire for all DNS queries.

I use a VPN to block ads. This is unacceptable to me, it should not be counted as hotspot data and I refuse to have advertisements shoved down my throat. 

If you are using VPN"s.  This can cause the data you are using to be misinterpreted.  Disable the VPN to ensure this doesn't happen.  A third party DNS can also sometimes cause this issue as well.  I have never experiences this issue personally on my s23 Ultra using Cloudfire for all DNS queries.

Not using a VPN. 

Userlevel 7
Badge +15

If you are using VPN"s.  This can cause the data you are using to be misinterpreted.  Disable the VPN to ensure this doesn't happen.  A third party DNS can also sometimes cause this issue as well.  I have never experiences this issue personally on my s23 Ultra using Cloudfire for all DNS queries.

Just got this starting for me this week, was on home wifi when i got the 80% warning and then data when I got the 100%, Hotspot was disabled. I am also using an S23+ Ultra

I just got the Hotspot message and checked all 3 phones on our plan. We have an iPhone 14 and 2 S23+. None of them have been running the Hotspot. What is really going on?

Userlevel 7
Badge +16

the recurring factor im looking at in here is just about every one of you have a S23 and are running into this..with at least one person with a Note 20 i think it was..

I traded in my old phone 4 months ago and got a S23 from T-Mobile on a magenta plan and as all of you experienced I received texts about 80% and soon after 100% hotspot data usage alert and after that some apps such as WhatsApp and telegram get slow.

It is happening every month and I called the costumer service couple times but no answer. They asked me to check the devices that connected to my phone. I disabled my hotspot and changed the password. Even I don't know what it is. I guess it is related to the e-sim which I activated without any physical Sim card

having this problem as well and i’m on S23. Only been like 4 days since the billing cycle renewed and it informed me my 5GB hotspot data allocation has been used up (100%). I did not turn on hotspot at all during this period. What is going on? I won’t have any hotspot data to use like this then. 

I’m having the same issue.  I have two S23’s and on both mobile hotspot have been disabled.  One shows over 2.5GB used and the other about .5GB.  Searched here and found this thread.  Will call customer support to inform them.  Too bad the Usage report doesn’t show you any details on Mobile Hotspot usage like it does for mobile data.

Is happening to mine as well the last month. Told about it, they replenished and gave me a couple months of added hotspot Gs.. to only find out today the same issue is happening and now the Gs being taken is more based on my quantity.  Ticket is submitted again and now that I'm reading all these other ones, don't know if they will find out what's going on. S20Note

Userlevel 7
Badge +16

Mine is an s23 ultra also. I paid cash for mine in July and it is still locked  and I can't get a straight answer on that either.. I think if you pay cash for the phone outright it should have been unlocked to start with.

probably help iif you posted in an area more dedicated to unlocking devices and not so much in a thread talking about hotspot usage.

 

but seeing as how you brought it up..no..if you bought a phone from TMO there are requirements that must be met in order to unlock it..which are listed in here..

https://www.t-mobile.com/responsibility/consumer-info/policies/sim-unlock-policy

 

if they are not met it wont be unlocked until then.

Badge

Mine is an s23 ultra also. I paid cash for mine in July and it is still locked  and I can't get a straight answer on that either.. I think if you pay cash for the phone outright it should have been unlocked to start with.

 

Reply