Question

T-Mobile Shows Hotspot Data Usage When it is Disabled in My Phone Settings

  • 22 November 2022
  • 36 replies
  • 3091 views

Badge

I just started with T-Mobile on the Magenta Max 55+ plan.  I activated my new phone using the plan 10 days ago.  I am noticing that my mobile hotspot data usage goes up a little bit each day and is now at 2.13 gigabytes.  But I have all "Mobile Hotspot & Tethering" settings disabled on my phone settings, and they have been disabled all along.  So, how am I using mobile hotspot data?  I looked at all the apps that have used mobile data on my phone, and "Mobile Hotspot & Tethering" is nowhere in the list, which is as it should be.  I am sending screenshots of the top 5 apps under mobile data usage; and showing that all my "Mobile Hotspot & Tethering" settings are disabled.  Furthermore, my TOTAL mobile data usage for the 10 days is only 5.6 gigabytes, so this “error” makes up almost half of my total data usage.  What happens if I use 100 GB of mobile data, will T-Mobile say I’ve used 50 GB of hotspot data? I was going to try the mobile hotspot feature today for the first time, but I don't want to do that until I get a good answer as to why I am using data with this feature turned off.  Please let me know what's going on.  Thank you.

 


36 replies

Userlevel 1

I am having the same problem. My hotspot settings have been disabled since I got my phone but each month I get texts from T-mobile saying I'm approaching my limit of high speed hotspot then eventually it says I've used it up. Online customer support was not able to help as they just had me check my settings, which were all off. 

I've also been seeing this problem over the last few months. I'll be using my normal phone data (which I'm supposed to have 100Gbs of) and as I use it I'll start getting those same texts of running out of hotspot data even though I'm not using my hotspot. And as soon as I go over that hotspot data cap my phone instantly starts to chug when I do anything on it data wise even though I am only a few gbs into my supposed 100gbs I'm paying for.

My only assumption is that the "hotspot" data is actually our real high speed data and that it's a shared data category with our actual hotspot as well. So when you use that data for normal use it also take up your "hotspot" data which is why we're getting the notifications.

Idk what the 100gbs of premium high speed data even is then and idk why I'm paying for it if that's the case. 

Would definitely like to hear from a community manager, mod, or TMobile employee about this since it's obvious we're not the only ones experiencing this. 

I am facing the same issue as well. I have raised a ticket with the customer care too. Hoping for some resolution. Did anyone here got any resolution from T-Mobile?

having this problem as well and i’m on S23. Only been like 4 days since the billing cycle renewed and it informed me my 5GB hotspot data allocation has been used up (100%). I did not turn on hotspot at all during this period. What is going on? I won’t have any hotspot data to use like this then. 

1st question... Are y'all using THE eSIM vs physical sim? I noticed when I got my flip 4 and used my Sim card everything was fine. I stream video all day at work n would only get the warning abt my monthly Data usage. . Then I decided to try the eSIM route. All of a sudden it says I went over my HOTSPOT ALLOWANCE. But I rarely if at all use Hotspot since my kids got a free one from TMob. One rep recommended to go back to physical sim AND WHAT DO U KNOW? PROBLEM SOLVED! 

Went to Samsung 24u, esim, no vpm.   Turn on hotspot to make sure it worked and I know how to use it..  turned it off...For last four months i get the message mobile hotspot data usage 80 percent then a few days later 100 percent.  Called support , spent time on phone etc finally a tech, went thru their steps, recycled my phone per them , fixed.  naw, same problem for three more months calling support is worthless,  final call this time (fourth month in a row) i kept demanding escalation,  sometimes this would be back to the suport queue sometimes to the agent sitting next to them, zero possibility of ever being escalated.   After four agent i was told this is a unique problem to me and has never been previously reported,  huh ?  i reported for four straight months, what, no record?  One agent did the standand, factory reset your phone….i said i did this previously, they said if i would not work with them they would not help.

I have verified HOTSPOT is off in the phone

I have changed the password to my hotspot

I verify daily on the phone zero hotspot usage

I have checked permission and no app has behind the scene access..

Tmobile Support is non-existent , incompetent…

Tmobile Wake up,   we the customer pay the bills,  we are not tethered to you.

Badge

Mine is doing the same thing except it slows down my internet after it says I reached this amount. So I have to have a slower connection because they can't fix this .

1st question... Are y'all using THE eSIM vs physical sim? I noticed when I got my flip 4 and used my Sim card everything was fine. I stream video all day at work n would only get the warning abt my monthly Data usage. . Then I decided to try the eSIM route. All of a sudden it says I went over my HOTSPOT ALLOWANCE. But I rarely if at all use Hotspot since my kids got a free one from TMob. One rep recommended to go back to physical sim AND WHAT DO U KNOW? PROBLEM SOLVED! 

I think you are right. I got the s24 Ultra. And I was transferring stuff and got a thing saying transfer SIM. So since it looked easier to transfer via eSIM I clicked yes.  And not I'm getting the Hotspot issue. 

 

I will put my SIM in this phone now. 

 

Thank you

My problem with the hotspot "leaking" happened since I changed my new phone S24 from S22, so I think the new android OS may conflict with tmobile's hotspot configuration and it caused data usage increasing. I'll try the physical SIM instead of eSim. Will update.

Badge

I am having this same issue, and the customer service reps are just ignorant. I have a Samsung A52, and my account renewed 8 days ago and according to Tmobile I have used over 300GB of data. My phone usage says 13 and my laptop says 9. I only have my laptop connected and use it for streaming services. I havent even used it everyday. 

This is the 3rd time this has happened to me. I was previously a Sprint customer, that was automatically switched to Tmobile last summer. 

The last time this happened one of the agents was able to look at my usage while I was connected to it and reset it. Today, after 2 agents they wanted me to call them to speak with a tech. Even though I never spoke to one previously. I don't have the time or patience right now to try and understand someone's accent, and have to explain all over again that the usage they have doesn't match what I have. 

I will go back to the chat though and tell them they need to check their forums as there are many people with this issue for over a year now. 

Same issue, says I used 50GB of hotspot data in my first 15 days...I haven’t even turned HotSpot on.

Same problem here.  Galaxy Fold 5 running Esim.  I get the text message every month with no hotspot usage.  No resolution so far.

Mine is doing this. They reset it last Sunday and today it is back to 2.5 GB. 

I am using a s23 ultra I want this fixed tosay!!!!!!!!!!!

 

Update: I have used over 90gb of data, almost 60 gb of Hotspot now, and have experienced zero throttling and great data speeds. I don't know if it matters but I'm kinda out of the main town area so congestion isn't a problem here. Perhaps if I was in the city I would notice a slow down but as for now, I think most of this issue is just annoying texts, doesn't seem to impact service itself. 

I am having the same problem. My hotspot settings have been disabled since I got my phone but each month I get texts from T-mobile saying I'm approaching my limit of high speed hotspot then eventually it says I've used it up. Online customer support was not able to help as they just had me check my settings, which were all off. 

Any update or was it resolved? 

I am having the same problem. My hotspot settings have been disabled since I got my phone but each month I get texts from T-mobile saying I'm approaching my limit of high speed hotspot then eventually it says I've used it up. Online customer support was not able to help as they just had me check my settings, which were all off. 

Any update or was it resolved? 

Nope. And still have this issue. I think for some reason your hotspot data and your "premium data" are pulling from the same pool of data. Even though they should be different. 

Running Samsung S20 5G FE and also have eSim installed. Yep, just activated service yesterday and hit the 10gb Tethering Data cap. Customer service was no help but so far my data speeds aren't any slower. 

Badge

Amazing that this thread is so long. I would like to report that I am experiencing the same issue. It seems to be impact my Music streaming application (Tidal). Tidal’s data usage is being marked as hotspot and when hitting the data cap it reduces the speed of Tidal data streaming, and only Tidal

Just got this starting for me this week, was on home wifi when i got the 80% warning and then data when I got the 100%, Hotspot was disabled. I am also using an S23+ Ultra

Badge

Still not fixed as of July 19th, 2023.  I last heard from a T-Mobile representative named Kirsten Hartford on March 24, 2023 with the message below.  I don’t think any “engineer” is looking at this “bug”.  They should be embarrassed.  I was a software engineer myself.  I’m thinking about offering a cash reward for the T-Mobile employee who can fix this.

Good morning, Mr. Hall. I see the issue with the system reporting smartphone mobile hotspot/tethering usage when you are letting us know there has never been that use, has been an ongoing concern for several months. This has led to you reaching out on multiple dates. I am already up to speed on the issue and all steps we have taken so far. While the reporting is not service impacting, I can appreciate your desire for the usage records to reflect properly. I want that reflecting properly too. I have sent this issue with all information and all prior tickets filed to our highest support teams. I don’t want you to have to spend more of your valuable time reaching out to start all over with someone new, so I will take this concern and stick with you until we have a definitive reply from our teams and all resolution paths have been worked. ^KirstenHartford

 

 

Userlevel 7
Badge +15

If you are using VPN"s.  This can cause the data you are using to be misinterpreted.  Disable the VPN to ensure this doesn't happen.  A third party DNS can also sometimes cause this issue as well.  I have never experiences this issue personally on my s23 Ultra using Cloudfire for all DNS queries.

I am having the same problem. My hotspot settings have been disabled since I got my phone but each month I get texts from T-mobile saying I'm approaching my limit of high speed hotspot then eventually it says I've used it up. Online customer support was not able to help as they just had me check my settings, which were all off. 

Any update or was it resolved? 

Nope. And still have this issue. I think for some reason your hotspot data and your "premium data" are pulling from the same pool of data. Even though they should be different. 

That sucks! Customer service or their technical unit couldn't give any reason why this is happening?! It's very frustrating and disappointing. 

I just started with T-Mobile on the Magenta Max 55+ plan.  I activated my new phone using the plan 10 days ago.  I am noticing that my mobile hotspot data usage goes up a little bit each day and is now at 2.13 gigabytes.  But I have all "Mobile Hotspot & Tethering" settings disabled on my phone settings, and they have been disabled all along.  So, how am I using mobile hotspot data?  I looked at all the apps that have used mobile data on my phone, and "Mobile Hotspot & Tethering" is nowhere in the list, which is as it should be.  I am sending screenshots of the top 5 apps under mobile data usage; and showing that all my "Mobile Hotspot & Tethering" settings are disabled.  Furthermore, my TOTAL mobile data usage for the 10 days is only 5.6 gigabytes, so this “error” makes up almost half of my total data usage.  What happens if I use 100 GB of mobile data, will T-Mobile say I’ve used 50 GB of hotspot data? I was going to try the mobile hotspot feature today for the first time, but I don't want to do that until I get a good answer as to why I am using data with this feature turned off.  Please let me know what's going on.  Thank you.

 

Have you received a resolution for this issue yet? 

I just got the Hotspot message and checked all 3 phones on our plan. We have an iPhone 14 and 2 S23+. None of them have been running the Hotspot. What is really going on?

Reply