wifi calling in Pixel 4a 5g, I can't hear

  • 17 February 2021
  • 44 replies

Show first post

44 replies

Having the same issue with my Pixel 5. There are times when I’m on a call using wifi calling and all of a sudden I can’t hear the other person. I turn my wifi off and I’m able to hear again just fine and continue the call. 

I’ve come across where I have wifi turned on, but not connected to any wifi signal and still have the problem.  I was on the road and making a call, I couldn’t hear who I called but they could hear me. I turned my wifi off on the phone and I could hear the other person fine.

I'm having the same issue, with a pixel 3 and 5 on Wifi.  In contrast to others' experience I find that turning off wifi mid-call is sufficient to get the audio from the other side back.  No device restart is needed. 

same issue Pixel 5 - wifi calling outbound works, inbound answers call with no audio - turning wifi off in the call is enough to get the audio working

Yup same.  My specifics is that my 5G signal, well, TMobile signal all together, is week near at my location.

I'll turn wifi calling off, but miss regular calls.  With wifi calling on, I can receive a wifi call, pick it up, I can't hear anything, bit while the call is still active, turn off wifi completely, the call switches to cellular and it works.

This works until I realize because my cellular signal is garbage, I miss a call.


Have any of you tried changing the preferred cellular network connection type to not 5G, so LTE?


This is a problem for me, as well, with my Pixel 4A 5G.  Very annoying and unacceptable.  Disabling Wi-Fi isn’t an option for me as T-Mobile coverage is so poor here that I can’t use the cellular network for calls.


Is everyone using Google Wi-Fi? I can’t remember if this happened when I was using my ISPs router or not.

Google wifi here with the issue.  Verizon FiOS ISP. Router issue perhaps?

Pixel 5a on Tmobile network.  Occasionally, phone calls have no incoming audio.  By the comments in this thread, it seems like I need to troubleshoot by working through all combinations of:

∆  Experimenting with network types (i.e., 4g, LTE, 5g) 

∆  Experimenting with reception types (i.e., cellular only, wifi only, cellular and wifi both enabled)

∆  Experimenting with call origin (did I initiate the call, or was it an incoming call)

∆  Experimenting with using the speakerphone function versus non-speakerphone.

∆. type of phone on the other end (is it some weird iPhone thing).

This is ridiculous.   How is it that a cellphone can't do the most basic audio.  It's in the name:   cellPHONE.    C'mon people.



Same issue with my pixel 4a 5g.  Disabled wifi calling completely.

Might be an issue with corporate network setting - (need to open some ports)

Seemed to fix my issues..

@chrispix can you explain how to do this?  i see the link but don’t see clear instructions.  thnx

There’s a google bug tracker open on this.  I encourage everyone here to go comment there too since it seems to be stagnant (although it is “assigned” to someone at least).

Both my wife and my Pixel 5’s have this same issue where we can’t hear the other caller sometimes, but switching off wifi “fixes” it immediately.  Both purchased unlocked from Google and we had them on Verizon briefly for a few months with zero wifi calling issues until we switched to T-Mobile.

Userlevel 1

This used to be a daily problem with my 4a 5G.  Now that I upgraded to Android 12, it only happened once so far.  



Same issue on my Pixel 5a 5G.  Since it seems to be affecting the Pixel 4a 5G, Pixel 5 and 5a 5G and those 3 phones are all using the snapdragon 765G processer does that have something to do with the issue?  I switched from Verizon to T-mobile and having to restart my phone multiple times a day just to make phone calls is ridiculous. Sounds like a phone update from google is needed to address the issue.  I also reported to the Google bug tracker.

Userlevel 1

Don’t hold your breath for a fix.  This has been broken for over a year now, and no progress is evident.


Pixel 5a with T-Mobile - wifi calling unusable b/c I can't hear anyone.  Live in rural location with spotty cell service so wifi calling is essential - I bought the phone based on this feature. Spectrum cable internet, up-to-date Tomato router, UniFi access point.  Fix please.


June 17 2022 Pixel 4a using T-mobile 5G, Cannot hear audio when Calls Over WiFi is enabled. Restarting the phone is a workaround but that’s not a sustainable solution nor something customers would want to do, or should do EVERY TIME they make a call. This is f-ing unacceptable (and yes I tried the reset network thing someone posted above, doesn’t help). 

Yes, I have this issue too with Google Pixel 4a 5g.  When on Wifi calls, the caller cannot hear me.  This seems random as sometimes the caller can hear me, with more times being, that I have to disable wifi calling in order to have a conversation.  I just disabled wifi calling, which is unfortunate as the signal in my home basement is not overly strong  

I don’t have the December 2022 security update yet, but many are reporting that this update for the Pixel 4a5g fixes the Wi-Fi calling problem.

I have a Google Pixel 4a factory unlocked phone.  Also have T-Mobile 5G Home internet with my own mesh router in between.  I used to think it was an issue with my Gateway settings, but have experienced the same issues over other WiFi networks so I'm now convinced it's something in the phone.  I can make and receive calls via WiFi, however, I can't hear the other person but they hear me fine.  It's one way audio.  Doesn't happen every time but 90% of WiFi calls have this issue.  I've got all the latest updates and still having this issue.  Very happy with the phone otherwise, but tempted to get a new phone just to have reliable calls.  I can turn off wifi mid call and talk fine once on cellular only (assuming cell signal available).  It is very hard to disable WiFi mid call because the top settings menu keeps flashing black and won't allow me to drop it down and change settings.  Takes many attempts before I can get into the menu and disable WiFi.  Very frustrating.  Please help with a fix!