Android Native Visual Voicemail Trouble

I'm using a Pixel2XL on T-Mobile and the native Visual Voicemail (built into the Google Phone app) will not activate. The VM tab does show, and I have the option checked in the menu settings for the Phone app. I continue to get the messages "Visual Voicemail Activating" and "Can't activate Visual Voicemail". I have VVM on my plan via the ONE Plus add-on.

I have removed the T-Mobile VVM app as I know that it will deactivate the native VVM. I have reset network settings, restarted the phone, and spoken with both T-Mobile and Google. I have yet to be given a reason this is not working.

(Note: brought the phone over from Verizon but it's unlocked - all other data and voice functionality is good)


Best answer by tmo_mike_c 2 March 2021, 16:40

View original

This topic has been closed for comments

115 replies


Yep . Same problem.  New Nokia 6.1 worked great for one day on TMO (had HD calling, fast LTE, VVM from goog).  After update to Pi, no more HD calling, LTE is half the speed, and Goog vvm doesn't work.  Sounds like a Google problem to me.  I thought Android One would allow me to stay updated; but when the updates break as much as Pi did - not worth it.

Userlevel 1

I'm now also in the "magically started working" camp.

Go figure. We put up enough data and evidence, TMo finally seems to have gotten it SORT OF fixed.

Userlevel 1

Still no luck here.

Userlevel 1

So this is going to sound stupid, but it worked on my wife's phone. Go into phone settings, under voicemail, and turn it off and on a few times .On the third or fourth attempt, hers activated . You can tell immediately when it activates, because the other options light up.

Same here. I just did what @carrierlost suggested, i.e. turn the voicemail

on and off few times and it started working...

I've been lurking on this thread for awhile.  Nothing recommended has worked, except for @carrierlost 's last recommendation.  I flipped the VVM switch under Voicemail Settings, and boom -- It's working.  I wonder if TMO recently fixed something, because I'm certain I've tried that many times. 

Userlevel 1

Mine is still stuck on "can't activate visual voicemail" Turned it off and on 10 luck.

Userlevel 1

This is all I ever see.

Userlevel 1

The suggested off and on isn't working for me at all. I tried over 20x's and still nothing. I paid off the phone so I'm probably gonna jump ship and try Google Fi at this point. My hopes were high after reading your posts about it suddenly working but I'm thinking of upgrading to the pixel 3 xl and I'm worried that I'll go through this same headache all over again if I do.

Userlevel 1

Just dropped T-Mobile for Google Fi. Not gonna waste time trying to figure why they can't something this simple to work. Good luck to those still waiting.

Curiosity got the better of me & I ventured into a T-mobile store this afternoon and uninstalled the t mobile visual voicemail app from the oneplus 6t that was on display and I was able to activate the native visual voicemail on that particular device. 

I'm thinking it maybe some kind of backend configuration on most of our accounts that are preventing some of our native visual voicemail apps from activating... of course the poor sales girl had no idea... but I'm sad that the "engineers" can't figure this out.

After you uninstalled the TMO VVM app and enabled the Goog VVM --- did it

work? On my phone, I could install VVM but it never worked. I reinstalled

the TMO app and the opportunity to use the Android VVM disappeared; but

since it didn't work, I don't care.

Note that Goog VVM worked great (as did wifi calling, hd VoLTE, etc.) on

Oreo; but when I updated to Pie on my brand new Nokia phone, those stopped

working as did Goog VVM. I reached out to Nokia support and they told me I

could bring the phone into a local service center and they'd downgrade me

to Oreo (which worked); but, the nearest service center is about 5000 miles

away in Europe 😥

They did tell me that Goog was aware of these problems and a fix is coming

in the next update of Android. So the net/net is: this is likely a

Google/Android problem and not TMO.

I was able to activate it on the 6T on display in the store, I waited a while for the error but it never errored like normal.

My friend is with Tmobile and has a Oneplus 6T and he let me know this morning that all of a sudden his began working today.

That's great, seems to be some kind of ongoing rollout of a fix.

REALLY wish they'd be transparent about this.

Mine is in the same state it was a couple weeks ago -- it "works" but I get

that bizarre Apple transcription for a few seconds, plus the voicemail

timestamp is 1 hour earlier than the actual time it was left.

Userlevel 1

Praise the Lord Carl Sagan!  Mine works now.

Through the native Oreo 8.1 phone app, I can get it to activate but it always says "Your voicemail inbox is empty / MAKE A CALL".  If I install the T-Mobile Android VVM app, then I can see the two saved voicemails.  I've tried the toggling on/off and it works instantly for activation, but no luck of it actually populating the tab with voicemails.

If VVM is turned on in the native phone app, Voicemail notifications don't work anymore as well.

For the people who have it working, is it working 100%, like before, under Nougat?

I have 2 Sony xperia XA2 and the one running stock android 8.0,0 has the same android vvm problem described in the thread.

The other is running lineage android 8.1.0 and has no problems whatsoever.

I spent an hour on the phone with tmobile and ended up with very poorly informed rep who told me that the "frequencies" of my XA2 were too old to work with vvm.

Interesting that it works fine with 8.1 but not 8.0.

Visual Voicemail broken after changing to Prepaid Rebellion Plan. I'm using a Nokia 6.1 on Android 9 and it worked with T-mobile before I changed sim cards. As soon as switched to the Rebellion plan, I received a text from T-mobile telling me to download T-mobile Visual Voicemail app from the Play Store

I'm having similar issues with the app, I've had it for years and it worked perfectly. A few months ago it suddenly stopped working saying it can't connect to the servers, I've uninstalled and reinstalled it, but before I can tap through the setup, the setup screen disappears and goes right into VVM and gives me the same error message. Any idea on how I can get this back working. Note 8 just updated to Pie and running the latest VVM version.

One more to the list of dissatisfied customer. Moto G5 plus. VVM was working on prepaid but nit after I switched to T-Mobile ONE plus. What the heck. Customer support says are different systems. I don't care! It is all TMobile for me. The T-Mobile App doesn't work either.

Please fix this!

Until recently, I wasn't even aware that there was native vvm functionality bulit-in to Android.  I'd always used the T-Mobile vvm app and had problems with it: sometimes a whole day would pass where I wouldn't get a notification that I had any voicemail messages and then, at the end of the day, I suddenly got notified that multiple voicemails had been left for me hours ago. 

I was messing around with someone else's iPhone a week ago, and really liked how the vvm was built-in to the dialer.  I started thinking there must be a way to do this in Android.  That's when I realized this was actually an option in Android and was possible with my phone (Razer phone).

I uninstalled the T-mobile vvm app and tried to activate my phone's vvm.  I got (and 3 days later am still getting) the "Can't activate visual voicemail" error message.  Interestingly, as soon as I started trying to activate the Razer's native vvm, I also started getting text messages from T-Mobile encouraging me to download the "new version" of their vvm app - the one I just uninstalled.

T-Mobile has shown no interest in fixing this issue. Your choice is to use the buggy app or call the voicemail number 😢 😠

I'd was getting nowhere, so I decided to reinstall the T-Mobile vvm app for the time being and then periodically check back to see if the native app might be working.  But, after I reinstalled the T-Mobile app, it would no longer activate!  I was frustrated with it, so I once again uninstalled the T-Mobile app.

Then, the next time I opened the phone's dialer, I noticed after a while that the error message WASN'T popping up.  So, I got on another phone, called myself and left a voicemail.  And, voila, it works!  No idea why reinstalling, and then again uninstalling, the T-Mobile vvm app should've done the trick, but it seems like it did.