Solved

Change voicemail from spanish to english?

  • 5 September 2016
  • 27 replies
  • 91873 views

Change voicemail from spanish to back to english?

icon

Best answer by tmo_mike_c 5 September 2016, 17:04

View original

27 replies

I can't switch my.langue. from Spanish back to English what the f___k is going on 

Wow! a month of no voicemail. Site after site and nothing worked at all. Until this post. This one did the trick. I can’t believe this issue has persisted for this long. On pros and cons for choosing or not choosing a carrier, this is definitely a con. Changes to Spanish randomly. At least now I can use it again, NO THANKS to T-Mobile.

Yep, still an issue. I’m beyond frustrated. I’ve done all the steps and my phone still speaks Spanish. I’ve spent HOURS trying to correct this issue. SO DONE WITH TMOBILE!

Call your voicemail as usual and type in your pin followed by #. Let the message begin and hit * (This takes you to the main menu) Press 4 for options, pause, then 7 for English. IMPORTANT: Have patience between each step and wait for a response to begin at each number press.  Otherwise it hears 4, then 7, as 47, and it will tell you in Spanish that this is not an option.  Listen to be sure the language has changed before hanging up.  You can always hit * again to start anew on the main menu to repeat the 4, then 7 process.

Yep, still an issue. I’m beyond frustrated. I’ve done all the steps and my phone still speaks Spanish. I’ve spent HOURS trying to correct this issue. SO DONE WITH TMOBILE!

What if you hit star for the main menu, then 4 for mail box options, then 7 for language settings? Does that allow you to change it?

Yes, this works! I had been trying, unsuccessfully, to change my wife's voicemail back to English. Frustration was on the horizon until I came across your response from 3 years ago and finally, success. Thanks for sharing, much appreciated! 

Just spent the better part of two hours on this same issue... seriously, after seven years they still have not fixed this very frustrating issue.  Thanks to whoever put these instructions online they worked great.

Userlevel 7
Badge +16

is that what you normally use or do you usually use the app but are trying to make changes through the call in one?

 

 

I'm trying to use the call in.

Userlevel 7
Badge +16

are you using the call in voicemail or the visual voicemail app?

This is ridiculous  Having voicemail switch to Spanish for no apparent reason is beyond frustrating.  I have attempted to make the change recommended here on multiple occasions with no success. I would never, never, never recommend TMobile to anyone.

My phone randomly changed to Spanish too! I used my pin...then 4...then 7. Back to English. Thank you!

What if you hit star for the main menu, then 4 for mail box options, then 7 for language settings? Does that allow you to change it?

That worked!  I wonder how it got changed to Spanish in the first place.  I have had this phone for years.

Call your voicemail and type in your pin followed by #. Press 4 for options, then 7 for English. After you hear the options in English, you can hang up. 

I can’t believe this (particular) thread is 5 years old and as of four days ago - according to KCB above - it’s STILL an issue. This press 7 to delete a vm but it switches your system to another language is absolutely ridiculous. I just spent 30+ absolutely frustrating min on the main website *trying* to troubleshoot this for my 87yr old dad and finally gave up and was more than happy to spend the next 5min venting my frustrations about that experience in the survey they offered.

A quick & simple google search led me here so thanks for the easy explanation as to WHY this happens and the answer how to fix it. It’s not rocket science T-Mobile… Please do better.

This happened to my mother’s phone.  Good news is that if you press 4 and listen all the way to the end, it will tell you in the other language to press 7.

 

Bad news is T-Mobile set this up so that the command to delete a message that you use all of the time is the same one that can switch languages if you are not listening to the message any longer.  This seems plain dumb.

Press 4....then 7

Thanks so much cause I was starting to get frustrated 😂🤣

Press 4....then 7

Userlevel 6
Badge +15

What if you hit star for the main menu, then 4 for mail box options, then 7 for language settings? Does that allow you to change it?

4, 4, 7 no longer works.  No way known to change from the Spanish "black hole".

when i call it. my phone is also lost in the house some where that's the next problem lol

Userlevel 6
Badge +15

Hey @shanmala6072

Thanks for stopping by to let us know this worked. We love hearing when folks have success getting things like this working!

‌tthank you! It's work, and back to English.

Userlevel 6
Badge +15

Oh bummer. Thanks for giving it the good ol college try. At this point, you'll want to contact our T-Force team using the Twitter or FB links in my badge. They can access your account and switch language over for you. They are available 24/7 so you can shoot them a message now, and they'll get it taken care of.

Thank you, i just tried that, it didnt work its just a lot of spanish i dont understand what shes saying. I just pressed 4 twice and 7. Still spanish.

Userlevel 6
Badge +15

Okay. There's a specific way to navigate through this menu to change it yourself (no español knowledge required 😉)

When you call the system, press 4, that'll bring you to Mailbox Options.

Then, press 4 again and that'll take you to Playback Options.

Lastly, you'll press 7 to change the language to English.

Reply