Question

Google Speech Services not downloading

  • 15 January 2022
  • 7 replies
  • 955 views

Badge

 My Note 9 has been trying to download Speech Services by Google for 4 days.  Has anyone else been dealing with this ?  I sent a bug report but it is still going on. It is draining my battery 


7 replies

Userlevel 6
Badge +11

had the same issue..couldnt even see it in the play store to cancel the download..ended up silencing it

Userlevel 7
Badge +15

Are you trying to download it over WiFi?  Some large apps require that they be downloaded over WiFi and not data.  

Userlevel 6
Badge +11

it attempted it over both in my scenario..never would actually download..eventually it might have. im not seeing it up top anymore listed..even did a couple restarts on my device to see if it would kick off.

Badge

This issue is still ongoing, and it seems to be so only on T-Mobile.  I am not blind myself, but am heavily involved with blind and low vision assistive technology on the PC and Android platforms.  Google Speech Services have completed updating on Android for the vast majority of people at this time, and without repeated attempts.

My phone keeps trying, but at every turn the message that’s showing up is, “Waiting for network connection.”  Well, the phone is connected to the T-Mobile network as it’s being used at the same time as a mobile hotspot and clearly shows that it’s got LTE or 5G service with multiple bars.

Something needs to be done to fix this, as it has got to be on the T-Mobile end of things, not the device end of things.

By the way, I am on the phone now with T-Mobile Tech Support, and I strongly encourage others who are having this issue to call in (611) and report it.  These things only get attention if the issue is formally raised by enough customers.


Update:  Tier Two Customer Tech Support was able to get me a resolution to this issue.  My device tries to auto-update languages only over Wi-Fi by default, and since I don’t have a Wi-Fi connection most of the time, it just keeps “spinning and spinning” with the Waiting for network connection message.  Here are the steps to fix:

1. Settings
2. Google
3. Settings for Google Apps (toward the bottom of the Google Settings)
4. Search, Assistant, & Voice
5. Voice
6. Offline Speech Recognition (Manage downloaded languages)
7. Auto-Update Tab

In the Auto-Update Tab there are three radio buttons:
- Do not auto-update languages
- Auto-update languages at any time.  Data charges may apply.
- Auto-update languages over Wi-Fi only [default]

Choosing either "Do not auto update languages," or,  "Auto-update languages any time. Data charges may apply," should fix the issue.
Turning it off definitely does, as no attempt is made to update, ever.

Userlevel 6
Badge +11

the fault might be on Googles side though..might not be waiting for a data connection rather than a connection back to Google to download it. especially seeing as how running anything else that uses data has no issues (or even updating any other app in your play store..no issues).

Badge

the fault might be on Googles side though..

-

Well, it appears to be a fault with how certain device manufacturers have their default settings for Google Language updates configured.  See the solution I appended to my prior message.

I can understand why Wi-Fi Only used to be the default during the era of low data caps and high dollars being spent if you went over those.  But for many (and on T-Mobile, I’d say all) those days are long gone.  I try to reset everything I know about that is Wi-Fi restricted to allow the use of mobile data for updates.  It’s the only way I can be sure of getting them in a timely manner, as I’m almost never connected to Wi-Fi.

Badge

By the way, one of the users on one of the blind tech lists also pointed out that the auto-update settings for offline speech are separate from the more general Google auto-update settings overall.  He long ago set almost all things Google to auto-update using either Wi-Fi or mobile data, but couldn’t figure out why it was only Google Speech Servces that just couldn’t auto-update.

Now that mystery is solved.

Reply