T-Mobile RCS Messaging Stability Issues

  • 24 July 2023
  • 41 replies
  • 7486 views

Userlevel 1
Badge

Since moving to the S23 with official locked Tmobile ROM, RCS messaging has been terrible. Fails to connect to RCS servers, fails to send text, fails to receive text all at random. Rebooting phone, clear Google Messages cache and deleting all text threads helps for a while, then it's back to terrible again.

I have researched online and others have the exact same issue. It all started when Samsung moved from Samsung Messages to Google Messages for the text app. The problem is that Google Messages which is now the official messaging app on Galaxy phones, still uses T-Mobile’s unreliable RCS services. They can reprogram the Google Messages app that official Tmobile Samsung phones have to use the stable Google Jibe RCS services instead. This only effects official Tmobile phones and not unlocked Samsung phones on Tmobile, as their Google Messages client uses Googles RCS services and not T-mobiles.  ATT just moved all their users from ATT RCS services back to Google Jibe for these performance reasons.

When is T-Mobile going to move Samsung Galaxy users off the unstable Tmobile RCS services and onto Google Jibe RCS services?  If any Tmobile reps are listening, please open a case with backend engineering to fix this.  Tmobile Samsung phone users have been dealing with for a year now.  This issue is enough to lose a substantial amount of subscribers over.

Need proof?

 


41 replies

First my OP N300, then my son’s TCL X30 and now my wife’s Moto Edge 2022 all have this problem. TM support told me it was because I was on a 4G plan. Upgraded to the Magenta plan last night, but so far I’m not seeing an improvement.  I was going to switch to an S24 for performance issues with the N300, too bad it won’t fix this problem.

So instead of T-Mobile moving new phones back to Google Jibe Servers it sounds like they're doubling down on using their own broken system for all their customers? Maybe they want to keep people from using encrypted communation and force us all to SMS with crappy RCS service? 

I have been having issues with RCS working on my phone since I've gotten it. The issue rears its head mostly in group chats where I do not receive about 2/3 of messages sent to me. This has resulted in me being inadvertently excluded from social events because people didn't know I wasn't receiving messages and obviously I didn't know either. I have had to disable RCS to reliably receive messages from my friends. I am also no longer part of a friend group chat and have to rely on my wife to convey information to me about social outings.

Feels like using T-Mobile makes me a second-class citizen. Perhaps T-Mobile wants us to change carriers?

Your issue is a Samsung issue. Google messages and Samsung devices been having issue. Doesn’t matter the carrier and which RCS server around the world. 

https://www.sammobile.com/news/rcs-messages-not-working-properly-for-some-galaxy-phone-users/

 

We had no issues with our Galaxy S21+ on Verizon, only when we moved to T-Mobile and got new S23+. You can even see T-Mobile is using their own servers for RCS when you view the RCS settings about info.

After updating my Galaxy S22 Ultra (T-Mobile variant) from One UI 5 to One UI 6, I am no longer able to send RCS text messages via the Google Messages app; SMS and MMS works fine. And yes, RCS is enabled in the Google Messages settings.

 

I've tried clearing the app and cache data for Google Messages, Carrier Services, Google Play Store, and Google Play Services. I've uninstalled and reinstalled Google Messages and Carrier Services (both production and beta versions). And I've even wiped the cache partition.

 

Lastly, I factory reset my phone and even with a fresh install of the OS, the issue persists.

 

Since I didn't experience this issue prior to updating to One UI 6, I have concluded that this is an issue with One UI 6.

 

Is anyone else experiencing this issue? 

This happened to us when we moved to T-Mobile in Dec and got new S23+ phones. Nothing fixes it because T-Mobile is using their own servers in the Google messages RCS process, instead of using the established Google Jibe server. They said they're fixing that but apparently instead of only affecting new phones they're switching everyone to their servers worth updates, thus breaking more and more people. We finally gave up and went straight SMS because we were missing so many messages. 

I have been having issues with RCS working on my phone since I've gotten it. The issue rears its head mostly in group chats where I do not receive about 2/3 of messages sent to me. This has resulted in me being inadvertently excluded from social events because people didn't know I wasn't receiving messages and obviously I didn't know either. I have had to disable RCS to reliably receive messages from my friends. I am also no longer part of a friend group chat and have to rely on my wife to convey information to me about social outings.

Feels like using T-Mobile makes me a second-class citizen. Perhaps T-Mobile wants us to change carriers?

Your issue is a Samsung issue. Google messages and Samsung devices been having issue. Doesn’t matter the carrier and which RCS server around the world. 

https://www.sammobile.com/news/rcs-messages-not-working-properly-for-some-galaxy-phone-users/

 

I have seen this happen but is not actually the problem I'm experiencing, since the message will get delivered in some form. The issue I'm having is that I'm just straight up not getting a significant portion of messages from people when I have RCS enabled. Not as sms or rcs, they just go off into the ether. And that is a Jibe/T-Mobile server issue.

 

The reason I know is that the people I'm having this issue with have the same exact phone as me, or same-generation Samsung devices but are on different carriers. I have checked their RCS settings and they have Jibe as their RCS provider, while I'm over here on the pathetic T-Mobile servers playing by myself.

Userlevel 6
Badge +12

I have been having issues with RCS working on my phone since I've gotten it. The issue rears its head mostly in group chats where I do not receive about 2/3 of messages sent to me. This has resulted in me being inadvertently excluded from social events because people didn't know I wasn't receiving messages and obviously I didn't know either. I have had to disable RCS to reliably receive messages from my friends. I am also no longer part of a friend group chat and have to rely on my wife to convey information to me about social outings.

Feels like using T-Mobile makes me a second-class citizen. Perhaps T-Mobile wants us to change carriers?

Your issue is a Samsung issue. Google messages and Samsung devices been having issue. Doesn’t matter the carrier and which RCS server around the world. 

https://www.sammobile.com/news/rcs-messages-not-working-properly-for-some-galaxy-phone-users/

 

I have been having issues with RCS working on my phone since I've gotten it. The issue rears its head mostly in group chats where I do not receive about 2/3 of messages sent to me. This has resulted in me being inadvertently excluded from social events because people didn't know I wasn't receiving messages and obviously I didn't know either. I have had to disable RCS to reliably receive messages from my friends. I am also no longer part of a friend group chat and have to rely on my wife to convey information to me about social outings.

Feels like using T-Mobile makes me a second-class citizen. Perhaps T-Mobile wants us to change carriers?

First my OP N300, then my son’s TCL X30 and now my wife’s Moto Edge 2022 all have this problem. TM support told me it was because I was on a 4G plan. Upgraded to the Magenta plan last night, but so far I’m not seeing an improvement.  I was going to switch to an S24 for performance issues with the N300, too bad it won’t fix this problem.

My wife and I, both on tmo, are having constant issue with RCS even with each other both using the Google Messages app.  I have issues with other users not on tmo as well.  Basically, tmo’s implementation appears to suck.
Not happy...

RCS is totally unusable on my wife’s S23U. When will it be switched over to use Jibe?

Userlevel 6
Badge +12

There's been issues with General Samsung devices across the world. Doesn't matter if on carrier or Google servers. 

 

https://www.sammobile.com/news/rcs-messages-not-working-properly-for-some-galaxy-phone-users/

 

Since I didn't experience this issue prior to updating to One UI 6, I have concluded that this is an issue with One UI 6.

 

Is anyone else experiencing this issue? 

 I just started having this issue in the last couple of weeks.  I am sure I was updated to One UI 6.  I’ve noticed though it’s always the contacts who have Apple phones where I get the error message “Trouble Sending. Check Options” (as well as “Waiting for connection” When I AM already connected to WiFi!. It’s pretty much every day several times a day.  The only contact that I see the messages sent as RCS has an android.

Time to see if I can find another Texting app. 

Continues to be an issue with my wife’s S22U and she just got it replaced. Surprisingly all the techs seem to not be aware of this issue. 

My S21 purchased via Samsung has no issues (on Jibe).

Grounds for a class action are building. 

Userlevel 6
Badge +12

Have to wait for Google to switch you over. 

My daughter on the S23U T-Mobile variant is on T-Mobile until recently and she hasn't had a problem. She is now on Jibe.  I just got the S24U T-Mobile and it's on Jibe. Usually I buy unlocked phones but I ordered late and didn't want to wait for this phone this year. 

 

Wife - S22+ TRCS no trouble

Me - S24U JRCS no trouble

Son - Moto TRCS no trouble

Daughter S23U TRCS and now JRCS No trouble. 

 

I had a coworker who had trouble and got a new sim and that fixed his issue. 

Userlevel 7
Badge +16

I have zero issues with RCS still….but dont have a Sammy phone..

T-mobile RCS sucks. I had to switch to SMS.

After updating my Galaxy S22 Ultra (T-Mobile variant) from One UI 5 to One UI 6, I am no longer able to send RCS text messages via the Google Messages app; SMS and MMS works fine. And yes, RCS is enabled in the Google Messages settings.

 

I've tried clearing the app and cache data for Google Messages, Carrier Services, Google Play Store, and Google Play Services. I've uninstalled and reinstalled Google Messages and Carrier Services (both production and beta versions). And I've even wiped the cache partition.

 

Lastly, I factory reset my phone and even with a fresh install of the OS, the issue persists.

 

Since I didn't experience this issue prior to updating to One UI 6, I have concluded that this is an issue with One UI 6.

 

Is anyone else experiencing this issue? 

Userlevel 7
Badge +16

It's official. T-Mobile is reverting Google Messages back to Jibe off their own servers. So it just proves this whole time that any T-Mobile employee on here hasn't been listening. Just regurgitating the same troubleshooting steps that everyone will comment back that they've done every step before. This has been an issue since it was implemented on Google Messages to use T-Mobile servers. There is no effort to help customers when so many of us are saying the same thing. I'm curious how many of us called T-Mobile about this for it to be sent up to someone else and never get a call back. It's frustrating. It's easier for support to respond back saying they don't know and to be honest, not going to get an answer for you. I posted a link since support is just as clueless.

 

https://9to5google.com/2023/09/21/t-mobile-rcs-google-jibe/#:~:text=In%20addition%20to%20Get%20the,or%20use%20their%20own%20infrastructure.

mind pointing out which “TMO employee” in here wasnt listening?

Badge +1

There is this one cell tower that once I connect to it, almost 100 percent the time RCS messages will hang. I have no data problems. I have to either toggle airplane mode or drive away from the cell tower and connect to another one. It happened on the S20 I had even when it was connected to Jibe. It was always on the same cell towers I use my S23 on. Explain that. And yes, all troubleshooting has been done. I think it goes without saying I had the issue on two phones who connected to two different RCS networks. My wife will experience the same thing. I shouldn’t have to troubleshoot it all the time. It should just work.

Any ETA on the switch to Jibe?  Will this occur in the background or is there something we’ll need to do?  Any way to make this happen soon??

My wife switched from a Pixel to an S23 and the messaging is terrible.  It has all of the problems described on this thread.  Never had an issue with this when she used a Pixel. 

Badge +1

It's official. T-Mobile is reverting Google Messages back to Jibe off their own servers. So it just proves this whole time that any T-Mobile employee on here hasn't been listening. Just regurgitating the same troubleshooting steps that everyone will comment back that they've done every step before. This has been an issue since it was implemented on Google Messages to use T-Mobile servers. There is no effort to help customers when so many of us are saying the same thing. I'm curious how many of us called T-Mobile about this for it to be sent up to someone else and never get a call back. It's frustrating. It's easier for support to respond back saying they don't know and to be honest, not going to get an answer for you. I posted a link since support is just as clueless.

 

https://9to5google.com/2023/09/21/t-mobile-rcs-google-jibe/#:~:text=In%20addition%20to%20Get%20the,or%20use%20their%20own%20infrastructure.

Userlevel 7
Badge +15

Using ADB to reinstall Google Messages directly from the on-device firmware.  I see Jobe from Google in mine.  This crap still doesn't work properly with dual-SIM, even after updating.  I checked before and after updating.  It shows the same connection to RCS on my s23 Ultra.

 

Userlevel 1
Badge

Update: https://9to5google.com/2023/09/21/t-mobile-rcs-google-jibe/

We will have to see how long it takes Samsung to upgrade their version of Google Messages.

Userlevel 7
Badge +16

its gotta be more of a specific devices/texting app issue. im still running my V60 with GM with no issues. i dont call people..90% of my contact to and from is via text with no issues.

Badge +1

I’ve recently removed the carrier services from my wife’s and my phone as were both on S23. Haven’t really seen a difference. Still experience issues. Mainly it is when I connect to another cell tower. Specifically, an area I frequently travel too where the messages will just hang. It’s also common that it states it's waiting for the person to be online even when Google Messages open and my wife is looking at the app. Who knows for certain who’s issue it is. It for sure happens more with those using Google Messages with T-Mobile at the backend. It's a joint effort. I will say I would experience some of the same issues when I was on a S20 when it would use Jibe. Because I experience it more when connected to specific cell towers I can see why some people just don’t experience the issue. And it is a little annoying that I have to send pictures and videos as files so they stay untouched.

Are you still having this issue? I got a new T-Mobile s23 ultra 3 weeks ago and RCS has been terrible. So unreliable. There’s no rhyme or reason to when it will/won’t decide to work. I did all the T-Mobile troubleshooting and all the Google troubleshooting and even did a factory reset a few days ago. I have been on every forum with other users who have had the same issue. I called T-Mobile today and told them what troubleshooting I did, they transferred me to Samsung advanced support, and it still isn’t working right. I wish I would have returned it within the 14 days and got an unlocked version instead. Lesson learned, I guess.

Reply