Question

cellular data doesnt work on ios 14.5 anymore!


Badge

iPhone 12 Pro Max on T-Mobile Essential NCC family plan. 

After updating to iOS 14.5, cellular data won’t work. It doesn’t matter if it’s connected to 5G or LTE, or at whichever signal strength. It doesn’t have internet access. I can only make phone calls and text. 

I have tried network reset, factory reset, and reinsert sim. I even went to the Apple store to have my phone replacement eventually. 

However, the issue persists on the new phone as well once after it was updated to iOS 14.5. 

Only solution for now: is downgrade to iOS 14.4.2 or earlier. (As of may 3 Apple has stopped signing iOS 14.4.2 or earlier)

Also, other people in my family plan with iPhone 12 models updated to iOS 14.5 have the same cellular data issue. 
There are several people on Reddit reporting the same issue as well. All currently on essential plan. 

Reddit post  

 

Hopefully T-Mobile and Apple is working on a fix!?
Ps. The most recent iOS 14.5.1 doesn’t fix this problem. 


4 replies

Badge

I have the same issue!!!

It happened last week Wednesday. My iPhone 12 pro can make phone calls, can send messages to other guys, but NO data. My data plan is unlimited. The signal bar is 5G, but no network.

I tried everything, reset all settings, erase all data and contents, that does not work. I went to the T-mobile store, they replaced a new 5G SIM card for me, but it did not work. I went to the Apple store, they thought it is a hardware or antenna issue, they changed it but still not work. After that, they replaced a new phone for me, but the issue still not resolved. They told me it has to be the carrier problem. I went T-mobile again today, I do not know what they did on my phone, but finally, it was working, it can open websites on cellular data. But again, 1 hour ago when I was outside, the cellular data just suddenly disappeared. I tried to restart, reset all settings, it does not work. I am so confusing is T-mobile restrict my usage or something else??

Badge

Correction: this problem doesn’t seem exclusive to essentials plan. It seems like many No credit check Plans are affected. 

I am having the exact same issue. I am on the no credit check plan and also recently updated to 14.5  and having issues. Even worse, I just reset my network settings, and now I can’t even connect to my home wifi, so my phone is literally unable to do anything except make and take calls and texts. 

I have the same problem, following.

Reply