cellular data doesnt work on ios 14.5 anymore!

Userlevel 1

iPhone 12 Pro Max on T-Mobile Essential NCC family plan. 

After updating to iOS 14.5, cellular data won’t work. It doesn’t matter if it’s connected to 5G or LTE, or at whichever signal strength. It doesn’t have internet access. I can only make phone calls and text. 

I have tried network reset, factory reset, and reinsert sim. I even went to the Apple store to have my phone replacement eventually. 

However, the issue persists on the new phone as well once after it was updated to iOS 14.5. 

Only solution for now: is downgrade to iOS 14.4.2 or earlier. (As of may 3 Apple has stopped signing iOS 14.4.2 or earlier)

Also, other people in my family plan with iPhone 12 models updated to iOS 14.5 have the same cellular data issue. 
There are several people on Reddit reporting the same issue as well. All currently on essential plan. 

Reddit post  


Hopefully T-Mobile and Apple is working on a fix!?
Ps. The most recent iOS 14.5.1 doesn’t fix this problem. 


Best answer by tmo_mike_c 10 May 2021, 18:24

View original

45 replies


I have the same issue!!!

It happened last week Wednesday. My iPhone 12 pro can make phone calls, can send messages to other guys, but NO data. My data plan is unlimited. The signal bar is 5G, but no network.

I tried everything, reset all settings, erase all data and contents, that does not work. I went to the T-mobile store, they replaced a new 5G SIM card for me, but it did not work. I went to the Apple store, they thought it is a hardware or antenna issue, they changed it but still not work. After that, they replaced a new phone for me, but the issue still not resolved. They told me it has to be the carrier problem. I went T-mobile again today, I do not know what they did on my phone, but finally, it was working, it can open websites on cellular data. But again, 1 hour ago when I was outside, the cellular data just suddenly disappeared. I tried to restart, reset all settings, it does not work. I am so confusing is T-mobile restrict my usage or something else??

Userlevel 1

Correction: this problem doesn’t seem exclusive to essentials plan. It seems like many No credit check Plans are affected. 

I am having the exact same issue. I am on the no credit check plan and also recently updated to 14.5  and having issues. Even worse, I just reset my network settings, and now I can’t even connect to my home wifi, so my phone is literally unable to do anything except make and take calls and texts. 

I have the same problem, following.

Same here, I have contacted both T-Mobile and apple store. No luck...

Userlevel 6
Badge +15

This’ll need to be sent to our network engineering team with a Trouble Ticket. You’ll have to contact our Tech Care team and they’ll file one for you to get this resolved. 

Same issue. No credit check plan. iPhone 12 mini. Updated to iOS 14.5.1 and broke cellular data. Oddly, Ookla Speedtest app works, but no other apps can access internet over cellular. Did all the things, including a factory reset. No success.

I took Mike’s advice and chated with a rep who was able to step me through fixing the problem.

Sta2lt what was the solution as I am experiencing the same issue. And submitted a trouble ticket over a week ago. 

Jass, They would not tell me. She said she made “some” adjustments on her end. I did it by Chat so I could work on my phone while working with the rep. Several times I had to hard rest my phone. Good luck.


This is still not solved. Dunno how this can be marked as solved…

Same problem here. NCC account, upgraded to iOS 14.5.1 and data stopped. Fix for me was migrating my account to Magenta 55+.

I have been having this problem since 4/28 and reached out to Apple directly on 4/29. After 3 subsequent visits to the Apple Store WTC in NYC and a number of “genius’” being involved they confirmed un-officially that the problem is with iOS 14.5 and 14.5.1 and as far as I’m aware 14.5.2. In the store they had me backup my original iPhone 12 to my MacBook prior to their resetting it to discover that the problem was real and I’m not crazy. Switched to a new phone, same problem. I’ve of the reps moved my SIM card to a 12 Pro and it worked, but that demo phone was evidently “not” running iOS 14.5. After more calls to Apple they agreed to swap out my phone and I would pay the cost difference. Got to the store and nobody knew anything. They ended up comping the difference in cost but the 12 pro max has the same “no cellular data” problem. They swapped out another phone and didn’t do the upgrade to 14.5.1 and all works fine like it did before the update, but my backup taken when my original phone was using 14.5 cannot be restored. I’m screwed and Apple could not care less. I can live without things in the backup until fixes are made that allows for the restore. This weekend I purchased a new Apple Watch 6 and I’ll be damned but it wants a version of iOS higher than 14.4.2 in order to initialize and set up the watch. It’s unbelievable that Apple can issue such an advertised major upgrade without sufficient testing of such a big ticket item with a major carrier and then be so apathetic in regards to a fix. I’ve got an Apple Store appointment now to find a work around using a demo phone at the store to initialize the watch. Hopefully some solution will work, but at this point I have little confidence in Apple and finally admit it’s time to migrate to Android. High prices shouldn’t come with hassles.

I have been through 3 rounds with T Mobile and have been waiting for “Shelly” from Tech support to call me back for several days. I am not happy.

I’ve had a trouble ticket opened for four days since this past Friday.  Hopefully they have an engineer working on it. It’s easy to blame Apple on this one because it started happening after the iOS 14.5 upgrade, but I strongly suspect this is a problem with T-Mobile:

  • It’s only happening with No Credit Check plan customers. Customers who have switched plans or swapped SIMs to other plans immediately have their phone work
  • For most customers forcing LTE does not work, however for a few it does
  • The error in the browser is Domain=NSURLErrorDomain Code=-1001 "The request timed out."

All of this together leads me to believe that T Mobile has some kind of incorrect network configuration issue. Although the phone appears to have signal and connectivity, it’s acting as if the cellular network is denying traffic. 
If this truly were a problem with iOS, it would happen for all 5G customers and across multiple carriers. You would be hearing about it a lot more.

Having the same issue here, Iphone 12 pro, cellular data not working after ios 14.5, Essential NCC plan. No solution provided or ETA from Apple or Tmobile after providing logs with apple support or visiting Apple store. I’m seriously considering switching to another carrier since it’s been too long for a concrete answer and it seems no one is looking into the problem.

Userlevel 7
Badge +16

you do understand that the fix must come from Apple themselves correct? theyre the ones that need to get the fix kicked out or at least kicked to TMO in order for them to test it

you do understand that the fix must come from Apple themselves correct? theyre the ones that need to get the fix kicked out or at least kicked to TMO in order for them to test it

Has there been a root cause identified?  Why would an iOS problem only affect No Credit Check plan customers on T-Mobile?

Userlevel 7
Badge +16

because they botched the update? any fix coming to these devices come from the manufacturer

I have the same issue, I just called Apple and they told to backup my phone and reset it to default. anyone tried that?

Nofal, the default and restore didn’t work for me. The issue is the combination of iOS 14.5 and no credit check.

I am still without Cell Data. I have been to Tech Support 3 times and had 2 tickets written, 53732084 and 35387896. One Tech person never called me back one did 3 hours after the scheduled time and one is 4 and a half hours late… One Tech told me it was a phone problem, call Apple. Apple tested the phone, hardware is good. Reset like factory and no change. Service center wiped all software from the phone and re-flashed it, no change.  Currently running 14.6. A helpful rep at my local store worked the problem for 2.5 hours and thinks the problem is with permissions to access Data but can not get any help from techs higher up. I am in a position where T Mobile and Apple are pointing fingers at each other. I personally think the guy a the store is correct about permissions. I am headed back to the store tomorrow and if I can’t get resolution I am thinking of moving to Visible. This thread should not be marked as solved, it is NOT! Does anyone know how to get to higher level tech/customer support? T Mobile are you listening?????

I posted looking for help on the Tmobile Facebook page which got me in a session with a advisor but no resolution other than she would escalate my trouble ticket and then will check back next Monday… Pretty much the same story I have been getting. I checked back on FB to see if anyone had left any comments or suggestions about this problem but T Mobile had taken down my post. It seems the standard response is to say wait 3 days for the trouble ticket to get addressed and they will contact you back which so far is 1 for 4 contacts. I am headed back to the store today to see if I can find a resolution. Looks like a permissions issue for Data, reading above that big dog got the issue solved by migrating to magenta 55+.

Sad to say, this has been my first truly negative magenta experience in my 6-years here. I have worked in IT for 23 years with a focus on tel-com. This issue has not been resolved. I went 3 different bout's with the ‘experts’ and they were unable to identify the source of the problem. I verified that my NCC plan SIM worked on every Andriod device as well as iPhone’s running iOS 14.4 and below. I also verified that the same SIM would not resolve cellular data on 3 different iPhones, running iOS 14.5, 14.5.1, and 14.6. I also verified that a Magenta Max plan SIM worked perfectly fine on the same iPhone that the NCC plan SIM did not.

At the end of the day, the only solution was to ditch my grandfathered plan and take a ~30/mo rate hike to get back up and running.

Pretty lame that T-mobile would not devote the appropriate resources to take care of the ~1000 cutomers who have viewed this thread.

5G Cell Data looks to be working for me today. I have only tried it one location, but so far so good.