WIFI Calling Preferences Being Forced to Cellular Preferred

  • 10 October 2020
  • 87 replies

Show first post

87 replies



I am experiencing my WIFI Calling Preferences always being forced to “cellular preferred”, as are others.   I live in an area with poor T-mobile mobile data signal and this recent behavior makes my phone unable to make and receive calls and text messages.   I believe the problem only started happening after the next to last T-Mobile software update.  Everything was fine for my first 5 months of ownership.  A Google search shows posts of other users experiencing the same issue, but no options other than a tedious workaround of manually switching the phone to Airplane mode and changing the WIFI calling preferences back to “WIFI preferred”.  I have to do this kind of process each time I enter and leave my home, and sometimes have to reboot my phone as well.   The times I’ve forgotten, I’ve missed package deliveries and went to a doctor appointment when the doctor had left a message that he was out sick.  This appears to be a carrier specific issue as far as I can see.   I even tried replacing my rock solid Netgear R6400 router with an ASUS AX3000 router with no resulting changes.   I’m in a small apartment only 10 feet from the router, with a very strong WIFI signal.  I have two Samsung Galaxy S20 phones (March 2020) which both exhibit the exact same behavior.   I spoke with T-Mobile Tech support which appeared to be clueless about this issue other than to send me two new S20 phones under warranty to my T-Mobile store.   I do not have high confidence in this approach but will try the new phones and report back. 

Does anyone know anything more?   I am not aware of T-Mobile publicly acknowledging this issue.

Yes, still having this issue though less often for the past six months or so. I thought it was fixed but has gone back to switching to cellular preferred lately.   It seems to change sometimes when there is no wifi, but does not change back when I get home with good wifi, but very poor cellular.   So, yeah, makes no sense and very detrimental if you forget to check it every time you get home.   I'm likely to leave T-Mobile due to this issue.   


And no I don't know any more about what T-Mobile has done.  I got tired of calling and reporting this issue a year ago.

So frustrating to find such an old thread, on a topic that has not been answered.

We live outside cell-signal range. Way back when, Wi-Fi calling was THE reason we had T-Mobile in the first place.

And we are still being frustrated by automatic resetting to "cellular preferred" MULTIPLE TIMES DAILY, disrupting our communications. 

Very frustrating that this issue has persisted for years and across multiple devices. I usually only think to check the setting when my call quality is bad, and sure enough it's switched back to "cellular preferred". 

I have this same problem with my Samsung 13 5G.  I called T-Mobile’s ‘technical’ support line, and they had the audacity to say that wifi calling is only supported on the iPhone. This was idiotic, and I vainly tried to argue with them that they were mistaken, but, for the technical support agent on the phone, ‘the script is always right’.

Very frustrating.

Still an issue and could be an easy fix if T-Mobile actually addressed it. A simple added feature to select preferred networks based on location. I need Wi-Fi calling at home. Is it really that difficult to have a home location set with an option to specify a network preference based on that location? Home -> use cellular, use wifi, use strongest network.


Duh T-Mobile. Let's actually do a little engineering and not let issues founder for years. 

I agree that it is likely some TMo bloat/firmware that is doing this since the VZW phone I was using didn’t have the problem.

Yes, I knew that they were likely just trying to get rid of me.  Since I’m retired I can take the time to go to Level 2/Manager support.  That is a task for this week now that I’ve done my research.

In the mean time I’m trying the Tasker hack that is supposed to automatically turn wi-fi preferred on if anything turns it off.  I don’t know yet if that is going to help, but it is worth a try. 

Samsung support said that this isn’t their problem since all wi-fi calling features are carrier specific.  I had to try.

I don’t know if there is a root for the S22 yet.  Even if there is I probably won’t do it yet since with a new model there is often a flurry of stock firmware updates for the first few months.  I’ve read that there is one coming.

I don’t believe T-mo bloatware is the issue here.
I have an unlocked S22 Ultra, purchased directly from Samsung.
I’m using Mint mobile, which uses T-mo towers, and I’m having this ongoing issue.

Userlevel 1

I know that this is an old thread.  However, they ARE STILL DOING THIS.  It is hard to understand why.  I don’t know what it “buys” them, except a lot of customer annoyance.

I live in an area with bad cellular service, but I have great Wi-Fi and I still have this issue all the time.  It is so frustrating that I’m considering leaving TMobile because of it.  I assume this is still an issue for others and no fix from TMobile?

This problem seems to have started after a recent T-Mobile software update and is affecting your ability to make and receive calls and text messages due to poor mobile data signal in your area. You've already tried several troubleshooting steps, including changing routers and contacting T-Mobile tech support, but the issue persists.

Here are some additional steps you might consider:

  1. Software Update Check: Ensure both of your Samsung Galaxy S20 phones have the latest software updates installed. Sometimes subsequent updates can fix bugs introduced in previous versions.

  2. Wi-Fi Calling Settings: Double-check the Wi-Fi Calling settings on both phones:

    • Go to Settings > Connections > Wi-Fi Calling.
    • Ensure Wi-Fi Calling is turned on.
    • Set the "Calling preference" to "Wi-Fi preferred".
  3. Carrier Settings Update: Sometimes carrier settings need to be updated separately from the phone’s software. This can usually be done via:

    • Settings > General management > Reset > Reset network settings.
  4. Network Reset: This step can often resolve connectivity issues:

    • Settings > General management > Reset > Reset network settings.
    • Note that this will reset your Wi-Fi, Bluetooth, and other network settings, so you will need to re-enter Wi-Fi passwords and pair Bluetooth devices again.
  5. Contact T-Mobile Again: Since this issue might be more widespread, consider asking T-Mobile if they are aware of any ongoing issues with Wi-Fi Calling preferences and if there are any patches or fixes planned for an upcoming software update.

  6. Samsung Support: Reach out to Samsung support to report the issue. They may have additional insights or solutions.

  7. Community Forums: Continue to monitor and participate in forums and discussion boards. Sometimes, other users or unofficial support channels might provide solutions or workarounds that are not yet widely known.

  8. Replacement Phones: Since T-Mobile has offered you two new S20 phones under warranty, go ahead and try them. If the issue persists with the new devices, it further indicates a software or carrier issue rather than a hardware problem.

  9. Alternative Solutions: In the meantime, continue using the workaround of switching to Airplane mode and manually changing the Wi-Fi Calling preference when necessary. Although tedious, it might be the most reliable interim solution until a permanent fix is available.

Given your situation, it's understandable how this issue impacts your daily life. Hopefully, T-Mobile or Samsung will acknowledge and address this problem soon. Keep documenting your interactions with support for reference and potential follow-ups.

Userlevel 1

The last I knew this was not a problem with Verizon (and XFinity Mobile and other Verizon offshoots).  TM is still not willing to admit that they are the source of the problem. 

However, if you complain enough they will provide you with one of their pico cell devices.  There is a $20 deposit for that.  That way you don’t need to worry about cell connections (and this setting) at least in the house.

I have yet to figure out why TM is doing this.  Probably just incompetence and/or laziness. 


I called TM yesterday to inquiry about this. The rep treated me like I was stupid. Kept telling me there is no service at my adddress when the entire issue is why is my

phone switching to cellular service and staying on cellular. He also suggested that I contact Apple because it could be an issue with my phone. After I told the guy repeatedly this is a known issue with TM. I even told him to go look in the community forum. He more or less ignored the issue.