Question

MLB The Show does not work on my T-mobile 5g internet box.


Badge

MLB The Show does not work on my T-mobile 5g internet box. It will say “Challenge Failed” when trying to play an online match. The game works perfectly fine when i bring my xbox to my parents house. But when i bring it back to my wifi, it doesn’t work. I test the NAT type until it’s open, I reset the router, etc. I’ve done everything I can think of and there no solution. Does anyone have this same problem?  This is the only game that won’t work either. This and NBA 2k brought me some issues. But i can play COD or shooters on my wifi… but cross play sports games seem to bring the issue 


10 replies

Same!!!! This is super super frustrating. Need answers!

Came here looking for answers also

Same thing, this didn’t start until early may.  However I can turn the hotspot on on my phone and it works fine. It’s not a question of speed. I can’t get answers for it anywhere

Here to see if anyone has solutions or fixes

Any updates on a fix.  We’re going to have to switch back to Spectrum if T-mobile doesn’t have a fix soon.

 

I have the same problem. I have reset router multiple times all other games work on console. looks like I need to go back to my old provider.

Badge

Dont look like we will get a fix.  I will have to switch providers as well as soon as MLB TS 24 drops. 

MLB the show is now working on my Xbox series S with T-Mobile home Internet. I switched the multiplayer connection from one position to another until it worked. It will work for a few weeks then I have to reset the router sometimes several times but it will start working again. I’m saving $80 a month from my old provider so I’m willing to live with resetting my router every few weeks.

Has anyone figured it out yet or is there settings on the tmobile 5g that needs to ve fixed so it can work? I haven't been able to play online in a month and it's making me frustrated. I called tmobile and they don't know why its not working and told me to contact San Diego studios I have yet to do that. But has anyone figured it out?

Okay, its not certain but after days and days of research the one thing that seems to have worked.. and now this could be just a lucky go at it but I went into my tmobile router app or whatever. I went ahead and switched the security from WPA2/WPA3 to just WPA2 so far its working.. I do use tmobile home internet. so hoping this actually is a work around..

Reply