Question

smart tv connection to tmobile home internet

  • 1 November 2021
  • 8 replies
  • 17339 views

Badge
  • First activity
  • 0 replies

Tmobile home internet can't connect to my roku tv. It's visible. But it won't let me connect. I tried my new password, the admin password, and the wifi key. None of them work. When I turn my S21 ultra into a hotspot, that seems to connect just fine to my tv.


8 replies

Userlevel 1
Badge

@nc1037 This works!!!!!!! Dancing a happy dance right now! THANK YOU😘

Userlevel 5
Badge +8

You shouldn’t change the default network frequency band settings.  It will automatically select 5 GHz or 2.4 GHz for each device.  I really appreciate this, because with my old router, I often needed to switch my TV from one to the other.  Also don’t change the default security settings.  Leave it at WPA2/WPA3.  This is significantly more secure than WPA/WPA2.  The default will work fine for most things.  You can rename the network and change the password.  

If your TV or any other device doesn't work with the default network, you can ADD a SECOND network that is 2.4 GHz (or 5 GHz) and with WPA/WPA2 security.  WPA/WPA2 is significantly less secure than WPA2/WPA3 so you want to avoid it if you can.  You can make the network Hidden so you have to type in its name, which will help secure it a bit.

Add the second network with the + at the bottom right of the Network tab on the app.  You can add a third network if you want.  So you could have the original default network, a dedicated 2.4 GHz network, and a dedicated 5 GHz network.

Had the same problem woth my Samsung TV. Thankfully there’s an easy fix:

First:

Change the Frequency Band to 5GHz instead of automatic

Second:

change the “WPA Version” to WPA/WPA2 

the WPA Encryption mode should say 

“TKIP & AES”

Turn your tv off and back on and try to reconnect. It should work

Did you rename the 2.4 and 5ghz wifi bands. The router has 3 bands all with the same name. Make sure the password is the same for all.

If your TV or any other device doesn't work with the default network, you can ADD a SECOND network that is 2.4 GHz (or 5 GHz) and with WPA/WPA2 security.  

This is the only fix that works for me!

 

Badge

Some devices will only like the WPA2 encryption vice the WPA3, try lowering the encryption level on SSID-1. Also some of devices may only the 2.4ghz so make sure the device matches SSID-1.

Yeah you’re right. I went back and change the settings again and found out all I had to do was just change the frequency to 5GHz instead of 2.5. I think my tv just couldn’t connect unless it was set to 5GHz instead of automatic. Definitely far less safe having it set to the settings I had previously, but it was the only way at the moment and ran with it. Luckily everything works fine now without compromising security 

i cant connect my tv to wifi and has been 

 

Reply