Question

T-Mobile Home Internet Account Constantly Disconnects

  • 24 December 2022
  • 4 replies
  • 1321 views

Badge

My T-Mobile Home Internet app constantly disconnects.  Each time I open the app I’m prompted with a statement “let’s get you reconnected” and if it does connect on occasion I see there’s an “X” for the connection to the internet.  If I reboot the gateway I sometimes can login successfully but the next time I attempt to access, I get the “let’s get you reconnected” message.  Anyone have any thoughts as to what might be happening and how to resolve this issue?


4 replies

Userlevel 6
Badge +7

Are you on an iPhone? If so, the T-Mobile application is terrible on that platform. I also had the same problem you're describing.

The way I fixed it was to shutdown and then restart my iPhone. As soon as the phone rebooted, I launched the T-Mobile Internet app, and it would work.

I usually kill apps that I'm not using, but I decided to leave it running and just use the phone as I usually do for email, browsing, IMDB, etc. Then, when I went back to the app, it alwasys opened right to the home page.

I can't tell you that’s the solution universally, but it worked for me on an iPhone 14 Pro running iOS 16.2.

Also, for the record, I'm on the Arcadyan KVD21 5G Gateway with about 42 devices connected.

Badge

Thank you for the reply. I experience this issue on my Samsung S22 Ultra, Samsung Tablet and Windows 11 Laptop, it's pretty much universal with any device I use. If I reboot the gateway I can gain access one time, if I come out of the application and try to access again, I get the error. I also have the Arcadyan gateway. I don't lose internet connectivity when this happens I just can't connect to the gateway via the application. 

Userlevel 6
Badge +7

I'm on a Mac, in an Apple environment. I gave up on Windows a long time ago. I don't know why that’s happening to you, but the general feedback on this forum is that the Android phones are more stable than iOS with the TMHI app.

Reluctantly, I'd have to tell you to talk to support and see if they know how to resolve your problem. The Arcadyan is the only gateway or modem I've ever used that didn't have a web interface, so for what little configuration you can do on the KVD21 has to be done via the app that T-Mobile supplies.

I, for one, would like to know how you make out. The solution that finally fixes your problem would be helpful to others with the same problem.

Userlevel 7
Badge +8

I have the iPhone 12 Pro and I see the same behavior. The phone IS connected to the wireless network but the useless application wants to get connected. I have tried multiple options to try to overcome the problem over the past couple of years. The one that seems to have some success is when the mobile application presents that overlay screen I leave the application open but I toggle off the wireless for say 15-20 seconds, it varies as I don’t count or anything, and then toggle the wireless radio on the phone back on. Sometimes that works and the application will present the login screen for the admin account access. The application is pretty unpredictable. Arcadyan and Sagemcon gateway users are stuck with using that mobile application due to T-Mobile crippling the web GUI access. I firmly believe it is about penny pinching as they don’t want to maintain both the mobile application and a web driven interface. When the Arcadyan released on the first firmware release it DID have the web GUI interface. After the upgrade was pushed out that was gone. So much for functionality.

Reply