Question

5G Home Internet: IPV6 with Asus RT-AC68U

  • 12 April 2021
  • 8 replies
  • 1750 views

Badge
  • First activity
  • 0 replies

Does anyone have IPV6 working with the T-Mobile 5G gateway feeding packets to an Asus RT-AC68U router?

I do have this working for IPV4, caveats on double NAT notwithstanding.

Can’t seem to get IPV6 configured properly on the RT-AC68U. “Native” mode doesn’t work at all. “Passthrough” sort of works (devices get addresses via SLAAC) at first, but blows up due to a MTU issue (router bug?).

If you have it working please share how you configured it and what your firmware revision is. Many thanks.


8 replies

Realize this is now 7mo old. Starting to play around myself and ran into the dreaded double NAT issues. They really need a solution. If I switch my Asus router to AP mode to solve this I'll loose all my parental controls over my kids!

Anyone figure out IPV6 on this Asus RT-AC68U router yet?  I can set to native (no ipv6 connections get through). but if I try to use pass through I lose all internet connections.  I have this cat cabled to TMO and all my devices connected to the Asus wifi seem to work until I try pass through.  Pretty Frustrating!  Note:  My TMO gateway is the new  Arcaydyn.

 

Badge

Hello --No I have the same issue and I use merlin on the ASUS. Did you ever figure out a solution?

It *seems* to be working for me.

I have T-Mobile’s Arcadyan KVD21 5G Gateway with the radio turned off (thank you Nater Tater/YouTube) in front of my ASUS RT-AC68U in router mode connected by CAT5 cable.  Yes, unfortunately this is a double NAT situation but prefer this setup to access point (AP) mode since although AP is simpler and avoids double NAT, I’d lose the ASUS’s firewall that way. 

Anyway, on the ASUS I set the IPv6 ‘Connection Type’ to Passthrough with ‘Connect to DNS Server automatically’ to Enable.  After clicking ‘Apply’, I tested using IPCONFIG.exe from Window’s Command Prompt and IP6 addresses were showing.  Then I went to https://test-ipv6.com/ and scored 10/10 for ‘IPv6 stability and readiness.’  The ‘Tests Run’ tab showed ‘ok’ for all 8 tests.  I have several PCs and they all worked fine at this site, and all had different IPv4 and IPv6 addresses, The reason I said it *seems* to be working for me is that the https://solutions.t-mobile.com/support/ipv6 page claims ‘No, you are not currently connected via IPv6.’ so I’m not sure how to reconcile that with the test-ipv6.com results.

Badge

@unspecified. Thanks. I have the Arcayan too and I have the wifi turned off as well and have the 68U connected via a Cat 5 Cable. I tried pass thru and it did not work. I am going to try again and will let you know what happens with mine.

Badge

Hello @unspecified I have a very similar set up. I went in and set the pass thru and ran tests. Then I went back in and kept it with pass thru. For DNS settings I disabled connect automatically and used googles 2001:4860:4860:8888 and for the second one 8844 as the last 4. When I tested with tmobile site it says not connected to ipv6.

When I connect to https://ipv6-test.com/it shows a 17 of 20 an  Id says that it fallsback to IPV4 in less than 1 second

When I connect to https://test-ipv6.com/ it shows 10 of 10

This is with my computer plugged in via ethernet to asus 68 router which is plugged in as router mode to tmobile Arcadyan KVD21’

When I run tests from chromebook which is connected to wifi --ipv6 tests fail

 

And I can longer get to the community from computer and have to use chromebook to get to this page. I have no idea why

Badge

OK. I think I got it.  I am using a native connection and I went with quad9servers

2620:fe:0:0:0:0:0:fe, 2620:fe:0:0:0:0:0:9

I pass every test except the tmobile address that the poster listed. I can get to IPV6 only addresses.

Badge

I am using a deco mesh in access point mode to avoid 2xNat.  Seems ok not sure bout ipv6 issues. I wish there is a bridge mode on the sagemcom

 

Reply