Question

Windows laptop can't find T-Mobile Home Internet network... but all other devices can

  • 10 February 2021
  • 82 replies
  • 50809 views


Show first post

82 replies

PROBLEM SOLVED.  I was having the same issue with an older Asus laptop. When I had the 4G LTE router/modem from T-Mobile the network would show up on my laptop but once I got the 5G one the network wouldn't show up on my laptop but it would show up on all other devices. The work around I found was purchasing the TP-Link RE300 range extender. You connect the range extender to the 5G router/modem then connect the problem device to the range extender. In my case it was my laptop which is now connected to the range extender and working fine. This range extender is 2.4ghz and 5g compatible. Not sure if other range extenders would work as this is the only one I own and have tried. Also, I just ran a speed test and there's no noticeable difference in speed due to being connected to the range extender instead of the T-Mobile router/modem directly.

 

The range extender I bought was only like $30 or $40 dollars and was very easy to set up. 

Thank you so much.  This is what worked for me, and my 10-year old laptop...which worked fine on every other wireless device, prior.  I read this last night, Amazon delivered the TP-Link RE300 ($30) 25 minutes ago, and I am typing this connected, as you describe.  I really appreciate your efforts to not only solve, but to share.

NC1037

Well guess what, plugged the USB adapters in and both computers instantly recognized the T Mobile Gateway in both the 5Gig & 2.4Gig bands. Hate to have to buy the adapters but for a non computer literate its the far less frustrating option. Again thanks for all your help.

Hi everyone, I had the same issue with my computer not seeing the SSID. in order to solve this problem in my windows 10 laptop computer I went to device manager looked up my network adapter name. then I went to the maker of the WIFI card on my laptop. In my case it was intel. (When i ran the update driver in windows it said that i had the latest driver) don’t listen to that, i went to intel’s site downloaded the exact driver that my device manager said i had, installed it and viola it saw the SSID. I am now connected. The intel site said that the card was discontinued but i still downloaded the latest driver which was from 2019. Try this it worked for me. Apparently windows only uses parts of the full driver.

Userlevel 7
Badge +8

The addition of a range extender makes sense to me if the client, say a printer or game device will not allow you add a USB network adapter. I had the same issues with two older clients that could not connect to the T-Mobile gateway. I bought the newer compatible USB WiFi adapters for the clients. Installing an older slower device in between as a shim is ok but not the best approach. I have never had a good experience with range extenders but they are useful in some cases. If you are going to use a range extender don’t buy a cheap one or you may be disappointed. My suggestion is to update/replace the adapter on the client with a newer USB wireless adapter and disable the old wireless adapter that cannot communicate with the newer bands. 
If you run Linux as an operating system there are some very solid USB adapters with driver support. Why run an old 802.11b adapter when you can run a newer, faster frequency? If the need for distance and signal penetration is there sure but with band steering on 802.11ax the transmission should be able to adapt to communicate. Update the client instead of putting a work around in between when possible. Just my 2 cents. 

Same issue after re-starting router home PC doesn’t SEE router but other devices in same room work Fine.   It is STUPID that tech support is a community share and NOT T-Mobile techs fixing the problem.  Oh and the app locks up anytime I attempt to see devices

Dell Inspiron something something, about 4 year old laptop.

I had to use windows updater (optional updates) to update drivers. I had intel wifi and a realtek driver that I updated so idk which actually fixed the issue.

 

I tried installing intel wifi drivers from website and it was ‘up-to-date’. Even with the instel system diagnostic software.

Never figured out how to change channels and stuff. My only options are to use combined or 2.4 and 5 separated. Couldn’t find any advanced settings to do more than that.

This is how I fixed my issue with an old Dell Notebook PC with the following network adapter:

Intel(R) Dual Band Wireless-AC 3160

I simply went to Device Manager, located that network adapter in the device manager, uninstalled it by right-clicking on that device, and then go to ACTION, “scan for hardware changes”, and then the WIFI network came up immediately!

Hope this helps!!!

 

Badge

Do you have both 2.4 and 5ghz broadcasting? I think some older laptops can’t see both 

I do… interesting theory. Any thoughts as to a workaround? Pretty sure I don’t want to disable either one...

If they’re both broadcasting then it should pick up the right one. I have a Tovala oven connected that only works with 2.4 and it’s working. That’s super odd. I have two asus laptops myself that connect fine but the oldest is only about 3 years old so it might be newer than yours. 

I have the exact same issue. It won't show up on the list of available networks of my laptop. It has windows 10 too. It shows and works fine in other devices (laptops, cellphones, tablets). I don't know what to do about it

Userlevel 7
Badge +15

Does the laptop support the type of security you selected for the WiFi from the modem?  Older laptops might not work with WPA2.  Try setting the2.4GHz and 5GHz to WPA Personal to see if that works.  

I have the exact same issue. It won't show up on the list of available networks of my laptop.  hellodear.in
 

  tea tv apk


 

The best thing to do if you can. Return to modem and go back to who you hade before making the switch to tmoblie. I’m stuck in limbo. Tech support doesn’t know how to connect my laptop to the modem I keep getting rerouted to different tech supports. This was to good to to be true. Internet works but laptop unable to see tmobile modem. I keep talking to people that is unable to speak english

Userlevel 5
Badge +7

Some older computers and devices don’t work well with the default network settings.  You should leave those settings alone for all your devices that do work well.  But if your computer or other device can’t see the default network, you need to add a second network.

Here are T-Mobile’s instructions for how to do this with the app.

iOS: iOS How to create additional Wi-Fi networks

Android:  Android How to create additional Wi-Fi networks

i was unable to connect an older microsoft surface pro to the t-mobile wifi, but all my other devices could connect. the network name was visible, but when i tried to connect i got an error stating that i could not connect to that network. i have a t-mobile black tower model FAST 5688W. first thing i did was insure that my wireless network adapter was up to date. i then disable and then enable the network adapter. i then tried connecting again and got the same error.  i then logged into the t-mobile internet app and created a second wifi network. i set new network's frequency band to “2.4 GHz” and the WPA Version to “WPA2”. i used this new network name to connect to my surface pro and the connection was successful. i left all my other devices connected to the original network.

Known issue on older devices. The Intel WiFi drivers need to be updated.

ac3160 wifi no longer supported

I have the exact same issue. It won't show up on the list of available networks of my laptop. It has windows 10 too.

Userlevel 3
Badge
  1. Which TMobile device are your talking about? Is this the New Nokia Gray Tower?
  2. If so, how did you set up the Wifi network in your home, did you set your own SSID’s or are you using the TMobile WiFI name?
  3. Did you select your own channels? Or do you have it on “Auto”?

The reason for my questions is because of this;

The Nokia Tower offers a wide selection of Wifi Channels which is fantastic. These channels are used world wide meaning not all channels are used in all countries. Its a global device. The Channels offered to us in the USA includes some channels with restrictions and not commonly used in typical routers. In this respect the Nokia router is superior, as you can truly set a channel in a crowded wifi area that no one else uses. 

The down side is, since these channels are not commonly used in the USA some devices are not programmed/capable of seeing them. So if you set your own channel you may have selected channels your device can not see, change it to a commonly used channel or simply set it to “Auto” and let the device choose your channel for you. 

More or less, it is something with your computer and not the Nokia Tower. Try refreshing your network on the computer because no matter what, its should be seeing the 2.5 network at the least, no matter what settings on the router. 

Userlevel 6
Badge +9

I have updated the drivers, changed the Channel, enabled and disabled the wifi device. Nothing works. This is a Dell Inspiron 7548.I am very frustrated by this.

 

Have you tried one of the other methods mentioned earlier?

 

  1. Activating and renaming the SSID of one of the 2.4GHz channels so that it is not shared (basically allowing non-WiFi6 access)
  2. Lowering the transmission mode to an older standard (example, ax/g to n/g)
  3. Lowering the encryption (WPA) to an older standard (example, WPA3 to WPA2)
Userlevel 7
Badge +8

The best resolution is to get a USB network adapter that is 802.11ax. 

Userlevel 7
Badge +15

Auto is not the setting you want to set your router to for WiFi Channels!  There are a lot of devices out there that are very specific about the channels they will work on.  3, 6, and 9 are usually the most compatible channels but also usually the most congested channels as well.  Nintendo is well known for not liking anything other than 3, 6, or 9 for the Wii, Wii U, and DS/3DS.  If your laptop can see the WiFi to connect to but can’t connect to it.  Then it is more than likely the security setting that is preventing it from connecting.  It could also potentially be the channel but that is much less likely.  Channels 1, 11, 12, 13, and 14 for 2.4GHz and 5GHz are usually the least compatible channels to set your router to.  If it can’t see the WiFi connection at all on both 2.4GHz and 5GHz.  Then the issue is more than likely with the laptop.  Whether it is a hardware compatibility, firmware compatibility, or driver issue.  That will take a little more effort to narrow down.  

I’m trying to change the settings on the router but the Admin IP just takes me to description page with a link to the app, which doesn’t have any option to change those settings.  Is there any way I can still access the router settings through the admin IP or do I have to use the app?

Userlevel 7
Badge +8

With the Arcadyan or Sagemcon gateways the mobile application is T-Mobile’s method for managing the units. 

All this is a common issue because of the age of your client device(laptop, phone etc). This is because the wireless card in the device does not support the newest 2.4ghz bands that the T-Mobile devices comes defaulted to. 

 

You do not need to buy an extender or any other piece of equipment, only change one setting on the router. 

 

You will want to log into the router settings, theses are found on the bottom of the T-Mobile device. 

 

Navigate to:

  1. Network
  2. Wi-Fi Network
  3. 2.4ghz
    1. Change Transmission Mode from “Auto(AX/G) 
    2. Start with N/G - if your device still cannot see the Wireless Network - go to next step
    3. Change to B/G

Due to the age of the device it is not a big deal to have a lower transmission speed on the 2.4ghz channel - all modern devices will connect to the 5ghz channel or WiFi 6 if your device supports it. 

 

Hope this helps! 

 

If you need any other IT Services feel free to reach out to us! www.cloudITaustin.com 

 

 

I don’t know if people are still having this problem.  I am, and it looks like T-Mobile has removed the ability to make these kinds of changes.  The left side menu is not there anymore when I go to my gateway’s IP.  I’m thinking of trying the range extender solution...

I could not see any networks on my Windows 10 computer and wifi was working but disconnected, so I was without internet access. To reconnect, “Devices” did nothing--I needed to search on “Services,” then WLan AutoConfig, Start-up Type Automatic (it had said Manual), Apply, and Start in left panel. Then all was back to normal. Hopes this helps someone else.

I was having this issue with:

Realtek rtl8723au 

and 

Edimax EW-7811Un (Popular for raspberry Pi units)

My fix on the 5G gateway was to change the following in 2.4 GHz settings

Transmission Mode from “Auto (ax/g)” to “n/g”

worked for both devices. For really old network cards (Hands up if you still use windows xp!), you could change this to “b/g” or even “b”, but if it does not support WPA, you would (NOT RECOMMENDED) be required to disable encryption all together...I would recommend an ethernet cable at that point.

Reply