Question

Windows laptop can't find T-Mobile Home Internet network... but all other devices can

  • 10 February 2021
  • 82 replies
  • 50820 views


Show first post

82 replies

Mine won't connect to tmoble wifi either but connects find to different Wi-Fi networks that I've tried.. following 

I hav the same problem as many above. Two Dell lap tops, 7440 & 5440, one running win10 (7440) and one win11 (5440) neither can find the TMobile gateway, however both can connect to other Wi-Fi routers with no issues.  After several hrs on multiple occasions with TMobile tech support no luck. Have iPhone 14’s, iPad Pro, iPad Air 2, Amazon Alexa all of which can access the 5G Gateway with no problem. The 7440 is about 10+ years old and the 5440 is 1+ year old. I just found this page so sure would appreciate if some could address my issues, so frustrated I’m about ready to trash the TMobile Gateway and go to Spectrum!!!

Userlevel 2
Badge

Mine won't connect to tmoble wifi either but connects find to different Wi-Fi networks that I've tried.. following 

What’s your hardware? I’m using an Asus laptop that’s probably 3-4 years old.

Mine won't connect to tmoble wifi either but connects find to different Wi-Fi networks that I've tried.. following 

What’s your hardware? I’m using an Asus laptop that’s probably 3-4 years old.

About the same.. age wise and its an asus too.. but even my daughter’s tablet / laptop combo wont connect to tomobile wifi. It conected to Spectrums just fine. 😞 Both of them connected to spectrum but my wifi name isnt even popping up to select it. 

Userlevel 5
Badge +7

INSTRUCTIONS

Some devices, such as printers, have trouble connecting to the gateway’s default configuration.

You can have several Wi-Fi networks on the gateway.  You want to leave the default network alone (2.4 & 5 GHz; WPA2/WPA3 and AES security) and add a second, dedicated 2.4 GHz network.  This second network is for devices that can’t connect to the default network.

Add the second network with the + sign at the bottom of the Network tab in the T-Mobile Internet app on your phone.  For this new network, set the band to 2.4 GHz and set the WPA version to WPA/WPA2.   (The encryption will automatically change to “TKIP & AES”)  Try connecting your device to this second network.

Use the default network for your other devices, as much as possible.  Note that WPA/WPA2 (on the second network) is less secure, so I recommend setting this network to be Hidden. You can hide it after you get your devices connected to it.

Here are the T-Mobile support instructions for how to add the second network with the app.

Android  How to create additional Wi-Fi networks | T-Mobile Internet app | Android | T-Mobile Support

iOS  How to create additional Wi-Fi networks | T-Mobile Internet app | iOS | T-Mobile Support

Main instructions

Help Center | APP Android | T-Mobile Support

Help Center | APP iOS | T-Mobile Support

nc1037, thanks soooo much for your response. I see that the instruction links u provided seem to be for Apple & Android iOS, are there any for windows 10&11 pc’s?? Thanks again!!!

Userlevel 5
Badge +7

@Chaz7138 you need to use the app on your phone to manage your TMHI gateway.  After you create the second network, you connect your computers to the new network the same as usual. 

Badge

Was having the same problem, tried the solution above by JaimieCF (except my extender is an el-cheapo Xiaomi brand)and it worked. Thanks.

nc1037

Well i set up a new 2.4GH network but computers still wont connect. on the win 10 unit the “manage network screen shows both the 5G & 2.4G networks, however when I switch “show available networks neither shows up. on the win 11 unit doesn’’t show either.  I ordered 2 USB 5.0 WIFI adapters today which support both 5G & 2.4G.Hopefully they will work.

Thanks again for your help!!!

Userlevel 7
Badge +15

Try setting the 2.5GHz security to WEP, if that is an option to see if that works.

Userlevel 5
Badge +7

@Chaz7138 you shouldn’t need a new wi-fi adapter.  Have you tried the others tips in this discussion, such as checking for driver updates, and your Services settings?  I can try to get images from my ancient Dell desktop.

Nc1037

First let me say thank u so much for trying to help me. No I haven’t tried any those. I’m an 81 year old neophyte when it comes to computers and how they should work. I can move around win 10 ok but I just got the win 11 unit in so the os is completely new to me. I was able to watch a you tube Video on how to boot the computer without Wi-Fi but have been stuck ever since just trying my win 10 to connect to the TMobile gateway, which I have had to work on an ethernet cable for over a year while trying to get someone at TMobile to help. All they tell me, in the end, is to call the mfg of my computer. Dell tells me the computer is past its lifetime expectancy so they can’t help.. Sorry to rant but I’m quite frustrated with the whole TMobile thing, they know they have an issue with pc’s so why don’t they fix it. My USB Wi-Fi adapter is due in today so I’ll try that next then determine weather to stay with Tmobile or move to Spectrum. Thanks again for your help, have to run to a DR appt. now !

PROBLEM SOLVED.  I was having the same issue with an older Asus laptop. When I had the 4G LTE router/modem from T-Mobile the network would show up on my laptop but once I got the 5G one the network wouldn't show up on my laptop but it would show up on all other devices. The work around I found was purchasing the TP-Link RE300 range extender. You connect the range extender to the 5G router/modem then connect the problem device to the range extender. In my case it was my laptop which is now connected to the range extender and working fine. This range extender is 2.4ghz and 5g compatible. Not sure if other range extenders would work as this is the only one I own and have tried. Also, I just ran a speed test and there's no noticeable difference in speed due to being connected to the range extender instead of the T-Mobile router/modem directly.

 

The range extender I bought was only like $30 or $40 dollars and was very easy to set up. 

YOU, SIR, ARE A GENIUS.

 

I actually had this in my stock of random "one day I might need to use" items & the instant I read your words *TP-Link RE300 range extender* I immediately knew I needed to go find it quick like. 

Somehow it translates the signal from one standard to the other.  My desktop computer's old USB wireless adapter was bought back in 2019 so it wasn't that old.  Happens to be TP-Link branded, too. 

 

I was scratching my head on this one here until I started looking to the Internet to see if I was alone & sure enough, you fine people also had the same headaches 

 

Thank you to JaimieCF for your wonderful solution to our problems.

I'm so glad I kept this device because it turned out to be a lifesaver right now.  I have the TP-Link RE105 model & I think I paid 40 at Best Buy.  

This solution works wonders. 

Userlevel 5
Badge +7

The support people don’t have hands-on experience; they work from scripts.  

Since your USB Wi-Fi adapter is due in today, I’ll wait to see if that works for you.  If you would like, I can make screenshots of how to connect with Windows 11 and also Windows 10.

In the meantime, here’s what my THMI network looks like on my 12-year-old Dell desktop computer (Windows 10).  The driver is from Microsoft and is dated 2013.  (This is just proof that it can work.)

 

Userlevel 5
Badge +7

Here is what the default network looks like in T-Mobile Internet app.  I changed the network name and password; the rest of the configuration is as it came a year ago.  Most devices should be able to connect to this.  The next post will be the dedicated 2.4 GHz network.  
 

 

Hello all. I am new to the TMobile Gateway. I just got the grey Gateway tower and I am having the same issues with my older laptop not connecting or even seeing my SSID. Everyone else in my house can connect and be on it just fine but when I got to connect my laptop it won't come up. It's a Toshiba Satellite Pro L850 series running Windows 8. I have done everything I can think of to find my connection. I went in and made sure my Wifi adapter was up to date, rolled back the drivers and even went in to command prompt and did the config. Still nothing. What am I doing wrong or what do I need to do to get it to connect??

Userlevel 5
Badge +7

Dedicated 2.4 GHz network.  (second network).  It is Hidden because it is less secure than the primary default network.  It is easier to establish initial connection if it is not hidden. (Change to Hidden later)

 

Userlevel 7
Badge +15

Don't use auto for channels and always select AES, not AES and TKIP.  Channels 3, 6, and 9 are the most compatible for troubleshooting.  AES as well instead of TKIP or both.  WPA/WPA2 is usually enough for most devices but being a decade old...  WEP is a possibility for as high as the device might support when connecting.  I have am old color laser printer that uses WEP at best when connecting to 2.4GHz WiFi.  If you can, wire the device if the troubleshooting doesn't get it connected, if possible.

Badge

The t-mobile router doesn't work with some Dell computers.  T-mobile Philippines support was clueless, and so was Dell.  I solved the problem by connecting via a wifi extender.

Userlevel 5
Badge +7

@syaoran WEP is very old and less secure than WPA.  It’s not an option on my gateway. 
TKIP & AES is the only option with WPA/WPA2. 
I agree that AES only is best, and is the only option with WPA2/WPA3 or WPA2.
I don’t think not using auto channel selection is an option with my gateway.  Where do you see it?
other than the time I spend here in the forum, I spend less time fiddling with TMHI than I did with my 802.11ac router and spectrum modem or their predecessors.  I remember trial and error with channel selection on my 802.11n routers.  

I hope this helps someone experiencing my scenario where Laptop WIFI Adapter Driver is old...

After installing the T-Mobile Gateway Gray Kit I was unable to see the SSID name in the list of available networks on my 2017 HP Laptop running Windows 10, but everything else in the house connected, since I renamed Gateway to the previous router SSID name. I searched the type of wireless adapter I have in laptop, Intel Dual Band Wireless-AC 7265, and visited Intel site to update Wireless adapter Driver to the latest for my device, 19.51.33.1. After the update I am able to see the Gateway SSID and laptop connects.

To find WIFI adapter name: Right click internet icon in Task Bar > Open Network & Internet Settings > select ‘WIFI’ > ‘Harware Properties’. Look for Manufacturer Name an Model. Go to manufacturer site and search for driver download; mine was an executable file, which installed and updated after a few prompts.

One may access the T-Mobile Gateway Settings by connecting Laptop directly to Gateway via LAN cable into back of Gateway and enter 192.168.12.1 into browser. One may view and modify the 2.4GHz and 5GHz WIFI Networks Settings. Username: admin > Password: (Is what you determined during installation, or the default listed on bottom of Gateway.) I’m using my laptop on the 2.4GHz network, so I changed the Gateway Channel from default 1 to 11, this didn’t affect the other devices already connected. None of these changes had any affect on laptop SSID discovery until after I updated the Driver.

Same issue here and this is what I also did. Great advice here!

Not a computer geek, electronic hobbyist 60+ years, electronic service rep for a year--all this to give background.  I believe Anthony C’s post above was absolutely correct.  Set up Gateway, connected 2 smart TVs, year old Lenovo laptop (Win 11), 20 yr old Toshiba laptop (Win 7), old HP desktop (Win 7), two smartphones to Gateway with no trouble--WiFi listed on all 7 devices.  All devices have been on our Century Link WiFi router.  Could not get 9 yr old Lenovo 11S to find Gateway.  Traveled with this laptop for business/pleasure, never problem connecting before.  Spent between 2-3 hours with TM tech assist, yesterday, no luck.  Came across post about transmission channels, logged into CL router, was transmitting on Channel 6 (not set on Auto).  Changed TM Gateway to channel 6 (from auto), laptop display would not list Gateway (I had deleted the CL router already).  I then did what Anthony C recommended, changing the Transmission mode from (Auto) AX/G to N/G and immediately the Gateway appeared.  I can’t explain how a 20 year old laptop and a desktop, both running Win 7 can identify the Gateway Auto (AX/G) and this Lenovo couldn’t, other than a Network Adapter quirk.  I probably spent 4 hours or more of my own time updating the adapter driver, searching the web, another few hours with Tech Support.  My suggestion:  Do as Anthony C suggested--log in as administrator and try changing the transmission protocol.  TMobile Tech support needs to get with the program.  Thank you, Anthony!!

I have the same issue with an old Windows 7 64-bit laptop that cannot detect the Wireless connection, I change the 2.4GHz transmission mode to n/g and the T Mobile Wireless Network was instantly detected. After that everything is working fine with a download speed between 21-29 Mbps.

 

 

 

Solved! The issue is your Proxy Server.When proxy is enabled, your network data gets transmitted differently than it would when proxy is disabled.

Therefore, turn the proxy server off on your PC and see if that helps you get rid of your problem. You can always turn the proxy server on with a few clicks. Here is the link to how disable the proxy server. 

https://helpdeskgeek.com/help-desk/how-to-fix-the-remote-device-wont-accept-the-connection-error/

Here’s how to disable proxy:

  1. Open the Run box by pressing Windows + R keys at the same time.
  2. Type inetcpl.cpl in the Run box and press Enter.
  1. In the Internet Properties window that opens, select the Connections tab.
  2. In the Connections tab, at the bottom, select the LAN settings button.
  1. On the Local Area Network (LAN) Settings window, disable the Use a proxy server for your LAN option. Then, select OK.
  1. Select Apply and then OK on the Internet Properties window.

This is how I fixed my issue with an old Dell Notebook PC with the following network adapter:

Intel(R) Dual Band Wireless-AC 3160

I simply went to Device Manager, located that network adapter in the device manager, uninstalled it by right-clicking on that device, and then go to ACTION, “scan for hardware changes”, and then the WIFI network came up immediately!

Hope this helps!!!

 

Sorry to say, did not work for me. Same AC 3160. Did you check “Delete the driver software for the device” ?  I did not. Thank you.

Reply