Windows laptop can't find T-Mobile Home Internet network... but all other devices can

  • 10 February 2021
  • 82 replies

Userlevel 2

Just set up my gateway… working fine for the most part, but it doesn’t appear in the list of available networks on my Windows 10 laptop. Phone, tablet, another laptop elsewhere in the house… the network shows up just fine on all those devices.

Any idea what would cause this? TIA!

82 replies

Userlevel 7
Badge +8

If you have the Arcadyan or Sagemcon gateway you cannot manage the gateway with the admin account via the web GUI. The way T-Mobile has those set you are required to manage them via the T-Mobile home internet mobile application. You download it from the respective mobile application store. The home internet application seems to work much more reliably on Android but can be difficult with Apple iOS. 

There are also some good videos on YouTube by Nater Tater. If you have not seen these you should check them out. He has very good information for working around configurations with the gateways.

Known issue on older devices. The Intel WiFi drivers need to be updated.

ac3160 wifi no longer supported

I have the exact same issue. It won't show up on the list of available networks of my laptop. It has windows 10 too.

Userlevel 7
Badge +8

The best resolution is to get a USB network adapter that is 802.11ax. 

I’m trying to change the settings on the router but the Admin IP just takes me to description page with a link to the app, which doesn’t have any option to change those settings.  Is there any way I can still access the router settings through the admin IP or do I have to use the app?

Userlevel 7
Badge +8

With the Arcadyan or Sagemcon gateways the mobile application is T-Mobile’s method for managing the units. 

I have the exact same issue. It won't show up on the list of available networks of my laptop.

  tea tv apk


Same situation

I had same issue one of my laptop wasnt connecting to 5 GHz gateway.  However connects to 2.4 GHz gateway automatically without issues.

I have the same issue with an old Windows 7 64-bit laptop that cannot detect the Wireless connection, I change the 2.4GHz transmission mode to n/g and the T Mobile Wireless Network was instantly detected. After that everything is working fine with a download speed between 21-29 Mbps.




I switched to T-mobile over a year ago and I’ve had to keep our old provider allllll this time, because 1 desktop PC in the house couldn’t find the gateway.  

All total, I probably spent a solid week’s worth of time reading these forums, doing all the stuff posted here, having support walking me through fixes (that failed), and even reading forums and support from other companies, whose users were having the same issue with those products.  

I even tried skipping the wireless and plugging it into the Ethernet port on the gateway, since it’s a desktop PC and not going anywhere, but those hopes were crushed when I discovered it’s in the one place in my house where the gateway couldn’t get a  signal.  

Last week, I was putting in a grocery order in at Walmart, not even close to thinking about technical annoyances, and I had a brain storm.  I added a USB wifi adapter to the grocery order.  When it arrived, I plugged it in, ran the setup, and BOOM! the T-mobile gateway appeared on the list.  

A whopping $9.99 and 5 minutes solved the problem. The desktop PC is online, its user is happy as a pig in slop, and I can FINALLY kick my old provider to the curb. 

Sometimes it pays to think outside the box, and inside the Walmart bag.  😄

Same issue after re-starting router home PC doesn’t SEE router but other devices in same room work Fine.   It is STUPID that tech support is a community share and NOT T-Mobile techs fixing the problem.  Oh and the app locks up anytime I attempt to see devices

Userlevel 5
Badge +8

Some older computers and devices don’t work well with the default network settings.  You should leave those settings alone for all your devices that do work well.  But if your computer or other device can’t see the default network, you need to add a second network.

Here are T-Mobile’s instructions for how to do this with the app.

iOS: iOS How to create additional Wi-Fi networks

Android:  Android How to create additional Wi-Fi networks

Solved! The issue is your Proxy Server.When proxy is enabled, your network data gets transmitted differently than it would when proxy is disabled.

Therefore, turn the proxy server off on your PC and see if that helps you get rid of your problem. You can always turn the proxy server on with a few clicks. Here is the link to how disable the proxy server.

Here’s how to disable proxy:

  1. Open the Run box by pressing Windows + R keys at the same time.
  2. Type inetcpl.cpl in the Run box and press Enter.
  1. In the Internet Properties window that opens, select the Connections tab.
  2. In the Connections tab, at the bottom, select the LAN settings button.
  1. On the Local Area Network (LAN) Settings window, disable the Use a proxy server for your LAN option. Then, select OK.
  1. Select Apply and then OK on the Internet Properties window.

The t-mobile router doesn't work with some Dell computers.  T-mobile Philippines support was clueless, and so was Dell.  I solved the problem by connecting via a wifi extender.

This is how I fixed my issue with an old Dell Notebook PC with the following network adapter:

Intel(R) Dual Band Wireless-AC 3160

I simply went to Device Manager, located that network adapter in the device manager, uninstalled it by right-clicking on that device, and then go to ACTION, “scan for hardware changes”, and then the WIFI network came up immediately!

Hope this helps!!!


Sorry to say, did not work for me. Same AC 3160. Did you check “Delete the driver software for the device” ?  I did not. Thank you.

I could not see any networks on my Windows 10 computer and wifi was working but disconnected, so I was without internet access. To reconnect, “Devices” did nothing--I needed to search on “Services,” then WLan AutoConfig, Start-up Type Automatic (it had said Manual), Apply, and Start in left panel. Then all was back to normal. Hopes this helps someone else.

All this is a common issue because of the age of your client device(laptop, phone etc). This is because the wireless card in the device does not support the newest 2.4ghz bands that the T-Mobile devices comes defaulted to. 


You do not need to buy an extender or any other piece of equipment, only change one setting on the router. 


You will want to log into the router settings, theses are found on the bottom of the T-Mobile device. 


Navigate to:

  1. Network
  2. Wi-Fi Network
  3. 2.4ghz
    1. Change Transmission Mode from “Auto(AX/G) 
    2. Start with N/G - if your device still cannot see the Wireless Network - go to next step
    3. Change to B/G

Due to the age of the device it is not a big deal to have a lower transmission speed on the 2.4ghz channel - all modern devices will connect to the 5ghz channel or WiFi 6 if your device supports it. 


Hope this helps! 


If you need any other IT Services feel free to reach out to us! 



I don’t know if people are still having this problem.  I am, and it looks like T-Mobile has removed the ability to make these kinds of changes.  The left side menu is not there anymore when I go to my gateway’s IP.  I’m thinking of trying the range extender solution...

I hav the same problem as many above. Two Dell lap tops, 7440 & 5440, one running win10 (7440) and one win11 (5440) neither can find the TMobile gateway, however both can connect to other Wi-Fi routers with no issues.  After several hrs on multiple occasions with TMobile tech support no luck. Have iPhone 14’s, iPad Pro, iPad Air 2, Amazon Alexa all of which can access the 5G Gateway with no problem. The 7440 is about 10+ years old and the 5440 is 1+ year old. I just found this page so sure would appreciate if some could address my issues, so frustrated I’m about ready to trash the TMobile Gateway and go to Spectrum!!!

Userlevel 5
Badge +8


Some devices, such as printers, have trouble connecting to the gateway’s default configuration.

You can have several Wi-Fi networks on the gateway.  You want to leave the default network alone (2.4 & 5 GHz; WPA2/WPA3 and AES security) and add a second, dedicated 2.4 GHz network.  This second network is for devices that can’t connect to the default network.

Add the second network with the + sign at the bottom of the Network tab in the T-Mobile Internet app on your phone.  For this new network, set the band to 2.4 GHz and set the WPA version to WPA/WPA2.   (The encryption will automatically change to “TKIP & AES”)  Try connecting your device to this second network.

Use the default network for your other devices, as much as possible.  Note that WPA/WPA2 (on the second network) is less secure, so I recommend setting this network to be Hidden. You can hide it after you get your devices connected to it.

Here are the T-Mobile support instructions for how to add the second network with the app.

Android  How to create additional Wi-Fi networks | T-Mobile Internet app | Android | T-Mobile Support

iOS  How to create additional Wi-Fi networks | T-Mobile Internet app | iOS | T-Mobile Support

Main instructions

Help Center | APP Android | T-Mobile Support

Help Center | APP iOS | T-Mobile Support

nc1037, thanks soooo much for your response. I see that the instruction links u provided seem to be for Apple & Android iOS, are there any for windows 10&11 pc’s?? Thanks again!!!

Userlevel 5
Badge +8

@Chaz7138 you need to use the app on your phone to manage your TMHI gateway.  After you create the second network, you connect your computers to the new network the same as usual. 


Well i set up a new 2.4GH network but computers still wont connect. on the win 10 unit the “manage network screen shows both the 5G & 2.4G networks, however when I switch “show available networks neither shows up. on the win 11 unit doesn’’t show either.  I ordered 2 USB 5.0 WIFI adapters today which support both 5G & 2.4G.Hopefully they will work.

Thanks again for your help!!!

Userlevel 7
Badge +15

Try setting the 2.5GHz security to WEP, if that is an option to see if that works.

Userlevel 5
Badge +8

@Chaz7138 you shouldn’t need a new wi-fi adapter.  Have you tried the others tips in this discussion, such as checking for driver updates, and your Services settings?  I can try to get images from my ancient Dell desktop.