Question

Home internet speeds extremely inconsistent and connection drops intermittently


Userlevel 1
Badge

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt


31 replies

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

Userlevel 5
Badge +5

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

Ah ask.

 

https://www.waveform.com/products/mimo-panel-kit-for-hotspots-routers?variant=39349359476839

 

FYI from the TMHI Facebook page

Hi folks! Waveform.com will be having a Black Friday/Cyber Monday sale starting on 11/22. I talked to our online sales team and they created a early access 15% off coupon for our popular MIMO antenna kits and individual RSRF-branded antennae just for this group!

This early access code is only valid until 11:59pm on 11/21, after that there will be a different code and discounts for other products.

Coupon code is: TMOBF21

Clicking this link will automatically apply the code as well:

https://www.waveform.com/discount/TMOBF21

Remember, if you guys ever have any questions, comments, or suggestions, feel free to message/@me or contact one of our sales associates via live chat, email, or telephone.

Userlevel 5
Badge +5

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

https://www.waveform.com/products/mimo-panel-kit-for-hotspots-routers?variant=39349359476839

I tried to post a discount code but got moterated

 

Badge

I installed a mimo panel antennae it helped a littel with the signal but im like everyone else 3mi from tower 50 hours on phone with tech in singapore telling me they are working on towers for 2 months noe they are finished and its just as bad as ever. i range from .2 to 25mbps 25mbps is rare and in theearly morning hours until 8am it drops immedialty to maybe 1-2 and signal bounces between that and .2 mbps ping is fairly constant 25-45 upload runs fairly consistent around 8 mbps all the time so tmobile can recieve my signal in a consistent matter. the dumps are always as people come online i live in a very rural area so not a lot of people my tower is along the I5 interstate hwy as are most of the towers but i can only connect to the one im on. ive driven and tested every tower with amazing speeds  until i get to my tower and got 6 mbps looking right at it. alll the others were 50-90 mbps total run around from tech support. network allocation is garbage. really cant wait to change as soon as im able.

rsri ,92-94

snr 10

rsrq -13

rssi -69

I had excellent service with the TMobile home internet.  The moment I had troubles is when I switched my cell phones from Verizon to TMobile.  Turns out that we are de-prioritizing the Nokia gateway when our family is using magenta Max data on our phones.  I wasn't connecting the phones to the gateway to keep the load off of it and the phones had unlimited premium data.  Turns out all the devices in the house are sharing and fighting over the same bandwidth even if each individual device is on its own data.  It is causing so much issues.  I guess I should have kept Verizon phone services and just keep TMOBILE home internet only.  If you live close to someone using T-Mobile or Metro they will also be sharing your data.  My family lives next door and they are hurting our speeds as well when they use their metro phone (same tower as TMobile) to watch YouTube and want not.  They don't have home internet so they are always on their phones and they are close enough to our house that I know when they are watching YouTube.  Did some crazy testing to figure out our issue.

Badge

I've never had any problem with T-Mobile in home 5g broadband before I live only 0.29 miles from the T-Mobile tower. I'm getting a constant 700Mb/100mb on my gaming desktop night and day with no slow downs at all. I can stream multiple TVs at the same time. I use at least a terabyte a month.

Reply