Solved

Can't Make Online Purchases


I've been trying to buy the Galaxy S9 from T-Mobile since the day it was released. I've tried literally every single day on multiple devices and even through the app on my phone, my mom's phone, and my sister's. No matter what I do it always comes up with an "Oops we hit a snag" error and then sends me back to select the phone and payment options after it starts to load the final screen that let's me purchase it. I'm so annoyed at this point that I'm ready to switch to another carrier. Has anyone else had this problem? If so, have you found a solution for it? I've tried clearing my cache, I've tried incognito mode, I've (as I already stated) used several different devices with no luck.

icon

Best answer by tmo_chris 6 April 2018, 20:23

View original

39 replies

I try everything and again in 2022 still having the same issue 😒

I change payment method with 5 different credit cards still doesn’t go through. This is very fustrating. If i go to the store to do it in-person. How much will the service cost me? Is it per line activation?

Because I am planning for 4 new lines to be activated with T-Mobile.
 

 

Badge

Same problem still occurring today

Same story as this originated 3 y ago. Wondering why TMobile had no resources to fix it , or they don’t wanna fix it because they want to 30$ activation fee? I am trying to place in purchase for days now, same problem, went to the store as they suggested me but the store can’t waive the activation fee. Thinking on taking my phone lines to another carrier. 

This is insane. I’ve had this problem for at least a week or two now and the last rep I spoke with seemed extremely unfamiliar with how T-Mobile even functions. All he seemed trained to do was to process the sale for me instead of fixing the problem. 

I've been trying to buy the Galaxy S20 FE from T-Mobile for the past 4 days. I've tried literally every single day on multiple devices and even visited the 3 showrooms - with No stock. IT IS SO FRUSTRATING to work with Tmobile. I am out of words to express my disgust. No matter what I do it always comes up with an "Oops we hit a snag" error and then sends me back to select the phone and payment options after it starts to load the final screen that let's me purchase it. This is purely annoying . Can anybody at Tmobile help me with aticket number so i can call “Expert” after 2 hours wait nd try to get this resolved. Has anyone else had this problem? 

 

This seems to be a problem clearly with many users as stated above and Tmobile basically doesnt care about its customers. High time somebody helps !!!!!!!!!!!!!

This is definitely a way to upswell you items. Looks like it’s been going on for years. I just opened my business line last week and go online to order and “Sorry your unable to order ANYTHING online right now.  Spoke to several people and it’s just a usual waste of time. They just want to upswell me more expensive things like air pods pro because AirPods 2nd Gen is “out of stock” No thanks. I want to order my merchandise myself, have proof of what I ordered, print proof of what I ordered and keep my proof of what I ordered and the terms of my order. I don’t want people on the phone messing with my account I’ve had way too many reps mess up my bills like Comcast who “couldn’t figure” out how to add my discount that was removed “by accident” by someone “in the back office” 

I have been trying to order a couple Otterbox cases for hours on the web and my phone and never get past the shipping page either. This has been going on for over 2 years? WTF?

Glad to see that this is still an issue over two years later.

Same. I suspect it’s to force you to call or go to a store so they can upsell you.

Glad to see that this is still an issue over two years later.

I too get the "oops, you hit a snag message." This seems to be a persistent problem with the website. I cannot believe it is specific to my account as suggested above because of the number of people whose account it is suggested it is specific too. Seems to be a shopping cart coding issue.

I am thinking the same thing.  I just tried to upgrade 2 phones and got the Oops message.  Again.  And again.  So irritating because this same thing happened a year ago when I tried to upgrade and they did try to charge me a fee for doing it via phone or messaging.  Seems awfully fishy.  I am wondering how much money T-Mobile has made over this "error".

If it is a scheme, then shame on T-Mobile.  If it is a true error, then shame on T-Mobile because it has been over a year and it still is not resolved.  I have some phones that I have to continue to pay on so am stuck but I think I am taking the other lines to a different carrier instead of upgrading. This is no way to treat longtime customers.

Tried to upgrade my phone on the mobile app as well as Chrome - hit the error on both platforms multiple times so far...

This is happening to me. I'm trying to upgrade my phone, and I get pretty far, however I get the "Oops! ..." modal after the Accessories page. The error occurs whether I chose an accessory, or "Skip Accessories" -- I would have bought an accessory just to get this thing to work, but alas, that didn't work.

I looked at the javascript console, the logs suggest there is missing data related to the shopping cart.

I was running into that very same issue earlier in the evening.  I waited an hour or so while I ate dinner and cooled my jets because I was about to punch a hole in my monitor.  At one point, I got an error telling me that I was not eligible for an upgrade...  once I was finally able to get back to the payment screen, I used the old zip code.  Seemed like a long-shot at the time - shocked it was the thing that was holding me up.  I mentioned the issue to the CSR who was helping me via Twitter and asked they look into it and maybe give it a try to troubleshoot this issue.  At the end of the day, it appears to be an internal issue with the company they use to process their credit cards. 

I wish I could get to the payment section to see if that works. It won’t let me get passed selecting the phone I want to buy before it says “oops! We’ve hit a snag!”

I think I have found a solution to this issue.  After dealing with this for 6.5 hours with a retail store, online messaging, telephone CSR's and finally the TMobile Twitter Support team, I tried using an old ZIP CODE while checking out..... and it worked.  I moved over a year ago... I used my current address, but changed the ZIP CODE in the billing portion to my old zip, and it worked.  I have had the same issue with Chevron gas as well..... my address is current in all of my banking institutions and bills.  This was an enormous hassle and waste of time - this needs to be corrected immediately - there is no reason so many people should be having these issues due to a faulty payment services system.

Getting same issue. tried with all the browsers in world. Not sure how much business t-mobile is losing . I just wanted to switch one of my Verizon line to my t-mobile account. tried everything.

NOT WORKING . PLEASE FIX.

Having the same issue, well over a year later and no resolution? I'm on the phone with T-mobile support and they simply claim that there is no issues with the website. How does this thread exist with so many people having the same issue and T-mobile still hasn't acknowledged the issue?

Still having the same issue. Reps have been super nice, but it’s still SO ANNOYING. I don’t want to see “oops we’ve hit a snag” ever again.

@tmo_mike_c​ thanks for the follow up, i just called in and did the upgrade and the upgrade fee was waved.

Userlevel 6
Badge +15

Are you getting this exact some error when trying to upgrade? We can have our care team file a Service Desk ticket if you haven't already. You should be able to make a purchase but if not, we can get this resolved.

@tmo_mike_c​ So you are saying you have had this "technical" issue since Nov 2018 and its still not resolved.  You should just tell your customers that it is not possible to upgrade/order phones Online and that they need to goto the store so you can charge them the $20 upgrade fee and see if you can upsell them on a more expensive devise or expensive plan, I get you run a business but dont waste your customers time spending hours trying to see if its a browser issue when this is probably just a way to get people to the store.  If that's NOT the case then you have serious issues with your development staff who cant fix a customer facing problem for over 8 MONTHS.

Having the same issue, tried all browser, multiple devices, cleared cache/cookies, even call Ed customer support and they where not able to get the system to give me my upgrade. I also tried support chat for over 2 hours and Cathleen was unsuccessful ln getting me an upgrade. This is beyond rediculous and im ready to leave T mobile for goo. Hello Amazon!

Same here. A quick Google search turns up hundreds of threads and comments about this issue going back over a year, with customer support representatives offering nothing helpful. Fun stuff.

Experiencing the same issue, considering switching if I'm honest so many issues

Reply