Solved

Sending E-mail SMS to T-Mobile Phone

  • 24 March 2018
  • 19 replies
  • 43042 views

Hey there!

My name is James, let me start with the summarized version of the issues:

     When sending a message from Gmail to a phone number **********@tmomail.com, the message successfully reaches the phone when that address is entered into the "To" or "Cc" field of the email, but the message is blocked when it is entered into the Bcc field. I tried this on multiple carriers and it seems that T-Mobile is the only one with an issue.

     Now for a more in depth explanation. I am currently testing to see if a Gmail account could be used as a quick alternative Mass Notification System for my company. I used my own cell and a few co-workers cells in the test, my own is T-Mobile and the others were AT&T and Verizon. When I sent the message from Gmail to the respective phone numbers, it reached everyone, but I had entered the addresses into the "To" field on the email. For obvious privacy and security reasons, its preferred to enter them into the "Bcc" field of the email, that way not everyone sees all of the numbers.

     T-Mobile was the only carrier that I tested that blocked the message, only when sent it the Bcc field, it worked from the same Gmail address when sent in both the To and Cc fields. I am wondering if this is a known issue or if there is anyway around this, such as sending the email from a different provider, or changing something in the email or possibly making a business account with Gmail. Thank you for reading and responding to this!

The message I get back is as follows:

Your message to **********@tmomail.net has been blocked. See technical details below for more information.

The response was:

550 permanent failure for one or more recipients (**********@tmomail.net:blocked)

Final-Recipient: rfc822; **********@tmomail.net

Action: failed

Status: 5.0.0

Remote-MTA: dns; d79033b.ess.barracudanetworks.com. (209.222.83.70, the server

for the domain tmomail.net.)

Diagnostic-Code: smtp; 550 permanent failure for one or more recipients (**********@tmomail.net:blocked)

icon

Best answer by tmo_amanda 31 March 2018, 02:57

View original

19 replies

Userlevel 6
Badge +15

Hmm, this is really interesting and we appreciate you coming here to post this. We don't have any reports of this being an issue but I'm curious if you've had the chance to test this with any other email provider to see if the same things happens. Does this happen when you're sending just plain text or is there also an attachment in the email?

Hello Mike,

I too am having issues sending emails to tmomail.net. My clients are opted in to receive alerts, but some are getting bounce backs that say the email was rejected. I've checked and the domain I'm sending the emails from has a good SPF and DKIM and the content of the email has not changed recently. Can you help identify the issue on your end as to why my emails would be getting hung up? Below is an example bounce back message, I've replaced the number with "X".

   Error Type: SMTP

   Remote server (64.235.153.2) issued an error.

   hMailServer sent: .

   Remote server replied: 550 permanent failure for one or more recipients (XXXXXXXXXX@tmomail.net:554 rejecting banned content)

Userlevel 6
Badge +15

Sorry to hear you're having the same issue. Is this only happening when you try entering an email address in the BCC field?

No its happening everytime we try to email a t-mobile email to text address. The email we are sending from is notify@notify.votenza.net

Userlevel 4

Hey, @okin89​!

It sounds like we may need to get the email host whitelisted. Either way, this is something our Engineers need more info on to get it resolved. Please contact us via Customer Care or T-Force (via Facebook or Twitter) to file a ticket with Engineering.

Thank you for the reply. How do I open a ticket through Facebook? I already tried going through Facebook but they said the only thing they could do is point me to the forums, which is how I ended up here. How do I get that support team to create a ticket with the Engineers?

Just following up since I haven't heard back from you. How do I open a ticket through Facebook? I already tried going through Facebook but they said the only thing they could do is point me to the forums, which is how I ended up here. How do I get that support team to create a ticket with the Engineers?

Userlevel 4

@okin89​, I just verified with T-Force that they would indeed be the ones to file the ticket as we do not have access to file those tickets here on the Support Community. Can you try reaching out to them one more time, please?

These steps work, but… the problem I encounter is trying to “group” text. If I do 1 person they receive the msg, but as soon as I put them in a group.. NOTHING! Why???

I’ve also heard that they do not go through if a hyperlink is included in the message. That’s a question for T-Mobile that I’d love to have an answer on.

example.. xxx@tinyurl.com

I am unable to send email sms if there is no subject line included. Sending email sms with a subject line works.

 

Unfortunately for my purposes I cannot use a subject. Is this normal behavior?

I am sending alert messages from a NAS to email, and same issue.  I cannot include a subject line!  The NAS does not send with a subject line, therefore I do not get the SMS.  No URL to send to, must have a subject line to send a text (the receiver doesn’t get the subject line!!!)…  wow.  2022 is almost here…  Little behind there, T-Mobile….

I’m having a similar issue as well and hoping this gets resolved. I can send emails to my phone number using the tmomail.net and they show up in my messages, but if I reply or text to an email address the message never is received by the email account. This works on other carriers and phones I’ve tested, so it is explicitly a tmobile issue.

I am sending alert messages from a NAS to email, and same issue.  I cannot include a subject line!  The NAS does not send with a subject line, therefore I do not get the SMS.  No URL to send to, must have a subject line to send a text (the receiver doesn’t get the subject line!!!)…  wow.  2022 is almost here…  Little behind there, T-Mobile….

I’m curious how do you send the message from your NAS? I’m trying to do the same, but nothing I do gets it through to my t-mobile phone. Would love to get the details of what NAS you have and what tool you use on the NAS.

This doesn’t work number@tmomail.net . This feature always worked when I has Verizon. So many things don’t work with T-Mobile that did with Verizon. I am so mad I switched!

I’m  sending an email with a picture attachment using tmomail.net to send a text message to a phone.

When the text is received it says “Message expired or not available”

I’ve tried sending to my Moto g7 and Samsung S22.

If I send just text with no attachment it comes through. 

I can send the same email with picture attachment to another email account and it comes through.

Thoughts?

Userlevel 7
Badge +13

to large of a file?

fireguy -- that is a good thought.  I can send the email from my yahoo account to the tmomail.net and the pic attachment comes through so it doesn’t seem to be a size issue.

So I figured out the pic attachment, although I’m not exactly sure where the problem exists.   I was using a mail utility called ssmtp and attaching the files by first using uuencode.

I switched the mail utility to mutt and the picture now shows up in the text msg when using tmomail.net.  

I now have an issue with the csv file.  It is attached but shows up as an “Unsupported File”.  If I try to download and save, it just says couldn’t save 1 attachment.

 

emailed to 9999999999@tmomail.net and returned back undeliverable ……….

Your message couldn't be delivered. Despite repeated attempts to contact the recipient's email system it didn't respond.

Contact the recipient by some other means (by phone, for example) and ask them to tell their email admin that it appears that their email system isn't accepting connection requests from your email system. Give them the error details shown below. It's likely that the recipient's email admin is the only one who can fix this problem.

For more information and tips to fix this issue see this article: https://go.microsoft.com/fwlink/?LinkId=389361.

Reply