Question

T-Mobile Shows Hotspot Data Usage When it is Disabled in My Phone Settings

  • 22 November 2022
  • 30 replies
  • 2544 views


Show first post

30 replies

My two cents here… I too have this issue, among many others but to throw a wrench in this thread I have an iPhone, not an android. I don't use a VPN. And, I have a physical SIM as opposed to an e-SIM. So, it's not just the Android users that experience it. As for the comment regarding the engineers should be embarrassed by this, I agree and would add a laundry list of other reasons why the entire company should be embarrassed beyond measure. 

My problem with the hotspot "leaking" happened since I changed my new phone S24 from S22, so I think the new android OS may conflict with tmobile's hotspot configuration and it caused data usage increasing. I'll try the physical SIM instead of eSim. Will update.

Badge

I am having this same issue, and the customer service reps are just ignorant. I have a Samsung A52, and my account renewed 8 days ago and according to Tmobile I have used over 300GB of data. My phone usage says 13 and my laptop says 9. I only have my laptop connected and use it for streaming services. I havent even used it everyday. 

This is the 3rd time this has happened to me. I was previously a Sprint customer, that was automatically switched to Tmobile last summer. 

The last time this happened one of the agents was able to look at my usage while I was connected to it and reset it. Today, after 2 agents they wanted me to call them to speak with a tech. Even though I never spoke to one previously. I don't have the time or patience right now to try and understand someone's accent, and have to explain all over again that the usage they have doesn't match what I have. 

I will go back to the chat though and tell them they need to check their forums as there are many people with this issue for over a year now. 

I upgraded my phone to the 24U and chose to use ESIM. Had the same issues like everyone else, so switched back to physical SIM, which became a whole thing. It did not want to work at first and took way longer to setup (over an hour of customer support troubleshooting) than if I had just stuck with the physical SIM in the first place. I think that solved my issues, even though they tried to convince me that it couldn't be the problem.

Also, T-Mobile support, without my authorization, added a 10gb data add-on to my plan, even though I made it clear MANY TIMES that I did not want any upgrades or add-ons. The add-on was also not listed in managed add-ons and was 5 bucks more expensive than the one we can select for ourselves. Make sure you guys check your account activity as it tells you everything you and T-Mobile does to your account. Also, view your T-Mobile data usage and plan details frequently. Mobile hotspot usage category disappeared from my account after this whole debacle.

I've always sung support's praises since they're usually very helpful and professional, so I couldn't believe what they did to me. While troubleshooting with them not only did they downgrade my plan (which I had to make them correct since they claimed to not know my plan was upgraded FOR FREE from a Simple Choice 6gb to unlimited years ago) they added data without my permission.

For some reason, even though I have an unlimited plan, it still shows my original plan. Usage details does make clear it's an unlimited plan though. Make sure you guys save all your texts, emails, chats, and any other correspondents with them, ESPECIALLY when it comes to changes made. I still have the info from when my account was upgraded to unlimited, so it's grandfathered in, which is not great for them and their pursuit of making more money.

I'm disgusted and furious. If they mess with my account again, I'm closing it and making sure no one I know uses them. There's many more options now.

I am facing the same issue as well. I have raised a ticket with the customer care too. Hoping for some resolution. Did anyone here got any resolution from T-Mobile?

Reply