App Exchange Not Working

Userlevel 1
  • First activity
  • 0 replies

My App Exchange does not work and I’m trying to figure out why.  I hit the Get Started and it starts doing its thing and then I get this Error Messages: Failed SOC Check Unable to get SOC Information 213.


I check the Preflight Progress, and all checks except the SOC Check.


Also this morning, I’m having issues with my App: Service Unavailable.  F451: Uh-oh looks like we have our wires crossed.  Try again.


Anyone else having these issues?


I have the Samsung 22+

21 replies

I'm having the same issue on Galaxy A32!

Same here Note 9

Also here S10.  Originally a Sprint customer who received a message that I needed to set up a t mobile log in etc... That went well but when I tried to move from the my sprint app to the t mobile app I got the soc issue.  Tried rebooting my phone to no avail.  Attempted a chat with t mobile only to be put on "hold" so to speak for 5 minutes.  Why is there no readily available answer to a problem that has been happening for months?  Is it a Samsung issue?


My LifePo4GolfCart App is not working in my samsung S9 (T-Mobile Version) on the other hand the app working properly on Samsung S8 not known what’s the reason behind this….

Any update?

Userlevel 2

Hey T-Mobile! What's the deal? This is an ongoing issue and you have said nothing on this subject.


These people have it and so do I. Get some answers.


Userlevel 2



You moved my account from Sprint to this MESS! You need to get your App WORKING!




Enough of the stupid pet tricks OR turn the Sprint systems back on!


An angry customer!

Userlevel 1

I came here for an answer to this same question. Not seeing one, but seeing everyone else’s complaints, is disheartening!

Same issue on2  A32s. What gives? This is obviously an ongoing issue. When will it be fixed?

Same problem got a galaxy A51

Same on my S20FE5G

Userlevel 7
Badge +16

oddly enough if you look the one main thing all of you have in common are Samsung phones...have yet to see anyone with anything else other than a Samsung phone posting in here...

Same, getting the error on a galaxy 20+ - kinda stinks and not a good look after the switch. Some attention to this stuff would be nice.

Same s20

SAME HERE for my son's S9+

Same issue on Samsung S20+
Half my text get stuck and I need to reboot my phone to send them.

Same here on iPhone and Samsung. 


T-Mobile, where's an update on this?

Wow! This has been going on for months??!!! 

S22+ user here and same issue as the threads above. Note, that I went to that app bc after going thru the regular T-Mobile app I thought, "not possible that this is it!?!" All that app option seems to do is let you pay your bill. I get an error when even trying to SEE my bill. So, when trying to navigate thru that it says I have no network connection which is how I ended up in the T-Mobile Experience debacle. 

Looks like there's been plenty of time to resolve this issue. Maybe, at least tell us where to go to find a functional app for bill pay, seeing our usage details, etc, etc... All the things that Sprint let me see in their app, or what I'm sure Verizon offers their customers to see in their app. 

Most of T Mobiles  apps don't work anyway 

This is the same issue I'm having,  get with it t mobile!

I have S22+ and I am having same problem. Tmobile needs to fix all these problems.  I'm also having problem not being able to text one contact.  I did update and it worked for a couple weeks then went back to not being able to text.  Tmobile isn't reading these. They don't care. They get your money that's all they care about.