Solved

"LG IMS keeps stopping"


This started on one family member’s V30 yesterday and another today.

This affects more than one LG model.

Obviously T-mobile has changed something in the network.

See this thread here:

 

I have tried safe-mode, Disabling mobile data. Etc, etc. including all suggested on the internet and above thread with no success.

I would advise against making any changes until an official response is issued from someone with sufficient knowledge to understand what network-wide changes were made and explain how to correct the problem or how T-mobile intends to correct the problem.

I worked this issue for more than 8 hours today!

icon

Best answer by fidget37 22 May 2022, 23:37

View original

96 replies

Userlevel 3

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

 

The following instruct in your T-Mobile pdf link does not work on most LG phones because it is not listed as an option.

  • Select Download for ‘LG IMS Improved’ and wait for the update to complete.

Yet another false solution.

Userlevel 3

Solution #1

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

If that does not do it, make sure WIFI is off and stays off, reboot phone carefully, make sure WIFI is off and do Solution #2 and repeat Solution #1 again.

Solution #2

FIX

  1. DO NOT FACTORY RESET YOUR PHONE
  2. Turn off WIFI
  3. REBOOT PHONE (ensure WIFI didn’t restart or make it stay off in phone settings
  4. Go to settings →
  5. Apps/notifications ->
  6. App info ->
  7. Three dots ->
  8. Show System ->
  9. com-lge-ims-rcsprovider ->
  10. Storage
  11. CLEAR CACHE
  12. FORCE STOP  (After clearing CACHE)
  13. CLEAR DATA (This will not delete your texts)
  14. FORCE STOP  (After clearing DATA)
  15. Leave Settings. Popups should stop.
  16. Reboot. Popups should remain gone unless you turn WIFI back on.

GO BACK AND REPEAT SOLUTION #1

Userlevel 3

its both. TMO sent out a side update to all devices (Samsung, LG, etc)..the only OEM that ended up with an issue were mainly older LG devices..their test server never popped up any errors..only after the update was pushed...so on the TMO side all showed good to go… main reason why TMO and LG are working on it..for the older devices it was something not causing any issues but was an actual issue..for TMO their test system never detected the problem.

 

the side update was to improve network connections.

 

Here’s the updated instructions for the permanent fix from 5/27/22 if anyone still experiences the issue or wants to make sure they have the latest update:
 

T-Mobile's support team on Twitter told customers that it was aware of the issue and that it would release a fix soon. The problem has apparently been caused by a network-side system update rolled out by T-Mobile. The carrier discovered the bug only after the update was already deployed.

While the issue has now been fixed, it highlights the risk of continuing to use a smartphone that no longer receives support from the manufacturer.

UPDATE

T-Mobile has officially acknowledged the recent IMS bug that occurred on many LG phones after it pushed a network settings update.

Below are the steps to apply the fix:

  1. From your list of apps, tap the "Settings" gear.
  2. Either select "System" or choose the "General" tab.
  3. Choose Update Center > App Updates.
  4. Select "Download for LG IMS Improved" and wait for the update to complete.
  5. Press and hold the power key, then choose to restart your device.

 

THIS IS FALSE. NO SUCH STEP EXIST ON MANY OR ALL AFFECTED LG PHONES:

“Select "Download for LG IMS Improved" and wait for the update to complete.”

---and T-Mobile has not officially done anything. Call your Attorney General.

Badge +1

its both. TMO sent out a side update to all devices (Samsung, LG, etc)..the only OEM that ended up with an issue were mainly older LG devices..their test server never popped up any errors..only after the update was pushed...so on the TMO side all showed good to go… main reason why TMO and LG are working on it..for the older devices it was something not causing any issues but was an actual issue..for TMO their test system never detected the problem.

 

the side update was to improve network connections.

 

Here’s the updated instructions for the permanent fix from 5/27/22 if anyone still experiences the issue or wants to make sure they have the latest update:
 

T-Mobile's support team on Twitter told customers that it was aware of the issue and that it would release a fix soon. The problem has apparently been caused by a network-side system update rolled out by T-Mobile. The carrier discovered the bug only after the update was already deployed.

While the issue has now been fixed, it highlights the risk of continuing to use a smartphone that no longer receives support from the manufacturer.

UPDATE

T-Mobile has officially acknowledged the recent IMS bug that occurred on many LG phones after it pushed a network settings update.

Below are the steps to apply the fix:

  1. From your list of apps, tap the "Settings" gear.
  2. Either select "System" or choose the "General" tab.
  3. Choose Update Center > App Updates.
  4. Select "Download for LG IMS Improved" and wait for the update to complete.
  5. Press and hold the power key, then choose to restart your device.
Userlevel 7
Badge +14

its both. TMO sent out a side update to all devices (Samsung, LG, etc)..the only OEM that ended up with an issue were mainly older LG devices..their test server never popped up any errors..only after the update was pushed...so on the TMO side all showed good to go… main reason why TMO and LG are working on it..for the older devices it was something not causing any issues but was an actual issue..for TMO their test system never detected the problem.

 

the side update was to improve network connections.

I’m giving T-Mobile until the first part of next week (I doubt they even read our postings) and then I am going to look into switching to Verizon. I’ve been with T-Mobile 23 years and hate to leave but this is ridiculous. 2 LG phones on Verizon and no problem. Talked with a friend this afternoon with LG phone on AT&T and he hasn’t had a problem. I have 2 LG phone purchased from and on T-Mobile and they are both screwed up. Support says it’s a LG problem….that’s a load of garbage. They can fix it or lose customers. The stupid pop up on my phone goes off about every time I touch the phone now.

Mine stopped for 1.5 days and started up again last night & has continued popping up the message all day today. 

Did LG IMS error start up again for anyone else?  It stopped but just started up again today.

I’m convinced that the problem is T-Mobile and not LG regardless of what we are being told. My reasoning for this is simply that my wife has the exact same LG phone that I have which is on a Verizon account and she has no problems at all. A friend has a LG 60 on a verizon account and has no problems at all. I have 2 LG phones both on T-Mobile (for 23 years) and both have the annoying & repeated IMG not working or has stopped messages. T-Mobile says buy a different phone. I say “I bought these phones from you and have been with you for 23 years, FIX THEM. Note: It is much cheaper to switch carriers than to buy new phones and if you couldn’t keep them working on your network, you shouldn’t have sold them to me at your store in DeLand, Florida.

I found the fix on line (NO HELP FROM TMOBILE!) I called my “ T-Mobile team EXPERT representative” to get resolution, of course you’re speaking with someone in Asia who just gives lip service saying I was number one priority when they fix it. Asked to speak with an American (to hopefully get a more clear/honest/informed answer, but never received a call back, go figure). So went to a T-Mobile store and was told LG stopped pushing updates to their phones and I would just have to upgrade to a new phone (We have 3 of them that we bought through Tmobile). Their spring-loaded EZ answer since it’s not their money- just buy new phones.... Seems like T-Mobile should own some of this, been a customer for almost 20 years. T-MOBILE AMERICA, ARE YOU LISTENING? ***UPDATE- called customer care stated cancellation in the menu, was connected with a US rep. He said they would replace the phones for FREE with the N200 Nord One Plus. Documented that on my account so I can now go to a t-mobile store to look at the phone and swap them out.  

DO NOT start resetting phones, folks. This problem just hit my LQ Q7+ out of the blue. Assume a T-Mobile problem which they should fix w/o user intervention, or w minimal intervention. I stand to be proven wrong, but I'm betting w others who think TM messed something up.

This started on one family member’s V30 yesterday and another today.

This affects more than one LG model.

Obviously T-mobile has changed something in the network.

See this thread here:

 

I have tried safe-mode, Disabling mobile data. Etc, etc. including all suggested on the internet and above thread with no success.

I would advise against making any changes until an official response is issued from someone with sufficient knowledge to understand what network-wide changes were made and explain how to correct the problem or how T-mobile intends to correct the problem.

I worked this issue for more than 8 hours today!

I've had this problem all day (8hrs). Went to a physical Tmobile. They spent 30mins working on the issue and found no solutions. Hopefully Tmobile sees everyone having the same problem and issues a fix.

Don’t count on a solution from T-Mobile as they are now owned by ATT, my past experiences with them are dismal. This has worked for me as posted by another customer…..

Go to settings → Apps/notifications -> app info -> three dots -> Show System -> com-lge-ims-rcsprovider -> storage

Force stop and clear data.

This has fixed the issue for my mother’s v20.  At least for now…

At least it took away the 3 second pop up notice. However, I did shut down & restart and the messaged started popping up again. So I redid the above directions and the annoying pop up message has stopped,

Badge

Update: I see now that this same procedure was recently published by someone else. 

 

Had the same issue with an LG V30 -- tried some of the suggestions on this thread and they didn’t work. Called 611 and the rep gave me a solution that worked the first time I tried it. It continues to work after multiple reboots. 

  • Set airplane mode so that the messages stop plaguing you while you do the rest of these steps. 
  • Goto Settings->Apps & notifications->App info
  • Click the “...” menu in the upper-right corner and select “Show system”
  • Click on the app “com.lge.ims.rcsprovider”
  • Click on “Force stop”
  • Click on “Storage” and clear both cache and data. 
  • Repeat the previous 2 steps a couple of time (Force stop, clear cache, clear data).
  • Disable airplane mode.

Hope this helps others!

 

Marc

 

ok, just used the following suggestion:

SocialCatastrophe wrote:

Go to settings → Apps/notifications -> app info -> three dots -> Show System -> com-lge-ims-rcsprovider -> storage

 

Force stop and clear data.

 

This has fixed the issue for my mother’s v20.  At least for now…

 

At least it took away the 3 second pop up notice. However, I did shut down & restart and the messaged started popping up again. So I redid the above directions and the annoying pop up message has stopped,

Thank you thank you...seems to have stopped!!

 

Thank you so much this actually worked for my phone sing Android 9 on an Aristo4+.   

I woke up to this message on my LG 6 phone: “Unfortunately, LG IMS has stopped.”

I have tried everything, shy of a Factory Reset.  So frustrating!  Not sure what to do, if there’s anything I can do.  

Has anyone taken their phone with this issue to a T-Mobile Store to have it checked?  If so, what did they say about it?

 

 

T-mobile customer service said to wait for a system update. T-mobile store's only solution is to sell you a new phone. All t-mobile stores know how to do are swap sim cards and sell phones. No other knowledge what so ever.

I just figured out a solution. My wife and I have identical LG Thinq phones and hers was not affected. So I checked every setting to make sure all were matching and found a mismatch. The access point network was missing from mine with the lg ims keeps stopping issue. Go to network & internet> Mobile networks> Access point names> click three dots> Restore default settings. After clicking restore default settings, T-Mobile LTE fast.t-mobile.com appeared in Access point names along with the 4G LTE symbol in the top right corner. Internet, phone, text, and all apps are back to normal. Have a great day everyone!

I woke up to this message on my LG 6 phone: “Unfortunately, LG IMS has stopped.”

I have tried everything, shy of a Factory Reset.  So frustrating!  Not sure what to do, if there’s anything I can do.  

Has anyone taken their phone with this issue to a T-Mobile Store to have it checked?  If so, what did they say about it?

 

 

T-mobile customer service said to wait for a system update. T-mobile store's only solution is to sell you a new phone. All t-mobile stores know how to do are swap sim cards and sell phones. No other knowledge what so ever.

Userlevel 3

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

 

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

I just tried this and it did not work. :( 

To be clear, the PDF  solution in the link is iffy because it is poorly written. Carefully do the following after rebooting your phone:

Solution #1

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

If that does not do it, make sure WIFI is off and stays off, reboot phone carefully, make sure WIFI is off and do Solution #2 and repeat Solution #1 again.

Solution #2

FIX

  1. DO NOT FACTORY RESET YOUR PHONE
  2. Turn off WIFI
  3. REBOOT PHONE (ensure WIFI didn’t restart or make it stay off in phone settings
  4. Go to settings →
  5. Apps/notifications ->
  6. App info ->
  7. Three dots ->
  8. Show System ->
  9. com-lge-ims-rcsprovider ->
  10. Storage
  11. CLEAR CACHE
  12. FORCE STOP  (After clearing CACHE)
  13. CLEAR DATA (This will not delete your texts)
  14. FORCE STOP  (After clearing DATA)
  15. Leave Settings. Popups should stop.
  16. Reboot. Popups should remain gone unless you turn WIFI back on.

GO BACK AND REPEAT SOLUTION #1

Userlevel 2
Badge

Well, it was t-mobile all along as per this:

https://www.androidcentral.com/phones/t-mobile-issues-fix-for-ims-error-that-renders-many-lg-phones-useless

Even LGs 5G phones were affected.

Such a mess…..

Userlevel 3

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

 

This PDF from T-mobile is WRONG and misleading! You must CLEAR DATA not just clear the cache. The instructs are not clear on that. ALSO, airplane mode turns the WIFI off but it will come back on once out of AIRPLANE mode so simply turn WIFI off and keep off until matter is resolved or repeat the process.

The following resolves it all:

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

 

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

I just tried this and it did not work. :( 

Userlevel 3

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

 

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

I wrote to LG and they sent me the attached PDF instructions. I've performed it on both phones and it works until the phone is powered off. I'll contact them again.

Userlevel 1

Still working after about 10 hours.

I had to go through the entire routine THREE (3) times on both of my LG Q7+ to get the pop ups to stop. But, no longer a problem now. Thanks.

From your home screen, please go into Settings.

Under the Networks tab, and select Mobile Networks.

In this menu go to Access Point Names. Hit 3 dots. Hit Restore Default Settings.

You may see the option for Disable 2G and 3g.

This setting will disable 2G and 3g service on the device.

LTE enables and IMS may correct. 💯 

 

Leave feedback if I helped you. :)

Happy to help. 😊

Userlevel 3

"LG IMS has stopped working" popup

AFTER 2 DAYS TRYING TO FIX, i SUCCEEDED WITH THE ‘PARTIAL FIX’ DOING THE FOLLOWING:

NOTES:

  • i have two LG V20 Phones and Fix worked for both when following these steps precisely.
  • This fix is lost if you turn the WIFI back on or if phone is set to auto turn on when rebooting/turning on phone.
  • Fix was not lost once resolved by rebooting phone.
  • Fix does not seem to hinder phone operations other than WIFI must remain OFF. You can send & receive calls/texts with no popups.
  • If you need WIFI  for watching video, doing backups, etc., turn back on, but realize nuisance popup will resume and you will need to redo these below steps until T-mobile fixes the problem they caused.
  • Call your State Attorney General and insist on an investigation.

FIX

  1. DO NOT FACTORY RESET YOUR PHONE
  2. Turn off WIFI
  3. BEBOOT PHONE (ensure WIFI didn’t restart or make it stay off in phone settings
  4. Go to settings →
  5. Apps/notifications ->
  6. App info ->
  7. Three dots ->
  8. Show System ->
  9. com-lge-ims-rcsprovider ->
  10. Storage
  11. CLEAR CACHE
  12. FORCE STOP  (After clearing CACHE)
  13. CLEAR DATA (This will not delete your texts)
  14. FORCE STOP  (After clearing DATA)
  15. Leave Settings. Popups should stop.
  16. Reboot. Popups should remain gone unless you turn WIFI back on.

T-mobile still has not addressed this massive problem publicly as of Mon May 23 10:15pm ET.. Shameful and possibly criminal.

Still working after about 10 hours.

Reply