Mobile App locks up entering password

  • 5 August 2023
  • 16 replies


I’m having a weird issue with the T-mobile app on my iPhone 14, I can’t enter any password over 25 characters, when you can see the text, or the login screen for app freezes. It freezes up with only 20 characters when you don’t show the password.

16 replies


I was able to resolve my issue, by doing a Reset All Settings on the iPhone. I can now enter the full length of my password without locking up the T-Mobile app.

I’m having the same issue with my iPhone 13. 

I am having the exact same issue. Had it on my iPhone 14 Pro Max and now on my iPhone 15 Pro Max.

I’m having the same issue. Enter the PW and all locks up. If you go online it works. 

I am having the same issue, I do have 20 characters in pw, T-Mobile, please fix this issue

I’m having the same issue as well. It happens whether I type the password or paste it. 

When will T-Mobile fixed the app so that it will allow you to enter the full length of your password? This should’ve been caught in testing. They broke the app and only way to view account is to sign in using the web since password is allowed to be much larger

I have been having this issue for months, on my old iPhone 12 and 15. T-Mobile doesn’t seem interested in fixing it. I have to go through the web site log in not the app 

Same issue here with my password since updating to the T-Life app a week ago. Why is there a lockup when entering long passwords or pasting a long password?!!! Please fix this issue!

This happens to me as well. Web page works but app locks up upon entering password. 

I am having the same problem. 

Wow they have still not fixed it! Am still having the issue and I had tried so many things before I stumbled upon this thread sometime back! 

same issue, freezes on 7th character. Uninstalled, restarted, reinstalled no change.

plz some one answer this i am having the same issue

T-Mobile should allow copy/paste into their app.  This is how Bit Warden works.  Please fix.

 And no I’m not using ‘reset all settings’. The problem started when the phone was brand new.



Same issue with iPhone 14 accessing TMobile app and TLife app.  Unable to type in full password.  Not an issue on my iPad or my MBP.    Even the reps @ TMobile don’t know how to fix.