sending text to my cell phone using @tmomail.net no longer working?

  • 30 June 2023
  • 38 replies
  • 7858 views

Badge

it no longer works, please assist


38 replies

Userlevel 5
Badge +8

@BBiggi i don’t use it. But here is a thread talking about how to use it. Maybe the T-Mobile service is backed up?

I hope this helps. 

Badge

Mine stopped working as well. 

Userlevel 7
Badge +16

same goes for sending yourself an actual text. this was removed..not overly sure why..i liked to use it for diagnosing texting issues..but not a deal breaker..

Userlevel 5
Badge +8

Interesting - I just sent myself a text using the (my cell #)@tmomail.net address and it worked fine. Are you adding a “1” in front of your number? 

 

Userlevel 7
Badge +16

no i mean we used to be able to send ourselves a text to our own number and it would kick you a notification as if someone else texted you...no longer happens. used to use this for texting troubleshooting/grocery lists lol.

This service stopped working on 6/30 after 1:34 CST.  There are no bounce back/Undeliverable messages either.  It’s as if T-Mo’s server is just dropping them.

I verified I can receive mails when sent with GMail.  But not Yahoo, or my company’s mail.  

Userlevel 1
Badge

This service stopped working on 6/30 after 1:34 CST.  There are no bounce back/Undeliverable messages either.  It’s as if T-Mo’s server is just dropping them.

Around same day for me. I use this service for texting security alerts from cameras. Does no one at T-Mobile monitor their email to SMS gateways?!?

Service doesn’t work from either my google or outlook accounts. 

Userlevel 1
Badge

Looking at this more it would seem T-Mobiles email to sms server(s) have no IP information associated with the DNS record, so no way for mail servers to send to them. If it was working from some email clients that’s because the DNS info probably hasn’t yet aged out of their cache, but those clients will eventually stop working as well. 

This is why some clients are still working while others are not. This is basic Internet 101, it’s a bit shocking no one at T-Mobile is aware of this issue! 

dig  tmomail.net @ns10.tmobileus.com

; <<>> DiG 9.18.12-0ubuntu0.22.04.2-Ubuntu <<>> tmomail.net @ns10.tmobileus.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60699
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;tmomail.net.                   IN      A

;; AUTHORITY SECTION:
tmomail.net.            900     IN      SOA     anppol31.gsm1900.org. arintechcontact.t-mobile.com. 2006060883 3600 600 3600000 86400

;; Query time: 204 msec
;; SERVER: 208.54.147.200#53(ns10.tmobileus.com) (UDP)
;; WHEN: Thu Jul 06 11:19:28 EDT 2023
;; MSG SIZE  rcvd: 124

 

 

I have a ticket open about this, and I will contact T and let them know about what you found.

Looking at this more it would seem T-Mobiles email to sms server(s) have no IP information associated with the DNS record, so no way for mail servers to send to them. If it was working from some email clients that’s because the DNS info probably hasn’t yet aged out of their cache, but those clients will eventually stop working as well. 

This is why some clients are still working while others are not. This is basic Internet 101, it’s a bit shocking no one at T-Mobile is aware of this issue! 

dig  tmomail.net @ns10.tmobileus.com

; <<>> DiG 9.18.12-0ubuntu0.22.04.2-Ubuntu <<>> tmomail.net @ns10.tmobileus.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60699
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;tmomail.net.                   IN      A

;; AUTHORITY SECTION:
tmomail.net.            900     IN      SOA     anppol31.gsm1900.org. arintechcontact.t-mobile.com. 2006060883 3600 600 3600000 86400

;; Query time: 204 msec
;; SERVER: 208.54.147.200#53(ns10.tmobileus.com) (UDP)
;; WHEN: Thu Jul 06 11:19:28 EDT 2023
;; MSG SIZE  rcvd: 124

 

 

 

They closed my previous ticket.  I have new ticket # 74400152 opened about this

Userlevel 1
Badge

Actually I made a mistake with my dig command. I forgot to ask for the MX (mail exchange) record which is the email address of T-Mobile’s systems:

dig -t mx tmomail.net @8.8.8.8

; <<>> DiG 9.18.12-0ubuntu0.22.04.2-Ubuntu <<>> -t mx tmomail.net @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27536
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;tmomail.net.                   IN      MX

;; ANSWER SECTION:
tmomail.net.            309     IN      MX      10 tmo-east.mx.a.cloudfilter.net.
tmomail.net.            309     IN      MX      10 tmo-west.mx.a.cloudfilter.net.


;; Query time: 44 msec
;; SERVER: 8.8.8.8#53(8.8.8.8) (UDP)
;; WHEN: Sat Jul 08 08:17:09 EDT 2023
;; MSG SIZE  rcvd: 107


I own a Wireless Internet Service Provider (WISP) and using our commercial email servers I am able to send text message to myself.

From my own commercial email server

Jul  8 08:15:20 smtp2 postfix/smtp[857458]: BD36A8003A: to=<603xxxxxxx@tmomail.net>, relay=tmo-east.mx.a.cloudfilter.net[34.232.155.8]:25, delay=1.2, delays=0.03/0.01/0.38
/0.8, dsn=2.0.0, status=sent (250 2.0.0 I6qNqMmCvdLyJI6qOqEW9U mail accepted for delivery)


The above indicates T-Mobile sms/email server accepted the message and with a few seconds I got the text message on my phone, but from my outlook email I got back the following response:

Delivery has failed to these recipients or groups:

603xxxxxxx@tmomail.net (603xxxxxxx@tmomail.net)
Your message couldn't be delivered. Despite repeated attempts to contact the recipient's email system it didn't respond.

Contact the recipient by some other means (by phone, for example) and ask them to tell their email admin that it appears that their email system isn't accepting connection requests from your email system. Give them the error details shown below. It's likely that the recipient's email admin is the only one who can fix this problem.

For more information and tips to fix this issue see this article: https://go.microsoft.com/fwlink/?LinkId=389361.

 

Similar response from my gmail account it...almost seems like an aggressive email filter is in place with T-mobile.

You might want to update your ticket with this info. 

Still dealing with this ticket.  Same situation as described above.   I’m told this has been worked on by senior engineers at T-Mo.  Still can’t get to the bottom of it.

Our mail server is getting a “Sender_Rejected” message.  Can’t speak for Yahoo.

I too am experiencing issues with the email to text.  I use Home Assistant to send notifications about the house to the phone.  Stopped working beginning of July.  I see the sent item in the Gmail Sent folder, no errors. But doesn’t make it to the destination.  Interestingly, when I use a different gmail account, it goes through.  But from the other gmail account it does not.  Weird. Gmail to Apple device.

I’m having the same issue.  I only have the phone to get MMS alerts from our alarm system.  If they can’t fix soon this I’ll be shopping for a new carrier.

 

The alarm sends through a gmail account,  when I send an Email with the same attachment via my swbell Email account I get the MMS text on my phone.  I know the gmail account is sending the message because I have it bcc another Email account.

Hey id10ts at T-Mobile add a white list that we can edit for the Email to MMS gateway.  I assume after some number of similar messages they block the sender as spam.  STUPID!

They closed my previous ticket.  I have new ticket # 74400152 opened about this

How do you open one?   Or contact anyone at T-Mobile with a clue?

Userlevel 7
Badge +16

They closed my previous ticket.  I have new ticket # 74400152 opened about this

How do you open one?   Or contact anyone at T-Mobile with a clue?

calling in to TMO lands you with tier 1 support.

Facebook/Twitter lands you with tier 2 support.

 

i recommend the FB/Twitter route.

Badge

I’ve had to same problem but for months now.

Sending a text to:  ph# @ tmomail . net does not work any more!

So add my TMobile Ticket Number to all the others that are on this thread…
My ticket # is:
Thank you for being a valued T-Mobile customer! 
Trouble Ticket # 74559581 
has been opened on your account. Please allow 3 business days for teams to review. Resolution can take longer depending on the issue. 
 
I also just called TMO support and had them Add the URL for this TMO Community Discussion “Thread” to my Ticket so their Tier 2 can see its a lot of people having this same problem
 

magenta, 

what happens if you send to your number from a different email account?

In my case if I send from a different account it does go through.

ph#@tmomail.net from my gmail.com is like it never happened, from my swbell.net email account gets through fine.

Try it if you can. If yours also works from a different Email it provides more evidence that is is some kind of SPAM filter run amok, solution is simple, add a whitelist of email accounts we want Email to mms messages from, all other can be regarded as SPAM in my case.

Badge

To Everyone on this Thread and having this problem using email/gmail to send text messages to Tmobile phones using    ph_number @ tmomail.net

 

I had just opened my Ticket 3 days ago and just yesterday updated the Ticket notes with the URL to this thread to show how many people are impacted.

AND GUESS WHAT…   THIS IS NOW WORKING AGAIN !!


I just successfully sent a Text to my tmo phone using GMAIL and it went thru !

 

 

 

 

Userlevel 1
Badge

To Everyone on this Thread and having this problem using email/gmail to send text messages to Tmobile phones using    ph_number @ tmomail.net

 

I had just opened my Ticket 3 days ago and just yesterday updated the Ticket notes with the URL to this thread to show how many people are impacted.

AND GUESS WHAT…   THIS IS NOW WORKING AGAIN !!


I just successfully sent a Text to my tmo phone using GMAIL and it went thru !

 

 

 

 

Opening a ticket just to get my email account working is not a good way to resolve a systemic problem.

The issue is still present for me with Outlook and Gmail...using my business’ Internet email servers works fine. 

This is a much bigger problem that T-Mobile needs to address. Personally as an Internet Engineer myself, I find it troublesome it’s taking them this long to resolve the issue which started a month ago. 

My gmail address to tmo also stopped working beginning of July. (about the 5th or 6th)

Still not fixed for me, and now it is ever worse as sending from my swbell.net account which worked last week doesn’t work today.

It’s not working for me either.

I am experiencing the same problem also and I have tried sending from several different e-mail providers including gmail.

Reply