Solved

Texting issues when connected to WiFi

  • 28 August 2018
  • 77 replies
  • 52716 views


Show first post

77 replies

I've been having a lot of trouble with this at work.  In my office I don't get a good cellular reception but my phone is connected to WiFi.  However, I consistently have the problem where SMS won't send (thru Messages).  Sometimes they are just really slow and they eventually go thru, though on occasion they get dropped completely (especially pictures).  Sometimes turning WiFi on and off helps push them thru, sometimes it doesn't.  However, I might have finally found the fix.  I switched the WiFi calling preference from mobile network to WiFi.  After doing this, when I send an SMS it consistently sends within 1-2 seconds.  Prior to the change, they would be in the "sending" state for 5-10 seconds minimum or 30+ minutes in the worst case when they just weren't getting thru.   And for reference I have a Pixel 3.

To clarify, I've always had WiFi calling enabled.  The change today was to select which network it attempts to use first, WiFi vs. mobile.

I tried just about all of the suggestions with not luck. Weird combinations of issues. Could send text over wifi to some iphones not others; could never send text or pictures over wifi to ANY android phone; etc. Finally just reset my network settings and so far so good. I wonder of network setting accumulate changes over months or years and gets confused. Anyway... will let you know if it sticks.

I'm having the issue as well. Tech said account was set up correctly. 

 

I was able to solve a similar issue. While connected to WiFi, and good 4G LTE  signal, and receiving the error message "cellular network not available. Connect to WiFi for messaging?" while attempting to send texted and all other internet functionality seemed to be working. And yes. There was a question mark at the end, even though that's not a question. Pet peeve of mine.

Ih

I'vead the same phone for years, and I've been a T-Mobile customer for almost a decade. Never had this problem, and not sure why someone would leave a great network for such a minor issue. That's like leaving Ford because your car didn't start one day. Anyway, I had called T-Mobile support for an unrelated and during that process they had me reset my network settings. That's when it started happening. I came across this thread and hopefully this helps some folks...

Check Settings>More under Wireless Networks and see if WiFi Calling is disabled. If so, turn it on and change Connection preferences to "Cellular Network Preferred". Texts began to send normally, and I was even able to keep texting after changing Connection preferences back to "WiFi Preferred" and even disabling WiFi Calling entirely.

Also have this issue. Need to get off wifi and get into cell coverage for texts to work. Tried creating a new APN with prescribed settings, tried most of the content from this thread. No success as of yet. Pixel 4.

I can’t believe this is still an issue four years on. No wonder people are leaving this service in droves. I’m about to be one of them, since you obviously don’t care about your customers. And no, I will not go into further details - you have plenty after four effing years.

Joined T-Mobile for the first time last month, and have been having the same issue the entire time (on a Samsung Galaxy S22 with up-to-date software). SMS messages and pics do not come through when I’m connected to any WIFI network. I’ve chatted with TM tech support, called TM tech support, called Samsung tech support, chatted with Samsung tech support, who remotely logged in to my phone to have a look around and change some settings, etc.  I’ve changed so many settings, I don’t even remember where I started. Nothing has worked. Was thinking of dropping TM altogether.

Today I found a setting CONNECTIONS > DATA USAGE > MOBILE DATA ONLY APPS that I hadn’t previously seen (or been directed to by any tech support). This is described as “Sets apps to always use mobile data, even when your phone is connected to Wi-Fi”. I selected it, scrolled down to and selected Messenger. All SMS messages - text and pics - have been coming thorough in real time, even as my phone’s wi-fi is turned on. It’s only been a few hours, but that’s longer than any other “fix” I’ve tried.

And yes, this seems like an obvious solution; like I should have known to do this. But in all my years of owning a smart phone I’ve never had to change such a setting. And if it’s so obviously easy, why wouldn’t TM or Samsung have suggested it?

Mine’s greyed out. They’re literally preventing me from using Messenger on mobile data when connected to wifi. That’s it, I’m outta here. F TMO

I’ve been having the same problem for about 3 weeks. (As well as poor call quality. My call quality has been good for years)

Tech support said it may be my old SIM card. They sent me a new one but texting on Wifi is still not working. My wife’s phone can text over wifi.

We're have the same issue

I also developed the same issue recently. I recently purchased an unlocked Pixel 6 and transferred my SIM card between devices. I live in an area with no cell coverage and every time someone attempts to send me an MMS message, I cannot download the message until I either restart my phone (only works sometimes) or drive to an area with cell coverage.

developer options still working in December 2023. called something else now, though. check your phone info.

 

CS and tech support still don’t know how to troubleshoot properly. try this before calling.

I suspect that every 24 hours you’re allowed a certain number of SMS over WIFI. I suspect that after that’s exceeded, you’ll have to wait until the next day and you’ll see that magically you can text again.

Let’s just say I have a strong suspicion that the carrier makes money with each text over cellular and makes nothing over WIFI. 

Hypothetically were this true, the APN settings point to servers where these limits would be enforced.

 

Matthew this is kaleya call me 

Problem still not solved. I was a happy Sprint customer of over 15 years, got the T-mobile sim card and been unhappy ever since. This needs to get fixed !  People if your thinking about T-mobile DONT DO IT. I will be looking to change providers shortly.  I have 3 phones in my family 2 x s20g5’s and I-phone 12 plus. All 3 have issues and do not like the t-mo network.  :(  cold hard truth, and customer service force me to give this company a “0”  on the 10 scale !   

Userlevel 7
Badge +16

Matthew this is kaleya call me 

please hand someone else your phone or computer..no one has a clue who Mathew is in here.

Joined T-Mobile for the first time last month, and have been having the same issue the entire time (on a Samsung Galaxy S22 with up-to-date software). SMS messages and pics do not come through when I’m connected to any WIFI network. I’ve chatted with TM tech support, called TM tech support, called Samsung tech support, chatted with Samsung tech support, who remotely logged in to my phone to have a look around and change some settings, etc.  I’ve changed so many settings, I don’t even remember where I started. Nothing has worked. Was thinking of dropping TM altogether.

Today I found a setting CONNECTIONS > DATA USAGE > MOBILE DATA ONLY APPS that I hadn’t previously seen (or been directed to by any tech support). This is described as “Sets apps to always use mobile data, even when your phone is connected to Wi-Fi”. I selected it, scrolled down to and selected Messenger. All SMS messages - text and pics - have been coming thorough in real time, even as my phone’s wi-fi is turned on. It’s only been a few hours, but that’s longer than any other “fix” I’ve tried.

And yes, this seems like an obvious solution; like I should have known to do this. But in all my years of owning a smart phone I’ve never had to change such a setting. And if it’s so obviously easy, why wouldn’t TM or Samsung have suggested it?

It seems in 5 years tmobile has refused to solve this issue. Not surprising really. I started with Sprint, which was decent. It had its moments, however they always at least tried to make things right. Discounts for healthcare workers, discounts for length of service with them,  etc.

But tmobile just simply doesn't care. Exorbitant prices for absolutely horrible cell service and even worse customer service.

Userlevel 5

Do all the phones have this issue in the same wifi network?  Maybe the router is at fault.

This issue happens on all wifi networks. Home, gym, work. All secure and private networks. Same goes for all others.

So I’m having the same issue but it definitely only started once my phone, (not iCloud), storage became nearly full.  Memory is just about used up and now my texts won’t send on WiFi as well as browsers are slow and not loading/ all apps crashing… Ive has to delete and offload all apps…I def need an upgrade With more storage than 64.

Ignoring the other phones. What can be done to resolve my issue? It seems to be getting worse.

Matthew

Userlevel 4
Badge +9

If anyone has enabled power/battery saver, the app/setting often saves battery by disconnecting from wifi while it’s not in use. This can cause a problem if you send a text message before it can reconnect. I always set the battery saver and then choose to NOT disconnect from wifi (i.e. Custom setting), thereby, solving the problem I once had. :wink:

Userlevel 4

What specific phone are you using? Are you on one of the Samsung phones or on the iPhone? I want to see if the issue persists if we turn off Wi-Fi calling.

Hi,

I've been having the same problem for a year or more, but finally relying on texting enough to try to debug it! Regardless of wifi network I connect to, my ability to send or receive texts becomes very unreliable if I'm connected to wifi - phone will try for several minutes to download or upload a message before giving an error message. If I turn off wifi, I can then send/receive texts.

My phone is a Moto G5 Plus with Android 7.0. I'm using Messages for texting.

I have wifi calling turned on and set to "wifi preferred" - though I've just changed the latter setting to "cellular preferred" and will see in the morning if that helps. If not, my next step will be to turn off wifi calling and see what happens. Any suggestions will be appreciated!

Thanks,
Brian

Reply